Trying to make Intel Matix RAID 0 play nice with Mint 14.1

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Trying to make Intel Matix RAID 0 play nice with Mint 14.1

Postby soubuckeye on Mon Feb 04, 2013 9:10 pm

I have a 2007 vintage system running Windows Vista with a 500gb HDD in a RAID0 (2x250) configuration guided by Intel Matrix Storage.

The computer is having issues booting. Windows will BSOD quickly. Investigation shows that the 2nd device in the RAID array shows "failed." The cause - I suspect - COULD be a couple of power losses that took place in quick succession during recent weather - power lost, came back 30 seconds later, stayed on a minute, cut out, etc, several times. I've managed to get into Vista's safe mode a few times, but not long enough (without BSOD) to start moving files off the system. SO, as my emergency "Plan B," I am booting Mint 14.1 via USB Flash Drive. Ironically, I was in the process of obtaining an external HDD for backing up files, etc. (anticipating eventual failure on a system going on 6 years old!)

My plan has been as follows: Boot into Linux as emergency access to transfer files over network (or direct via USB) to another computer and the backup HDD. Then, remove the dying HDD, and replace or simply go with half the storage space.

I'm at the point where I am into Mint. However, when I look at the disk offerings, I see two 250gb HDD's, and neither of which I can access/mount/etc. Going the command line route, I've tried DMRAID. "-ay" gives me the "wrong number of devices" error (I presume because the stripe is currently seen as broken, which is the issue confessed with "-s". Using "-r" sits and thinks for a second then appears to have worked, but then going back the "-ay" route gives me the same problem. I'm following this route based on the following forum thread: ... _Fake_RAID I'm feeling like I'm at the end of my rope with what DMRAID can offer me.

Simply put, what would be the BEST way to have Linux "see" the fact that I already have a RAID set up via Intel Matrix Storage?

While I am certainly a Linux/Mint noob, I am a pretty quick study and have a bit of technical experience working with the guts of computers going all the way back to the hedy days of DOS. Command line instructions aren't lost on me, so don't be afraid to get down and dirty. :)

Thanks, everyone, in advance!

-Eric Shock
Level 1
Level 1
Posts: 1
Joined: Mon Feb 04, 2013 8:51 pm

Linux Mint is funded by ads and donations.

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], jungle_boy, Matthew Paul, Reorx and 29 guests