Mint 14 + Clevo Laptop (650M) + cant disable nouveau

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Mint 14 + Clevo Laptop (650M) + cant disable nouveau

Postby deso on Fri Feb 08, 2013 7:27 am

Hey friends,

i would really like to switch over to linux from using windows. But even with alot of googling i havent been able to install the proprietary nvidia drivers.

So far i tried using the following guide:
http://eternalvoid.net/tutorials/linux-optimus-gt650m/

but my problem ist that i cant disable the nouveau driver, no matter what i do. I already added the following lines to the /etc/modprobe.d/blacklist.conf file.

blacklist nvidia
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current-updates
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current
alias nouveau off
alias lbm-nouveau off

But if i do a lsmod combined with a grep for "nouv" i still receive:
david@david-W150ER ~ $ lsmod | grep nouv
nouveau 895609 0
ttm 83595 1 nouveau
drm_kms_helper 46784 2 i915,nouveau
drm 275528 6 i915,nouveau,ttm,drm_kms_helper
i2c_algo_bit 13413 2 i915,nouveau
mxm_wmi 12979 1 nouveau
video 19335 2 i915,nouveau
wmi 19070 2 nouveau,mxm_wmi

The main problem at the moment is, that if i connect my external 24" samsung Monitor to the laptop it badly "flickers" so that my eyes nearly start to cry. My monitor is recognized as 7" samsung electronic something by mint. My Monitor shows a resolution of 1920 x 1079.

Here is the output of my lspci:

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000e000-0000efff
Memory behind bridge: f6000000-f70fffff
Prefetchable memory behind bridge: 00000000e0000000-00000000f1ffffff
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 1550
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 650M] (rev a1) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 1550
Flags: fast devsel, IRQ 16
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel modules: nouveau, nvidiafb

Any help would be really appreciated. I already did alot of googeling before helplessly searching for help in a forum. I promise! :)

Greetz
deso
deso
Level 1
Level 1
 
Posts: 1
Joined: Fri Feb 08, 2013 7:12 am

Linux Mint is funded by ads and donations.
 

Re: Mint 14 + Clevo Laptop (650M) + cant disable nouveau

Postby arne-nl on Tue Feb 12, 2013 1:14 pm

Same problem here. On the nvidia trouble shooting page there is the following hint:

What if my initial ramdisk image contains Nouveau?

Some distributions, particularly recent Red Hat/Fedora distributions, include Nouveau in an initial ramdisk image (henceforth referred to as "initrd" in this document, and sometimes also known as "initramfs"), so that Nouveau's kernel modeset can take place as early as possible in the boot process. This poses an additional challenge to those who wish to prevent the modeset from occurring, as the modeset will occur while the system is executing within the initrd, before the directives in /etc/modprobe.d are processed.

If you have an initrd which loads the Nouveau driver, you will additionally need to ensure that Nouveau is disabled in the initrd. If your initrd understands the rdblacklist parameter, you can add the option rdblacklist=nouveau to your kernel's boot parameters. This should be done in your bootloader's configuration file(s), so that the option gets passed to your kernel every time the system is booted. Please consult your distribution's documentation on how to configure your bootloader, as different distributions use different configuration files.

An alternative is to rebuild your initrd without Nouveau. If you choose this option instead of configuring your bootloader, please consult your distribution's documentation on how to rebuild the initrd, as different distributions have different tools for building and modifying the initrd.


How do I prevent the X server from loading Nouveau?


Blacklisting Nouveau will only prevent it from being loaded automatically at boot. If an X server is started as part of the normal boot process, and that X server uses the Nouveau X driver, then the Nouveau kernel module will still be loaded. Should this happen, you will be able to unload Nouveau with `modprobe -r nouveau` after stopping the X server, as long as you have taken care to prevent it from doing a kernel modeset; however, it is probably better to just make sure that X does not load Nouveau in the first place.

If your system is not configured to start an X server at boot, then you can simply run the NVIDIA driver installer after rebooting. Otherwise, the easiest thing to do is to edit your X server's configuration file so that your X server uses a non-modesetting driver that is compatible with your card, such as the vesa driver. You can then stop X and and install the driver as usual. Please consult your X server's documentation to determine where your X server configuration file is located.


So I removed the nouveau drivers from X:
Code: Select all
sudo apt-get --purge remove xserver-xorg-video-nouveau


Create a new initramfs boot image:
Code: Select all
sudo update-initramfs -u


Reboot, press Ctrl-Alt-F1 to get a terminal, login and stop mdm:
Code: Select all
sudo service mdm stop


After this it should finally be possible to unload the kernel module:
Code: Select all
sudo modprobe -r nouveau


Indeed, now I could install the nvidia driver.

I would forget about the nvidia-xconfig, I have never seen anything good come out of it, just boot your system without the /etc/X11/xorg.conf file an X will sort it out.

But that was not all, *sigh* After reboot, I only had 640x480 resolution available. I installed bumblebee as per these instructions. That took care of that. But then the next issue: only cinnamon 2D. ~/.xsession-errors showed the following error:
Xlib: extension "GLX" missing on display ":0.0"


I happened to stumble upon this article, suggesting to reinstall X:
Code: Select all
sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64


Now when I type 'glxgears' in a terminal window, the gears appear. And using optirun ('optirun glxgears'), I get ~750 fps. And the power usage of my laptop was reduced quite considerably.
arne-nl
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 10, 2013 5:57 am

Re: Mint 14 + Clevo Laptop (650M) + cant disable nouveau

Postby Rita G. on Sat Mar 23, 2013 7:16 pm

So I removed the nouveau drivers from X:
Code: Select all
sudo apt-get --purge remove xserver-xorg-video-nouveau


Create a new initramfs boot image:
Code: Select all
sudo update-initramfs -u


Reboot, press Ctrl-Alt-F1 to get a terminal, login and stop mdm:
Code: Select all
sudo service mdm stop


After this it should finally be possible to unload the kernel module:
Code: Select all
sudo modprobe -r nouveau


Indeed, now I could install the nvidia driver.


Thanks arne-nl,

This was the only solution that worked on this particular computer.
Rita G.
Level 2
Level 2
 
Posts: 56
Joined: Tue Oct 14, 2008 5:32 pm

Re: Mint 14 + Clevo Laptop (650M) + cant disable nouveau

Postby mike_S on Thu Mar 20, 2014 3:48 am

But that was not all, *sigh* After reboot, I only had 640x480 resolution available. I installed bumblebee as per these instructions. That took care of that. But then the next issue: only cinnamon 2D. ~/.xsession-errors showed the following error:

Xlib: extension "GLX" missing on display ":0.0"



I happened to stumble upon this article, suggesting to reinstall X:
Code: Select all
Code: Select all
    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64



Now when I type 'glxgears' in a terminal window, the gears appear. And using optirun ('optirun glxgears'), I get ~750 fps. And the power usage of my laptop was reduced quite considerably.



Thank you, arne-nl. After several weeks of searching, this 'fix' finally worked.

mike
mike_S
Level 1
Level 1
 
Posts: 2
Joined: Thu Mar 06, 2014 4:44 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 29 guests