How to set F5 as refresh in Firefox [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

How to set F5 as refresh in Firefox [SOLVED]

Postby gibbs1984 on Sun Feb 10, 2013 7:03 am

For some reason the F5 button doesn't seem to refresh my browser window (doesn't do anything).

I think it is the only keyboard shortcut that doesn't work and I used to use it pretty often. I can still use the refresh button on the menu via the mouse but I like to use the F5 button.

Other buttons on my keyboard work correctly like the volume up and down, My Music, Mail etc.

Well actually the Web/Home button seems to bring up Nemo...

I can't see anything in Cinnamon Settings > Keyboard that changes the refresh behaviour in Firefox.

My keyboard is a Microsoft Wireless Multimedia Keyboard 1.1:

Image
Last edited by gibbs1984 on Sun Jun 01, 2014 9:10 am, edited 1 time in total.
Linux Mint 17 (Cinnamon) 32bit.
User avatar
gibbs1984
Level 5
Level 5
 
Posts: 672
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Linux Mint is funded by ads and donations.
 

Re: How to set F5 as refresh in Firefox

Postby karlchen on Sun Feb 10, 2013 1:24 pm

Hello, gibbs1984.

My system:
Linux Mint 14, 32-bit, Firefox 18.0.2, Cinnamon 1.6.7, mdm 1.0.8.
Keyboard: No-name Windows keyboard KB9810.

Checked it right now:
<Ctrl>+r as well as <F5>, pressed inside Firefox, will make Firefox refresh the current page. - Have not done anything special to make the two shortcuts work. They simply did do so out of the box.

Checked Cinnamon Settings => Keyboard => Keyboard Shortcuts: No shortcut found using <F5> systemwide for any action.

Therefore <F5> should not be intercepted by any other software as long as Firefox has got the input focus. - So more likely than not in your case there will be some software which registered <F5> systemwide and intercepts it so that Firefox has got no chance of reacting on it.

Kind regards,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3979
Joined: Sat Dec 31, 2011 7:21 am

Re: How to set F5 as refresh in Firefox

Postby gibbs1984 on Sun Feb 10, 2013 2:48 pm

karlchen wrote:Hello, gibbs1984.

My system:
Linux Mint 14, 32-bit, Firefox 18.0.2, Cinnamon 1.6.7, mdm 1.0.8.
Keyboard: No-name Windows keyboard KB9810.

Checked it right now:
<Ctrl>+r as well as <F5>, pressed inside Firefox, will make Firefox refresh the current page. - Have not done anything special to make the two shortcuts work. They simply did do so out of the box.

Checked Cinnamon Settings => Keyboard => Keyboard Shortcuts: No shortcut found using <F5> systemwide for any action.

Therefore <F5> should not be intercepted by any other software as long as Firefox has got the input focus. - So more likely than not in your case there will be some software which registered <F5> systemwide and intercepts it so that Firefox has got no chance of reacting on it.

Kind regards,
Karl

Thanks for the reply Karl.

I didn't know about Ctrl + r, just tried it and that shortcut refreshes the page so like you say some software must be using F5 as a shortcut, now the hard part I suppose. How do I track that down?

I looked for shortcuts in Firefox and from what I saw in the Preferences there was a tab for shortcuts but I can't see it now.

I'll go through all the shortcuts in Keyboard Shortcuts and see if I can see it.

The only thing I can think of is that when I used Compiz ages ago on previous versions of Linux Mint that it used F5 for something (I don't use Compiz since moving to Cinnamon).
Linux Mint 17 (Cinnamon) 32bit.
User avatar
gibbs1984
Level 5
Level 5
 
Posts: 672
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: How to set F5 as refresh in Firefox

Postby gibbs1984 on Sun Jun 01, 2014 8:43 am

So this problem still exists in Linux Mint 17 Cinnamon 32bit.

I remapped the F5 key to another shortcut and then remapped it to another key so the F5 key definitely isn't used by another shortcut.

It's like all of my F keys aren't recognised as shortcuts, the F5 key doesn't work in Nemo either. Just checked in Chrome and it doesn't work there either and I can't find any options in the Keyboard Shortcuts section to map a key to a Refresh option.

My other special keys like the Mail, Play, Stop etc buttons all work fine.

Does anyone know the command to setup the Refresh in Nemo/Firefox?
Linux Mint 17 (Cinnamon) 32bit.
User avatar
gibbs1984
Level 5
Level 5
 
Posts: 672
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Postby Zalbor on Sun Jun 01, 2014 9:00 am

Are you sure the F Lock key isn't activated?
Zalbor
Level 4
Level 4
 
Posts: 235
Joined: Tue Apr 19, 2011 11:53 am

Re:

Postby gibbs1984 on Sun Jun 01, 2014 9:09 am

Zalbor wrote:Are you sure the F Lock key isn't activated?

No of course not, it couldn't be something so simple as that :oops: :(

Thanks, that fixed it, didn't even know about the F Lock button :D
Linux Mint 17 (Cinnamon) 32bit.
User avatar
gibbs1984
Level 5
Level 5
 
Posts: 672
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], kc1di, Thermoman and 33 guests