huawei e1550 on mint 14

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

huawei e1550 on mint 14

Postby fouad on Thu Feb 14, 2013 2:07 pm

Dear Team,

I have an HP Compaq nc8430 laptop, with 3g of ram, i have always dremt of using linux and have now taken the step, i deleted windows and installed mint 14, the software is amazing, i just cant get internet to work.
i have a usb modem from huawei e1550, i did everything possible, but it is not recognized on the system, can someone please help me out?

I got it working now, but there is no interface to send sms to recharge and add bandwidth, any ideas? also i am unable to put the at sign in an email, where can i adjust this?
fouad
fouad
Level 1
Level 1
 
Posts: 1
Joined: Thu Feb 14, 2013 1:56 pm

Linux Mint is funded by ads and donations.
 

Re: huawei e1550 on mint 14

Postby nnamdi on Thu Sep 12, 2013 5:18 pm

please i have the same issue, i cant use my huawei e1550 modem on my mint 14, please how do i setup

thank you

Nnamdi
nnamdi
Level 1
Level 1
 
Posts: 3
Joined: Thu Dec 13, 2012 8:09 am

Re: huawei e1550 on mint 14

Postby administrollaattori on Fri Sep 13, 2013 2:23 am

Google tells.
Code: Select all
gksu gedit /etc/udev/rules.d/15-huawei-e1550.rules

and paste in the following code:
Code: Select all
SUBSYSTEM=="usb",SYSFS{idProduct}=="1446",SYSFS{idVendor}=="12d1",RUN+="/lib
/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"


Save the file and close the editor. Remove and re-insert the device. You should notice that service providers icon has popped up on the desktop – don’t worry about it as it is just the storage part of the device being recognized. Configuring the connection If you now click on the network-manager icon in the notification area, you’ll see a new option, “New Mobile Broadband (GSM) connection”

http://askubuntu.com/questions/73398/ho ... 550-dongle

An another tutorial:

/etc/udev/rules.d/15-huawei-e1550.rules file

Code: Select all
ACTION!="add", GOTO="huawei_zerocd_end"

 SUBSYSTEM=="usb", ATTR{bDeviceClass}!="ff" ,ENV{DEVTYPE}=="usb_device", GOTO="huawei_zerocd_disable"
 SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_device", GOTO="huawei_zerocd_disable"
 GOTO="huawei_zerocd_end"

 LABEL="huawei_zerocd_disable"
 ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd"

 LABEL="huawei_zerocd_end"


Now, save and exit. Next time when you plug in your USB modem, your system should automatically switch it to USB Modem mode and you’re good to go.

http://suhothayan.blogspot.fi/2010/10/h ... buntu.html
User avatar
administrollaattori
Level 6
Level 6
 
Posts: 1489
Joined: Tue Sep 03, 2013 4:51 am


Return to Newbie Questions

Who is online

Users browsing this forum: austin.texas, Bing [Bot], coolguy2k, H.Remedy and 27 guests