Always a Newbie

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Always a Newbie

Postby jimisbell on Sat Feb 16, 2013 4:59 pm

I will always be a newbie because I can never get this system running long enough to learn it.

I just tried downloading a .sh file that is supposed to install a program I want to use. BUT if I search for the downloaded file it tells me it is at home/ jim/downloads but when I go to home/jim/downloads it isnt there!!

Where is it putting downloaded files and why doesnt it ask where I want them to be put?
Democracy is two wolves and a sheep discussing what's for dinner. Freedom is a well armed sheep contesting the decision.
thefreerepublicat.wordpress.com
jimisbell
Level 3
Level 3
 
Posts: 116
Joined: Fri May 07, 2010 7:15 pm
Location: The Third Coast

Linux Mint is funded by ads and donations.
 

Re: Always a Newbie

Postby kyphi on Sat Feb 16, 2013 7:27 pm

Where downloaded files go to is determined by Firefox which puts them into a folder called "Downloads" by default (please note the capital D in the file name, Linux commands are case sensitive). If you want to change that, open Firefox, go to Edit, Preferences, General and change the "Save files to" field.
The correct syntax for you to go to the Downloads folder would be "/home/jim/Downloads" - that is assuming that you spell your name as "jim" rather than "Jim".
To run a .sh file, the command is "sh filename.sh
Qiana Cinnamon 64bit
User avatar
kyphi
Level 6
Level 6
 
Posts: 1066
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: Always a Newbie

Postby TheDynamicHamza21 on Sat Feb 16, 2013 9:33 pm

Also sh.files are hidden press ctrl h to view them or using the file manager view> show hidden files
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 780
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: Always a Newbie

Postby catweazel on Sat Feb 16, 2013 9:41 pm

TheDynamicHamza21 wrote:Also sh.files are hidden press ctrl h to view them or using the file manager view> show hidden files

Rubbish.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Always a Newbie

Postby TheDynamicHamza21 on Sat Feb 16, 2013 11:27 pm

TehGhodTrole wrote:
TheDynamicHamza21 wrote:Also sh.files are hidden press ctrl h to view them or using the file manager view> show hidden files

Rubbish.



I only have one .sh file in my home folder it's hidden.


EDIT: I didn't notice until now it my file starts with "." My mistake.
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 780
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: Always a Newbie

Postby jimisbell on Sun Feb 17, 2013 12:29 am

kyphi wrote:Where downloaded files go to is determined by Firefox which puts them into a folder called "Downloads" by default


Seriously? Firefox, the browser, actually determines the operating parameters of the operating system???? Really????
Democracy is two wolves and a sheep discussing what's for dinner. Freedom is a well armed sheep contesting the decision.
thefreerepublicat.wordpress.com
jimisbell
Level 3
Level 3
 
Posts: 116
Joined: Fri May 07, 2010 7:15 pm
Location: The Third Coast

Re: Always a Newbie

Postby jimisbell on Sun Feb 17, 2013 12:58 am

kyphi wrote:Where downloaded files go to is determined by Firefox which puts them into a folder called "Downloads" by default (please note the capital D in the file name, Linux commands are case sensitive). If you want to change that, open Firefox, go to Edit, Preferences, General and change the "Save files to" field.
The correct syntax for you to go to the Downloads folder would be "/home/jim/Downloads" - that is assuming that you spell your name as "jim" rather than "Jim".
To run a .sh file, the command is "sh filename.sh


yes it is jim in the computer, no cap

I changed it in Firefox to ask me where it goes.

But now, How do you run a file using sh <filename>.sh unless you are in terminal? If I go into terminal and try the command sh /jim/Downloads/thinkorswim_other_installer.sh I just get the message that it could not open /jim/Downloads/thinkorswim_other_installer.sh Maybe I mispelled something or was that not what you were suggesting?

I just checked the spelling, its fine. Here is the message I get:

jim@jim-N105 ~ $ sh /jim/Downloads/thinkorswim_other_installer.sh
sh: Can't open /jim/Downloads/thinkorswim_other_installer.sh
jim@jim-N105 ~ $
Democracy is two wolves and a sheep discussing what's for dinner. Freedom is a well armed sheep contesting the decision.
thefreerepublicat.wordpress.com
jimisbell
Level 3
Level 3
 
Posts: 116
Joined: Fri May 07, 2010 7:15 pm
Location: The Third Coast

Re: Always a Newbie

Postby TheDynamicHamza21 on Sun Feb 17, 2013 4:14 pm

Maybe you need change permissions right click the file,choose properties>Permissions ensure you are the owner and can read and write and make sure the box allow file as executing program is checked. Then all you have do click the file it will run.

Read step 4:
http://tradingwithlinux.blogspot.com/p/ ... buntu.html
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 780
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: Always a Newbie

Postby catweazel on Sun Feb 17, 2013 4:21 pm

TheDynamicHamza21 wrote:Maybe you need change permissions right click the file,choose properties>Permissions ensure you are the owner

<facepalm>
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Always a Newbie

Postby kyphi on Sun Feb 17, 2013 5:24 pm

Open a terminal and copy and paste the following line:

Code: Select all
cd ~/Downloads


That will change directory to the location of your downloaded file. The "~" is a shortened form of "/home/jim". Then, still in the terminal copy and paste:

Code: Select all
sh thinkorswim_other_installer.sh


If that does not produce the desired result, repeat the command with "sudo".
Qiana Cinnamon 64bit
User avatar
kyphi
Level 6
Level 6
 
Posts: 1066
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: Always a Newbie

Postby Webtest on Sun Feb 17, 2013 8:11 pm

A hiccup for Newbies ... you can NOT change the permissions on files in DOS formatted partitions (FAT 16 or 32). It isn't supported. If you want to mark a file as executable you have to store it on an ext formatted partition (generally ext2 or ext3). It took me a LONG time to figure that one out.

Blessings in abundance, all the best, & ENJOY!
Art in Carlisle, PA USA
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 4 GB - Mint 10 Gnome, Mint 13 Mate, Mint 15 Mate <on LOCKED Kanguru USB drives>
Webtest
Level 3
Level 3
 
Posts: 184
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: austin.texas, coolguy2k, Google Adsense [Bot], H.Remedy and 33 guests