Unable to mount location

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Unable to mount location

Postby philross on Fri Feb 22, 2013 12:18 pm

I have just installed Linux Mint and so far when I boot up or try to access the floppy disk, I get "Unable to mount locatioon" as a title then I get - Error mounting /dev/fd0 at /media/philross/disk: Command-line `mount -t "auto" -o "uhelper=udisks2,nodev,nosuid" "/dev/fd0" "/media/philross/disk"' exited with non-zero exit status 32: mount: /dev/fd0 is not a valid block device
.... basically the floppy doesnt work. I have edited the fstab file but that has done nothing - I would really appreciate some help.
Many thanks
Phil Ross
philross
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 12:13 pm

Linux Mint is funded by ads and donations.
 

Re: Unable to mount location

Postby viking777 on Fri Feb 22, 2013 2:57 pm

Try
Code: Select all
ls /dev/f*

Perhaps your floppy drive is not known to the kernel as fd0 but something else?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Unable to mount location

Postby philross on Sat Feb 23, 2013 5:35 am

Thanks for your reply.
I did input ls /dev/f* to get this response:

/dev/fb0 /dev/fd0 /dev/full /dev/fuse
/dev/fd:
0 1 2 3

does this help at all ?
Regards,
Phil
philross
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 12:13 pm

Re: Unable to mount location

Postby viking777 on Sat Feb 23, 2013 5:50 am

Not really, /dev/fd0 is there - I thought it might show something like /dev/floppy or some other option instead of /dev/fd0. I was wrong.

Here is a thought though. Do you have the application fdutils installed? If not get it from package manager. According to its docs it has these features:

The package includes the following items:

- superformat: formats high capacity disks (up to 1992k
for high density disks or up to 3984k for extra density
disks);
- fdmount: automatically mounts/unmounts disks when they are
inserted/removed;
- xdfcopy: formats, reads and writes OS/2's XDF disks;
- MAKEFLOPPIES: creates the floppy devices in /dev;
- getfdprm: prints the current disk geometry (number of
sectors, track and heads etc.);
- setfdprm: sets the current disk geometry;
- fdrawcmd: sends raw commands to the floppy driver;
- floppycontrol: configures the floppy driver;
- general documentation about the floppy driver.


A couple of those utilities might be of use to you. Of course I have no idea how to use this suite of tools as I don't have a floppy drive to test them on. Either the general documentation mentioned at the end or perhaps

Code: Select all
man fdmount

Code: Select all
man floppycontrol

After you have installed the package might help you.

There is also this:

http://ubuntuforums.org/showpost.php?p= ... ostcount=2
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Unable to mount location

Postby philross on Sat Feb 23, 2013 8:08 am

Thank you so much - I really appreciate it ... I'll let you know how I get on.
Phil
philross
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 12:13 pm


Return to Newbie Questions

Who is online

Users browsing this forum: ajgreeny, Bing [Bot], snoopy1881 and 28 guests