/configure problem with wz2100 3.1.0

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

/configure problem with wz2100 3.1.0

Postby calf on Sat Feb 23, 2013 9:22 am

Its been a long while since i used Linux and i where pretty much in but i have to admit i forgot alot and now i have this newbish issue i fail on actually, i hope you can help me by installing this sweet game

i actually have installed Linux Mint KDE 14 and saw they still have the 3.1 qt2 version what is way too old the newest one is 3.1.0 (final) and i only found a tar.xz version on the original site and no .deb or any other easy package

so i remember the good ol easy way: ./configure - make - install

and now iam stuck on a error message in the ./configure state and hope you can help me :oops:

Code: Select all
checking for rcc-qt4... no
checking for rcc... /usr/bin/rcc
checking for X... libraries , headers
checking whether to build NSIS installer... no
checking whether to compile in debug mode... no
checking whether the C compiler accepts the -Werror -Wno-switch flag... yes
checking whether the C compiler accepts the -Werror -Wno-enum-compare flag... yes
checking for SDL... configure: error: Package requirements (sdl >= 1.2) were not met:

No package 'sdl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SDL_CFLAGS
and SDL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Thanks for any help - i love this awesome game, its totally worth to try every final or beta version even its getting a "bit" old

greez calf
calf
Level 1
Level 1
 
Posts: 16
Joined: Sat Feb 23, 2013 9:13 am

Linux Mint is funded by ads and donations.
 

Re: /configure problem with wz2100 3.1.0

Postby bu99zy on Sat Feb 23, 2013 9:38 am

Do you have libsdl1.2 installed? You might need libsdl1.2-dev too.
User avatar
bu99zy
Level 3
Level 3
 
Posts: 135
Joined: Wed Jan 18, 2012 12:59 am

Re: /configure problem with wz2100 3.1.0

Postby calf on Sat Feb 23, 2013 11:07 am

wow after ALOT missing packages and "make" and "sudo make install" and "checkinstall" and the note of bu99zy its finally working - thanks alot :)

question: i now have a .deb file for wz2100-3.1.0 final - could i use this on any other pc (with 64bit) to install or is there anything i have to check on before ?

if not i would like share this one with all you guyz

- calf
calf
Level 1
Level 1
 
Posts: 16
Joined: Sat Feb 23, 2013 9:13 am

Re: /configure problem with wz2100 3.1.0

Postby bu99zy on Sat Feb 23, 2013 5:42 pm

calf wrote:wow after ALOT missing packages and "make" and "sudo make install" and "checkinstall" and the note of bu99zy its finally working - thanks alot


Thats great you got it working

calf wrote:question: i now have a .deb file for wz2100-3.1.0 final - could i use this on any other pc (with 64bit) to install or is there anything i have to check on before ?


Yes provided they are the based on the same distro release, mint 14 is based on ubuntu 12.10

calf wrote:if not i would like share this one with all you guyz


You could upload it on the mint app store, there is a game section.

http://community.linuxmint.com/software/browse/3
User avatar
bu99zy
Level 3
Level 3
 
Posts: 135
Joined: Wed Jan 18, 2012 12:59 am


Return to Newbie Questions

Who is online

Users browsing this forum: Havrebollen, meduser, Tikiman and 30 guests