ACPI shutdown/suspend

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

ACPI shutdown/suspend

Postby pteron on Sat Feb 23, 2013 1:20 pm

Hello everybody!

This is my first post so please let me know if I did something wrong and please excuse my bad English.
I've once again tried switching from Windows to Linux, this time to LM14 64bit, and for the first time I've found a distro that actually may replace Windows for me (yay!). I was able to reduce my "Linux-problems-that-make-me-want-to-switch-back-to-Windows"-list to under 10 items by neglecting my girlfriend for only a week or so, but there are still a handful problems that I want to fix before committing me to a long-term relationship with Linux - this one being on the in the top 3: ACPI-problems.

1) When pressing shutdown, my laptop does not power off. It just hangs at the black and white login-screen and I have to press the power button for a couple of seconds. It actually worked when I first installed LM but I suspect some of the updates from the Update Manager broke it.
2) When letting my laptop run out of battery it suspends as it should, but only for a couple of seconds and then wakes again. Then is suspends again and so forth. The suspend function works like a charm plugged in when I initiate it myself.

So I guess there is a problem with ACPI but I've never learned how to fine tune that stuff.
I've tried searching google and the forum and asking on IRC, but I could find a solution to my problem.


Here is some details on my system:
I'm using laptop-mode-tools and bumblebee with great success.

Code: Select all
System:    Host: vortex Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine:   Mobo: ASUSTeK model: N53SN version: 1.0 Bios: American Megatrends version: N53SN.206 date: 04/07/2011
CPU:       Quad core Intel Core i7-2630QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 2001.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz 5: 2001.00 MHz 6: 800.00 MHz 7: 800.00 MHz 8: 800.00 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA Device 0df6
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 9.0
Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network:   Card-1: Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlan0 state: up mac: e0:b9:a5:9c:d8:ec
           Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: down mac: f4:6d:04:3e:18:51
Drives:    HDD Total Size: 500.1GB (58.4% used) 1: id: /dev/sda model: Samsung_SSD_840 size: 500.1GB
Partition: ID: / size: 451G used: 272G (64%) fs: ext4 ID: swap-1 size: 8.49GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 1:38 Memory: 1158.9/7896.7MB Client: Shell inxi: 1.8.4


Sincerely
pteron

PS
My Linux skills are not that great, and I work the terminal like an old senile man so please bear with me.
User avatar
pteron
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 17, 2013 6:08 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher and 26 guests