gtk? python? printer manager?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

gtk? python? printer manager?

Postby baddog8it on Sat Feb 23, 2013 1:51 pm

Several things aren't working, and I'm sure it all probably boils down to one issue.

First noticed that my print information (system > admin >printing) wasn't working.

Tried 'mintupdate'. Got 'command not found' reply.

Next ran 'sudo apt-get remove --purge mintupdate', then 'sudo apt-get install mintupdate'.

That apparently went fine, then when I entered 'mintupdate', I received 'No module named gtk'.

Then did a 'sudo apt-get update'.

Received the following:
Ign file: binary/ InRelease
Ign file: binary/ Release.gpg
Ign file: binary/ Release
Ign file: binary/ Translation-en_US
Ign file: binary/ Translation-en
Ign stable InRelease
Ign natty-security InRelease
Ign katya InRelease
Hit stable Release.gpg
Hit stable Release
Get:1 katya Release.gpg [197 B]
Hit natty-security Release.gpg
Get:2 katya Release [16.5 kB]
Hit natty-security Release
Ign natty InRelease
Ign natty InRelease
Ign natty-updates InRelease
Ign natty InRelease
Ign natty InRelease
Hit stable/main i386 Packages
Ign stable/main TranslationIndex
Hit natty Release.gpg
Get:3 stable InRelease [2,979 B]
Hit natty Release.gpg
Hit natty Release.gpg
Get:4 natty InRelease [7,093 B]
Hit natty-security/main i386 Packages
Ign stable InRelease
Ign natty Release.gpg
Get:5 katya/main i386 Packages [8,581 B]
Hit natty-security/restricted i386 Packages
Hit natty-security/universe i386 Packages
Hit natty-security/multiverse i386 Packages
Ign natty-security/main TranslationIndex
Ign natty-security/multiverse TranslationIndex
Ign natty-security/restricted TranslationIndex
Ign natty-security/universe TranslationIndex
Hit natty Release
Hit natty-updates Release.gpg
Hit natty Release
Get:6 katya/upstream i386 Packages [16.0 kB]
Ign stable/non-free i386 Packages/DiffIndex
Ign natty Release
Get:7 katya/import i386 Packages [5,940 B]
Hit natty Release
Hit natty/main Sources
Ign stable/non-free TranslationIndex
Ign katya/import TranslationIndex
Ign natty/main i386 Packages/DiffIndex
Ign stable/main Translation-en_US
Hit natty/partner i386 Packages
Ign katya/main TranslationIndex
Ign katya/upstream TranslationIndex
Ign stable/main Translation-en
Hit natty-updates Release
Hit natty/main i386 Packages
Ign natty/main TranslationIndex
Ign natty/main TranslationIndex
Ign natty-getdeb InRelease
Ign natty/partner TranslationIndex
Hit natty/main i386 Packages
Hit natty/restricted i386 Packages
Hit natty/universe i386 Packages
Hit natty/multiverse i386 Packages
Ign natty/main TranslationIndex
Ign natty/multiverse TranslationIndex
Ign natty/restricted TranslationIndex
Ign natty/universe TranslationIndex
Hit natty/free i386 Packages
Ign natty-security/main Translation-en_US
Ign natty-security/main Translation-en
Ign natty-security/multiverse Translation-en_US
Hit natty-updates/main i386 Packages
Hit natty-updates/restricted i386 Packages
Hit natty-updates/universe i386 Packages
Hit natty-updates/multiverse i386 Packages
Ign natty-security/multiverse Translation-en
Ign natty-security/restricted Translation-en_US
Ign natty-security/restricted Translation-en
Ign natty-security/universe Translation-en_US
Ign natty-security/universe Translation-en
Ign natty-updates/main TranslationIndex
Ign natty-updates/multiverse TranslationIndex
Ign natty-updates/restricted TranslationIndex
Ign natty-updates/universe TranslationIndex
Hit natty/non-free i386 Packages
Hit stable/non-free i386 Packages
Ign natty/free TranslationIndex
Hit natty-getdeb Release.gpg
Ign katya/import Translation-en_US
Ign stable/non-free Translation-en_US
Ign katya/import Translation-en
Ign natty/non-free TranslationIndex
Ign katya/main Translation-en_US
Ign katya/main Translation-en
Ign stable/non-free Translation-en
Ign katya/upstream Translation-en_US
Ign katya/upstream Translation-en
Ign natty/main Translation-en_US
Ign natty/partner Translation-en_US
Hit natty-getdeb Release
Ign natty/main Translation-en
Ign natty/partner Translation-en
Err natty/main i386 Packages
404 Not Found
Ign natty/main Translation-en_US
Ign natty/main Translation-en
Hit natty-getdeb/apps i386 Packages
Ign natty/main Translation-en_US
Ign natty/main Translation-en
Ign natty/multiverse Translation-en_US
Ign natty/multiverse Translation-en
Ign natty/restricted Translation-en_US
Ign natty/restricted Translation-en
Ign natty/universe Translation-en_US
Ign natty/universe Translation-en
Ign natty-updates/main Translation-en_US
Ign natty-updates/main Translation-en
Ign natty-updates/multiverse Translation-en_US
Ign natty-updates/multiverse Translation-en
Ign natty-updates/restricted Translation-en_US
Ign natty-updates/restricted Translation-en
Ign natty-updates/universe Translation-en_US
Ign natty-updates/universe Translation-en
Hit natty-getdeb/games i386 Packages
Ign natty-getdeb/apps TranslationIndex
Ign natty-getdeb/games TranslationIndex
Ign natty-getdeb/apps Translation-en_US
Ign natty-getdeb/apps Translation-en
Ign natty-getdeb/games Translation-en_US
Ign natty-getdeb/games Translation-en
Ign natty/free Translation-en_US
Ign natty/free Translation-en
Ign natty/non-free Translation-en_US
Ign natty/non-free Translation-en
Fetched 54.3 kB in 10s (5,289 B/s)
W: GPG error: stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 082CCEDF94558F59
W: Failed to fetch ... 6/Packages 404 Not Found

Then tried 'sudo apt-get python'.

It kicked back:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Tried mintupdate again, and again received 'no module named gtk'.

Ran 'pydoc modules' and received:

ImportError: could not import gtk
ImportError: could not import gtk.gdk
/usr/lib/python2.7/dist-packages/zope/ UserWarning: Module test was already imported from /usr/lib/python2.7/test/__init__.pyc, but /usr/lib/pymodules/python2.7 is being added to sys.path
import pkg_resources
Fatal Python error: can't initialise module lpi

Any idea where to go?
Level 1
Level 1
Posts: 4
Joined: Sat Sep 10, 2011 8:14 am

Linux Mint is funded by ads and donations.

Return to Newbie Questions

Who is online

Users browsing this forum: shakugan05 and 33 guests