Windows / Mint 14 Shared Folder issue...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Windows / Mint 14 Shared Folder issue...

Postby darkstrike on Fri Mar 08, 2013 9:01 am

Hi folks!

I took the plunge and installed Mint 14 on my netbook as my primary OS, however, I'm hitting my head against a wall here trying to get Shared Folders working properly. I can access and read/write to Windows shares no problem, however, from Windows, I can see the Mint shared folder, but get the "You do not have permission to perform this action." error every time I try to create a new folder/file in it.

As far as I can tell, under the Shared Folder settings in the System menu, I've got all the settings correct - i.e it's the right directory, and it's NOT set to read only. The folder in question on my Mint install which I am trying to share is the "Public" folder in my home directory. All I've done is rename it to Shared Documents. If I check that folder's properties, I've got it's group permissions set to sambashare for the user and to "create and delete files."

Is there something I a missing to finally let me get reading and writing working properly??? :S
Last edited by darkstrike on Tue Mar 19, 2013 3:25 pm, edited 2 times in total.
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Linux Mint is funded by ads and donations.
 

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby altair4 on Fri Mar 08, 2013 9:40 am

Note: I'm assuming you are using Cinnamon since you did not specify.

Please post the output of the following commands:
Code: Select all
testparm -s

And just in case you also created a samba share directly from Nemo post the output of this one:
Code: Select all
net usershare info --long
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6138
Joined: Tue Feb 03, 2009 10:27 am

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Fri Mar 08, 2013 11:54 am

Hi Altair4,

Sorry for not specifying - I'm actually running XFCE, not Cinnamon and I use Nautilus as my primary File manager...?

I created the share by renaming the Public folder to Shared Documents, and then used the Shared Folders option in the System options under menu to make it shared.
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby altair4 on Fri Mar 08, 2013 11:58 am

Please post the output of the commands I listed above.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6138
Joined: Tue Feb 03, 2009 10:27 am

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Fri Mar 08, 2013 12:10 pm

I am at work at present, but I will try those commands and get back to you when I get home this evening after 5pm (AST)

Thanks!!
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Fri Mar 08, 2013 6:00 pm

Back home!

Here's the output you requested:

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Shared Documents]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
[global]
server string = %h server (Samba, LinuxMint)
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
idmap config * : backend = tdb

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
print ok = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[Shared Documents]
path = /home/darkstrike/Shared Documents
read only = No
guest ok = Yes
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby altair4 on Fri Mar 08, 2013 6:55 pm

Take a look at the permissions of the target directory:
Code: Select all
ls -dl "/home/darkstrike/Shared Documents"

The only way this will work with your configuration is if you allow everyone write access. Everyone on your network is coming across as "nobody" ( an actual user name ) so if the "ls -dl" does not come back with a "drwxrwxrwx" it won't work.

*** One option is to make it "drwxrwxrwx":
Code: Select all
chmod 0777 "/home/darkstrike/Shared Documents"

*** Another option is to make all your remote users appear to be you ( for that share ) by changing the share definition to this:
[Shared Documents]
path = /home/darkstrike/Shared Documents
read only = No
guest ok = Yes
force user = darkstrike

Then restart samba:
Code: Select all
sudo service smbd restart


Some unsolicited advice:

** I would get out of the habit of renaming your home subfolders. They are system generated based off a template and many programs and processes use different subfolders by default. Create a new subfolder instead.

** If you are going to create a folder it's best not to use spaces in their names. Use camel back notation: SharedDocuments or just use Shared.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6138
Joined: Tue Feb 03, 2009 10:27 am

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Fri Mar 08, 2013 11:18 pm

Hmmm....if I simply renamed the folder back to Public, would that fix any of the issues I've been having? If not, would there be any way to regenerate a "normal" Public folder in my Home directory? As it's a new install, I don't have anything anywhere in there anyway....

I DID have a successful test share set up with the LiveUSB I used when I was testing Mint on this netbook, pretty sure it was with the Public folder as well.

Is it just that I am trying to set up a share within my Home Directory that is causing the issue?

EDIT - I just noticed that Samba is disabled in the Services menu (and I didn't disable it!)...would that be causing the issue?
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby altair4 on Sat Mar 09, 2013 2:10 pm

EDIT - I just noticed that Samba is disabled in the Services menu (and I didn't disable it!)...would that be causing the issue?

Now you have me very confused.

There is no Services menu in Mint14 XFCE that I can find.
There is no Services menu in in the latest LMDE either.
The only Services menu I can find is in Mint14 MATE and quite frankly I have no idea what it's doing in there. Mine is disabled as well but smbd is running just fine. Regardless of what operating system you are using run one of the following commands to determine if samba is running:
For LMDE:
Code: Select all
sudo service samba status

For everyone else:
Code: Select all
sudo service smbd status
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6138
Joined: Tue Feb 03, 2009 10:27 am

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Sun Mar 10, 2013 12:12 am

altair4 wrote:
There is no Services menu in Mint14 XFCE that I can find.


On the desktop, Menu at the bottom left, then System, then Services...?

That command returns that my Samba is, indeed, working.

I did a fresh reinstall of Mint 14 XFCE again tonight and tried sharing the Public folder in my Home directory using the "Shared Folders" item under System in the Menu. Instead, no matter if I select Public in my Home directory, or Downloads, or what, it simply shares my WHOLE home directory as visible to the network and I still receive an incorrect permissions error when I try to move anything onto my Linux box from Windows...?

This is a fresh install, so apart from updates and installing some of the apps I use regularly, I've not changed anything else....starting to get stumped....am I doing something wrong here? As far as I can see, the method I am using seems pretty logical...? :(
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby altair4 on Sun Mar 10, 2013 8:43 am

I have been able to reproduce the latest of your symptoms. It appears to be a bug in "Shared Folders".

[1] Remove the share you created.

Menu > System > Shared Folders > Select "Click to make changes" > select "/home/darkstrike" > Delete

[2] Install the following package:
Code: Select all
sudo apt-get install system-config-samba

[3] Add the Public share

Menu > System > Samba > "+" > Basic Tab:
PublicShare.png

Access Tab:
Access.png

You created a share of your Public folder that allows guest read / write access.

[4] You are not done yet. Samba allows r/w access but Linux does not because the Linux permissions on the Public folder don't allow it.

You have 2 choices - the same one's I gave 2 days ago:

** Change permissions to allow others to access the folder:
Code: Select all
chmod 777 /home/darkstrike/Public

** Keep permissions as they were and make your guests look like you for that share:
Edit smb.conf as root:
Code: Select all
gksu gedit /etc/samba/smb.conf

Add a line to your share definition:
[Public]
path = /home/darkstrike/Public
writeable = yes
; browseable = yes
force user = darkstrike
guest ok = yes

Save smb.conf and restart samba:
Code: Select all
sudo service smbd restart
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6138
Joined: Tue Feb 03, 2009 10:27 am

Re: Windows / Mint 14 Shared Folder issue...all settings cor

Postby darkstrike on Sun Mar 10, 2013 1:24 pm

Altair!

You are my saviour, haha! :D

That worked like a charm - my shared folder is now working perfectly! Thanks for beins so patient with a Mint newbie! ;) :)
User avatar
darkstrike
Level 2
Level 2
 
Posts: 95
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Windows / Mint 14 Shared Folder issue...

Postby truthlesshero on Sat Apr 20, 2013 3:26 pm

I would like to thanks altair as well...this saved my ass for my htpc xbmc setup...almost completely going without windows now, hehe
truthlesshero
Level 1
Level 1
 
Posts: 9
Joined: Sat Apr 20, 2013 2:43 pm

Re: Windows / Mint 14 Shared Folder issue...

Postby TomMDS on Wed Jul 24, 2013 10:31 pm

Nice thread. I'm starting to wonder why we even have windows. Though not LinuxMint, Linux is the backbone of my home network and I'm not even looking back:

http://microdevsys.com/wp/htpc-backup-home-server-solution-using-linux/

And the sharing is brilliant:

http://microdevsys.com/wp/networking-sh ... ing-samba/

though it has it's fun moments:

http://microdevsys.com/wp/networking-sharing-folders-between-windows-and-linux-using-samba/3/

Hope it helps if you get stuck in the future.

Regards,
TomMDS
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 22, 2013 8:01 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 29 guests