{SOLVED} Device /dev/sdbX is already mounted at <PATH>

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

{SOLVED} Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Tue Mar 12, 2013 9:31 pm

I've set up my external USB drive to be mounted via fstab and shared via Samba and it is is working exactly as designed, however every local user that logs in gets a dialogue box stating that "Device /dev/sdb3 is already mounted at <PATH>' in mint14 using the MATE desktop. The drive partitions are mounted for each user and they are accessible by each user and my remote machines can connect to the samba share so all I want to do is make the annoying dialogue popups go away.

I am assuming there is a start-up script that runs after fstab that tries to mount these to a default mount point and I have searched several of the standard linux file that are typically used during startup and I will be danged if I can find what is running the secondary automount.

I have searched the forum and the rest of the internet and apparently I am the only one that has this complaint. :-)

Anyone have any tips where I look to kill off these messages/dialogue boxes?
Last edited by jawgrape on Wed Mar 20, 2013 5:32 pm, edited 1 time in total.
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Linux Mint is funded by ads and donations.
 

Re: Device /dev/sdbX is already mounted at <PATH>

Postby Zorba on Tue Mar 12, 2013 9:55 pm

You need to blacklist it :D but can you please post us the complete error message?
Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2336
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Tue Mar 12, 2013 10:13 pm

Device /dev/sdb3 is already mounted at /media/nas/rocks

and has an "ok" button to dismiss.

Blacklist it where?
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Re: Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Wed Mar 13, 2013 6:43 pm

well I've done a bit of research around the blacklisting and It that all revolves around blacklisting hardware modules and drivers. I was not able to find any resources that suggests blacklisting is appropriate for this particular problem, although if Brahim has more info about that I am all ears. :-)

Again I think I need a pointer to the process in mint that does the automounting outside of fstab. I am starting to wonder if I should be allowing the automounter (not fstab) that the system does to see if that suits my needs but I suspect that I won't get to choose the mount location and such, which I can probably let go of but what I am not willing to give up is deterministic behavior, due to the need to have a stable share and mount point.

Any other thoughts?
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Re: Device /dev/sdbX is already mounted at <PATH>

Postby bigj231 on Thu Mar 14, 2013 11:04 am

It could be that the automounter is trying to mount it. Try switching to a different virtual terminal and logging in there. If you don't see the error, it's probably within MATE/Gnome, and most likely the automount feature of nautilus/nemo.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Device /dev/sdbX is already mounted at <PATH>

Postby altair4 on Thu Mar 14, 2013 11:51 am

I've set up my external USB drive to be mounted via fstab ...

Post the line in fstab that you are using to auto-mount this partition.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6279
Joined: Tue Feb 03, 2009 10:27 am

Re: Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Thu Mar 14, 2013 4:59 pm

Code: Select all
UUID=51EDAE8D3061D8DF   /media/nas/rocks  ntfs    defaults    0   0


At one point I tried changing 'defaults' and split out the options that I wanted and included 'noauto' but it resulted in the exact same behavior. So I just reverted it.

In response to whether it's Gnome/Mate I believe it is, since that is where the dialogue box is popping up. I don't have remote users ssh'ing into this machine, which is how I interpreted the post.
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Re: Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Thu Mar 14, 2013 10:06 pm

I found this and tried it and it didn't work. Which could have been what brahim was refering to earlier in this thread.

http://unix.stackexchange.com/questions ... uring-boot
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Re: Device /dev/sdbX is already mounted at <PATH>

Postby jawgrape on Thu Mar 14, 2013 10:46 pm

A Solution Discovered:

This is a combination of a few things that I have read and tried but had failed to have the specific Mate combination.

So I know this works for my purposes in Mate 14

In terminal type:
Code: Select all
 $ mateconf-editor

This opens the mate config editor, where you can modify the defaults that the windows manager (caja in this case) abides by.

Goto:
Code: Select all
/>apps>caja>preferences
disable media_automount


fstab still works and stops the windows manager from attempting to mount the drive after fstab has already been consumed and run by mount.

This does however kill all other usb automount, so if you want other usb devices to be mounted on plug-in then this may not be the right solution. {Clarification: The USB devises do show up under Computer and just need to be clicked on to mount.}
jawgrape
Level 1
Level 1
 
Posts: 29
Joined: Tue Mar 12, 2013 9:10 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: all41, Mute Ant and 40 guests