samsung 355V4C laptop brightness not working (solved)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

samsung 355V4C laptop brightness not working (solved)

Postby roguefx on Fri Mar 22, 2013 9:16 pm

When I tried to install mint 14 on my Samsung 355V4C laptop (AMD A8 4500M) I found that the brightness was stuck at full and no controls would adjust it.
Fn + F2 or F3 not working, brightness applet not working, echoing backlight did not work.
Found a suggestion to set backlight via grub but this was to increase the brightness not decrease it and wasn't sure how to do the reverse.
Had to reinstall 3 times to undo the mess I'd ended up in.
Finally tried installing the linux catalyst driver but this didn't work initially until I found the link below.
I've copied the commands here incase anyone needs them.
The only problem with this is that you get some tearing when setting the brightness with the function keys but if you use the catalyst control centre in administrative mode there is no problem. I'll update this if there are anymore problems.
You may not need to install the linux headers 3.5.0.17 as my mint 14 already had that
Last time I tried the catalyst drivers I rebooted after installing and missed step 6 which appears to be crucial

1 Download the amd radeon driver from here
2 Run terminal and tupesudo apt-get install linux-headers-3.5.0-17-generic
3 Go to directory where you have downloaded the zip file of driver which might be /home/your_username/Downloads. Extract the zip file there. You will see a .run file.
4 Run command: sudo sh amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run
5 It will open the installer window. Now install the driver. After finishing it will ask you to reboot but don't.
6 Open a new terminal and type: sudo amdconfig --initial
7 Now reboot your system. Your brightness control will work fine.

Thanks to the link below I can use the laptop without sunglasses :D
http://askubuntu.com/questions/247145/brightness-controls-are-not-working-in-sony-vaio-with-amd-radeon-hd-7650
roguefx
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 18, 2013 6:38 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: baldrick.777 and 33 guests