Unable to open Synaptic, Update Manager or Package Manager

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Unable to open Synaptic, Update Manager or Package Manager

Postby 8AfterMint on Sun Mar 31, 2013 9:47 am

Hi all,
I couple of day ago , I changed both my apt.config and my bashrc files to work my university proxy and has since restored them. Since then I have not been able to open the above-method programs. There are no error messages they just don't start. If I open Synaptic via the terminal I receive the follow error message:
Code: Select all
E: Could not open file /var/cache/apt/pkgcache.bin - open (2: No such file or directory)
E: _cache->open() failed, please report.

as well as this in the terminal
Code: Select all
(synaptic:7643): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(synaptic:7643): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(synaptic:7643): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

if I try to open mintinstall via the terminal
Code: Select all
usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 28, in <module>
    from widgets.pathbar2 import NavigationBar
  File "/usr/lib/linuxmint/mintInstall/widgets/pathbar2.py", line 1025, in <module>
    class PathBarThemeHuman:
  File "/usr/lib/linuxmint/mintInstall/widgets/pathbar2.py", line 1038, in PathBarThemeHuman
    animate = gtk.settings_get_default().get_property("gtk-enable-animations")
AttributeError: 'NoneType' object has no attribute 'get_property'



Please help! it is very urgent.

Thanks
Mint 16 "Petra", Cinnamon 64-bit 2.0.14 Kernel 3.11.0-12 Dual Boot W8.1
Samsung NP550P5C Intel Core i7 @2.40GHz x 4 Ram: 8GB DDR3 Graphic Card: GeForce GT 630MA with Intel 3rd Gen Core processor graphics controller
User avatar
8AfterMint
Level 1
Level 1
 
Posts: 8
Joined: Wed Feb 27, 2013 4:53 pm
Location: Cape Town, South Africa

Linux Mint is funded by ads and donations.
 

Re: Unable to open Synaptic, Update Manager or Package Manag

Postby bigj231 on Tue Apr 02, 2013 11:21 am

So you can't use apt-get either? I guess you could try using dpkg to reinstall the apt components, but I don't know if that will work. Make a backup and start trying different things. A reinstall might be easiest though.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], markey164 and 38 guests