[SOLVED] Black screen after login

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[SOLVED] Black screen after login

Postby speeder1987 on Mon Apr 01, 2013 6:19 am

Hi guys,

I started up my computer this morning and basically got a black screen after logging in. Interestingly my desktop flashes up for a second, but if I move my mouse, then it goes black. I can still see and move my curser though. I've got a feeling this is either an xserver proplem, or a problem with the graphics drivers. I can ctr +alt + F1 into a console. A bit of info on my system, I'm running mint 13, with the mate wm, 64 bit with the proprietory nvidia drivers installed. I've tried some googling to solve the problem, (used lynx for the first time which is pretty awesome), but nothing seems to be helpful or particulary related.

I think what may have triggered the problem was installing steam, it asked for a dependancy to be installed with I think was the nouveau driver. Could this now be conflicting with the proprietry Nvidia driver somehow? I have the nouveau driver blacklisted. Should I remove it? I tried but couldn't find it using apt :oops:

If I run lspci - k, I can see that it is the nvidia driver being loaded, however the kernal modules loaded include the nouveau driver.

I haven't tried reinstalling the nvidia drivers yet, but I suppose that should be the next thing to try. It's difficult to track down the problem when I can't see any error messages.

Any suggestions on how to proceed with this?

Thanks in advance for any help

Cheers
John
Last edited by speeder1987 on Wed Apr 03, 2013 5:35 pm, edited 1 time in total.
speeder1987
Level 1
Level 1
 
Posts: 17
Joined: Thu Aug 23, 2012 5:28 pm

Linux Mint is funded by ads and donations.
 

Re: Black screen after login

Postby speeder1987 on Tue Apr 02, 2013 4:31 am

I tried reinstalling and removing the nvidia driver but I can't seem to do either, it states that the driver has been modified since installation, and none of the symlinks exist.

I also changed the xorg.conf file to use the nouveau driver. This time after login I could see my wallpaper and cursed but it wouldn't load past here

John
speeder1987
Level 1
Level 1
 
Posts: 17
Joined: Thu Aug 23, 2012 5:28 pm

[SOLVED] Re: Black screen after login

Postby speeder1987 on Wed Apr 03, 2013 5:35 pm

I managed to sort this problem, i'll list the solution incase it helps someone else. It was driver related as I first thought. I realised I had installed the nvidia drivers from a repository, which is why it was throwing errors at me when I tried to install it from the Nvidia script. I actually found that for some reason the Nvidia driver was no longer installed, so I reinstalled it using the repository and it worked fine ...

Cheers
John
speeder1987
Level 1
Level 1
 
Posts: 17
Joined: Thu Aug 23, 2012 5:28 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Buzzsaw and 21 guests