Cannot update mint

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Cannot update mint

Postby zeh3212 on Wed Apr 10, 2013 9:24 pm

Hello guys, as you can see i'm newbie with Linux mint, i really love this system, but i'm having some erros while i trying to upgrade it.

The error message is:
E: /var/cache/apt/archives/libwebkitgtk-3.0-0_1.10.0-0ubuntu1.1_amd64.deb: cannot copy extracted data for './usr/lib/libwebkitgtk-3.0.so.0.17.3' to '/usr/lib/libwebkitgtk-3.0.so.0.17.3.dpkg-new': unexpected end of file or stream





What can i do? Ty for attention!
zeh3212
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 10, 2013 9:09 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot update mint

Postby stanley82 on Thu Apr 11, 2013 3:56 pm

Upgrade usually refers to upgrade mint13 to mint14. Update brings all the stuff in mint13 to the latest and greatest. From the look of the message it was a bad file that you downloaded. Did you try a couple of times?
stanley82
Level 2
Level 2
 
Posts: 61
Joined: Sat Jan 28, 2012 11:01 pm

Re: Cannot update mint

Postby zeh3212 on Thu Apr 11, 2013 6:56 pm

yeah, i'm trying but without success =/
i've mint 14 by the way =P
ty for attention,
zeh3212
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 10, 2013 9:09 pm

Re: Cannot update mint

Postby cecar on Thu Apr 11, 2013 7:29 pm

Try:
Code: Select all
sudo apt-get -f install
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Cannot update mint

Postby zeh3212 on Thu Apr 11, 2013 8:08 pm

jose@Jose-PC ~ $ sudo apt-get -f install
[sudo] password for jose:
sudo: unable to open /var/lib/sudo/jose/3: Read-only file system
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.


with dpkg command:

jose@Jose-PC ~ $ sudo dpkg --configure -a
[sudo] password for jose:
Sorry, try again.
[sudo] password for jose:
sudo: unable to open /var/lib/sudo/jose/3: Read-only file system
dpkg: error: unable to access dpkg status area: Read-only file system




what can i do?
zeh3212
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 10, 2013 9:09 pm

Re: Cannot update mint

Postby cecar on Fri Apr 12, 2013 2:23 am

Hmmm.. Ok.. Then try this yhen.

Code: Select all
sudo rm -vf /var/lib/dpkg/lock

Code: Select all
sudo apt-get update && sudo apt-get upgrade
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], tdockery97 and 24 guests