Linux Mint Nadia 64bit can't install wine1.4/5

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Linux Mint Nadia 64bit can't install wine1.4/5

Postby Leonov246 on Thu Apr 11, 2013 2:46 pm

Hi. First Post. Forgive me if it shouldn't be here.

I'm trying to install wine on 64 bit linux mint, which seems to be a problem as of late. Google gave me a number of solutions, which haven't solved the problem. Here is the digest version.

I tried to install wine, and get:

Code: Select all
>> sudo apt-get install wine
[sudo] password for ****:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


So I try to install wine1.5, but get something only slightly different:

Code: Select all
>> sudo apt-get install wine1.5
...(same as last time)

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.27-0ubuntu1)
E: Unable to correct problems, you have held broken packages.


On a suggestion from another post, then, I added the i386 repositories:

Code: Select all
>> sudo dpkg --add-architecture i386


Then performed an update and an upgrade:

Code: Select all
>> sudo apt-get update

Code: Select all
>> sudo apt-get upgrade


after this I tried to install the missing package, but get another error:

Code: Select all
>> sudo apt-get install wine1.5-i386
...

The following packages have unmet dependencies:
 wine1.5-i386:i386 : Depends: libglu1-mesa:i386 but it is not going to be installed or
                              libglu1:i386
                     Recommends: libasound2-plugins:i386 but it is not going to be installed
                     Recommends: libosmesa6:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


So I tried to install this missing mesa package, and get:

Code: Select all
>> sudo apt-get install libglu1-mesa:i386
...

The following packages have unmet dependencies:
 libglu1-mesa:i386 : Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


So I finally think I've got an answer, but it is too good to be true:

Code: Select all
>> sudo apt-get install libstdc++6:i386
...

The following packages have unmet dependencies:
 gstreamer0.10-plugins-good : Depends: libcaca0 (>= 0.99.beta17-1) but it is not going to be installed
                              Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or
                                       libjack-0.116
                              Depends: libsoup-gnome2.4-1 (>= 2.27.4) but it is not going to be installed
                              Depends: libsoup2.4-1 (>= 2.26.1) but it is not going to be installed
                              Depends: libtag1c2a (>= 1.5) but it is not going to be installed
 libstdc++6 : Breaks: libstdc++6:i386 (!= 4.7.2-5) but 4.7.2-2ubuntu1 is to be installed
 libstdc++6:i386 : Depends: gcc-4.7-base:i386 (= 4.7.2-2ubuntu1) but 4.7.2-5 is to be installed
                   Breaks: libstdc++6 (!= 4.7.2-2ubuntu1) but 4.7.2-5 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


So, if I'm reading this right, my problem is, at the core, a conflict between i386 standard c++ libraries and the 64bit c++ libraries. I'm at a loss at this point. Can anyone help?
Leonov246
Level 1
Level 1
 
Posts: 1
Joined: Thu Apr 11, 2013 2:22 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], WharfRat and 29 guests