Login screen not appearing on monitor

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Login screen not appearing on monitor

Postby Babbles on Sat Apr 13, 2013 5:04 am

When I boot Linux Mint 14 up on my docked laptop - the login screen displays on the closed laptop screen, not the monitor. So in order to login, I have to open the laptop, click the username box, close the laptop, type my username, tab, password, return to login.

Once past the login screen, it correctly displays content only on the external monitor.

Does anyone know how I can make sure that Mint correctly ignores the laptop screen when the laptop is closed during login? The system shows the bios and bootloader info on the monitor correctly, it's just when it comes to login that I have a problem.

Any ideas?
Babbles
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 02, 2013 10:45 am

Linux Mint is funded by ads and donations.
 

Re: Login screen not appearing on monitor

Postby Benevolent27 on Thu Dec 12, 2013 9:25 am

I'm having this exact problem with Linux Mint 16 64-bit.

I put my laptop out of the way when I hook it up to a monitor (due to limited desk space or it's connected to a tv), so it's a real chore getting it out just to select my username. I've looked all around the web for a solution and have not been able to find one. It seems like the login manager for earlier versions of Mint could run a script upon boot, but for MDM, I just can't find any solutions. It seems to me like the display settings are only applied once a person logs in and if there is a way to run a script upon the log-in screen coming on, I haven't found it yet. If anyone could help, I'd appreciate it.

I'm not sure what information may be needed, so here's my info:
My computer is a Dell Vostro 1500 and has a Nvidia 8600-GT (mobile).
I am using the nvidia-319 drivers.
The external monitor is set as the primary and laptop screen is set to off in the "Displays" and in the "NVIDIA X Server Settings"
The lid is shut during boot and there are no bios setting for changing monitor output.
I am currently running the output to my TV via a VGA output.

And here is my xrandr info:
Screen 0: minimum 8 x 8, current 1280 x 720, maximum 8192 x 8192
VGA-0 connected primary 1280x720+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
1920x1080 60.0 +
1680x1050 60.0
1600x900 60.0
1440x900 59.9
1400x1050 60.0
1360x768 60.0
1280x1024 60.0
1280x800 59.8
1280x720 60.0*
1152x864 60.0
1024x768 60.0
800x600 60.3
640x480 59.9
TV-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected (normal left inverted right x axis y axis)
1680x1050 60.0 + 60.0
Benevolent27
Level 1
Level 1
 
Posts: 2
Joined: Thu Dec 12, 2013 8:32 am


Return to Newbie Questions

Who is online

Users browsing this forum: othmans and 28 guests