Firefox for Linux Mint

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Firefox for Linux Mint

Postby krickit on Mon Apr 22, 2013 2:28 pm

My question is about the new tab page.
Whenever I click to open a new tab, I am taken to: <link disabled, this is a browser virus!!!> www dot cherchi dot biz
I don't want this as my new tab homepage.
I tried "New Tab Homepage". Found HERE, but it only worked for a few days.
I also tried to change changing it via the "about:config" page. This had no effect at all.
If anyone has some uefull advice, I woud greatly appreciate it.

Thanks in advance . .
krickit
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 22, 2013 2:14 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox for Linux Mint

Postby xenopeek on Mon Apr 22, 2013 3:50 pm

I've disabled the link in your post, as this is a browser virus and we don't want others to get it by visiting that page. Do an Internet search for that website, and you would have found this out yourself. There are various websites describing how to remove it, though all I found have a focus on Windows. Perhaps though this will work: http://techvts.com/remove-cherchi-biz-virus

Do you perhaps have Firefox sync active, or another way to synchronize settings with a browser on Windows? Then your Windows computer will have this virus.

To hopefully easily remove this browser virus, if the above link doesn't help, it is to start with a clean Firefox profile. First step; close all your Firefox windows. Then, open your file manager and press Ctrl+H to show hidden files. Find the .mozilla folder in your home folder and rename it to something else (mozilla-old or something similar). Start Firefox again and test that if you open a new tab it now works as expected. If that works, you may open bookmarks from the menu and select to import bookmarks. Browse to the mozzila-old (or what you renamed the .mozilla folder to) folder, go into firefox, go into <something>.default, and finally into bookmarkbackups. I suggest you load a bookmarks backup from a date you know for sure you didn't have this browser virus. Cookies, passwords and add-ons will have been lost by this action and I suggest you don't recover add-ons. Watch out with installing add-ons, as this browser virus would have been loaded through one of the add-ons you installed yourself as far as I understood it.

I hope you can clear it up this way :|
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15497
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Firefox for Linux Mint

Postby krickit on Wed Apr 24, 2013 3:38 pm

I apologize for the link. I didn't even think about that when I posted it. I do not have sync set up on this system. This is a work only laptop. The company I work for is a military contractor, so as you can imagine, I don't get online very often with this machine. Any device that we plug into these machines have to be scanned and approved daily before we are allowed to use them. So I know I didn't get this from work. I own this machine, but I am not allowed to have any personal data on it. Nor am I allowed to use it for casual browsing on the internet.
I'll keep looking into this matter until I find a solution. I have been given a temp replacement machine by my employer, so I can work on this until I do figure it out. I will post results here when I do.
krickit
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 22, 2013 2:14 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 20 guests