No sound at all in mint 15 detects card though

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

No sound at all in mint 15 detects card though

Postby psylent on Mon Jul 22, 2013 6:25 am

I'm having an issue where the sound jusoundcore 12680 1 snd
st does not play at all. The 'test' buttons don't even light up to show they are trying to play a sound.

I have checked alsamixer on the CLI and disabled the automute, also checked that all volumes are up there on all sound cards detected.
I have tried installing the packages from daily build alsa HDA (http://ppa.launchpad.net/ubuntu-audio-d ... aily-dkms/) but am unsure which one to choose (i've tried raring so far).

Also i have totally removed pulseaudio and it's packages, and alsa and it's packages and re-installed them all using apt-get.

the output of lsmod |grep sound :
[list=]soundcore 2680 1 snd[/list]

the output of lspci | grep -i audio :
[list=]00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)[/list]

output : inxi -f
CPU: Quad core Intel Core i7-3630QM CPU (-HT-MCP-) cache: 6144 KB
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz 3: 1200.00 MHz 4: 1200.00 MHz 5: 1200.00 MHz 6: 1200.00 MHz 7: 1200.00 MHz 8: 1200.00 MHz
CPU Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts
acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good
nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid
sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm
tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms

In the sound manager (i'm using Mint 15 cinnamon), I can see HDMI / Display port (GK107 HDMI Audio Controller)
HDMI / DisplayPort (Built-in Audio) and
Speakers (Built-in Audio)

I have volume controls, the function volume controls on the keyboard work, everything 'looks' like it's working but there is no sound in any application or system sounds at all.

The system i am using is an Alienware m14x R2 (it does use Nvidia Optimus) - I have not installed bumblebee as yet. This is a fresh install with no changes other than updates and the procedures I have tried above.

I have edited the alsa-base.conf multiple times with different specs (PCH / generic / dell / and so on).

Funny thing, I tried ubuntu, it worked with sound but wouldn't load X because of some problem with the graphics setup, so i loaded sabyon and it worked but had problems with broken dependencies (which i just couldn't resolve), so i tried fedora, it worked but had issues with steam / games so it hought mint was a happy medium being buntu based should work with steam well etc, but now it has problems with the sound....

So i'm a bit frustrated with it all at the moment, it's been days on end of googling things, installing uninstalling / changing distros etc... I'm just after something that I can install , will use the hardware i have, and go from there. I don't mind playing with things like huawei modems / sd slots etc, those things I expect to be tricky, but simple things like display driver / sound driver / HDD read write / SAMBA... would be nice if just one distro could install without problems :(

anyway, /rant. Any help would be appreciated because i really don't want to go through another session of distro swapping.
User avatar
psylent
Level 1
Level 1
 
Posts: 7
Joined: Sat May 29, 2010 7:31 am

Linux Mint is funded by ads and donations.
 

Re: No sound at all in mint 15 detects card though

Postby Resistor on Mon Jul 22, 2013 12:28 pm

The sound problem may be a kernal bug from Ubuntu 13.04.
A lot of people have no sound and have not found a solution.
I stumbled across this Debian solution last night. It did not seem to work.

I suspended over night and this morning, I have sound.
I was doing several things at the same time, so I'm not sure this is the one that worked.

The HDMI / DisplayPort Built-In Audio still does not work.
I now have a new generic device listed in the second position:
Speakers, Built-in Audio.

I do not know what the 'nano' is about, since I have no folder by that name, that I have seen.
I just went straight to /etc/modprobe.d/alsa-base.conf

So, this might be worth a try...
Code: Select all
 nano /etc/modprobe.d/alsa-base.conf


Then, add the following line:
Code: Select all
 options snd-hda-intel model=generic


Save, reboot.
Windows 8 is gone.
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Rapid Start Technology2, Intel Centrino Wireless-N 2230.
WDC 500 GB Hard drive, SATA ODD HL-DT-ST DVD+/-RW
mSATA SSD PM830 32GB.

LM 17 Qiana v2, Cinnamon
Resistor
Level 2
Level 2
 
Posts: 88
Joined: Wed Nov 03, 2010 12:04 am

Re: No sound at all in mint 15 detects card though

Postby tuxer9823 on Sat Sep 14, 2013 1:13 pm

thanks.worked fine for me.
tuxer9823
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 14, 2013 1:08 pm

Re: No sound at all in mint 15 detects card though

Postby lawrencemaria on Thu Jan 23, 2014 6:38 am

Tried this solution.
No -it did not breathe back the sound to my laptop speakers (linux mint 16 kde 64bit on Sony Vaio vpcz138gg)
Audio however comes through only headphones!
------------------------------------------------------------------
Maria Lawrence
lawrencemaria
Level 1
Level 1
 
Posts: 39
Joined: Tue Nov 15, 2011 4:43 am
Location: Rome, Italy


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Bryan88 and 29 guests