Laptop WILL NOT resume after lid close/suspend

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Laptop WILL NOT resume after lid close/suspend

Postby ARCHE7YPE on Sun Aug 11, 2013 4:45 pm

Hi guys! I'm back on Mint after a month of problems with the notorius Execute Disable Bit thinking my Mint partition trying to run malicious code!

After a month of tedious to-ing and fro-ing I've flashed the bios with an update and everything is back to normal. I have wiped my hard drive and decided to start afresh with Mint 15.

Very impressed with the improvements so far, but one thing is really bugging me.

When I close the lid, or it suspends due to inactivity or battery level, it outright refuses to come back on. The power button lights up, but there is nothing at all on the HDD indicator. The screen has nothing at all either, not even the backlight. I have no choice but to hard power off, which can't really be doing it much good (although with no HDD activity I'm not overly concerned)

Is this a known problem? It seemed to work fine when running Windows 7 after flashing the bios and reinstalling it.

It's not a dealbreaker as I'll just leave it on or shut it down, but when I get caught with my pants down in regards to the battery, or my wife does the normal thing of just closing it, it makes it a tad awkward.

Any ideas would be much appreciated.

I'm running Mint 15 x64 on a Samsung RV520 - 2nd gen i3 2.2GHz - 8GB RAM and 500GB HDD if this helps at all.

Thank you all for your time!

Joe
ARCHE7YPE
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 02, 2013 1:39 pm

Linux Mint is funded by ads and donations.
 

Re: Laptop WILL NOT resume after lid close/suspend

Postby Spearmint2 on Sun Aug 11, 2013 4:59 pm

Try key combos CTRL-ALT-F1 followed by CTRL-ALT-F8.

Check /etc/fstab and make sure the swap UUID agrees with the one for swap displayed by this command. Then open the Resume.conf file and make sure it matches too.

Code: Select all
blkid


or

Code: Select all
parted -l


https://wiki.debian.org/Hibernation#Cha ... _partition

"Changing or moving the swap partition

In case you need to change the swap partition, apart from updating /etc/fstab, you must also change /etc/initramfs-tools/conf.d/resume and execute
"

Code: Select all
apt-get install --reinstall initramfs-tools
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
Spearmint2
Level 7
Level 7
 
Posts: 1598
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Laptop WILL NOT resume after lid close/suspend

Postby ARCHE7YPE on Sun Aug 11, 2013 5:20 pm

Thanks for the rapid reply!

Ok, this is a new one to me. I've been using Linux for a few years, but I'm just going to make sure I'm doing things right.

My fstab file reads this....
Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=288868a4-fcbc-46dc-8740-1fd9e98632ff /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#UUID=b2a04b80-2bef-4bc6-a235-ffbf952ca550 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0


Which, to me at least, looks like it's thrown an error on remount.

Secondly, when putting blkid into terminal it gives:
Code: Select all
/dev/sda1: UUID="288868a4-fcbc-46dc-8740-1fd9e98632ff" TYPE="ext4"
/dev/mapper/cryptswap1: UUID="5a7eb871-6f14-41a3-81e8-50157c187d22" TYPE="swap"


Which looks accurate, apart from mentioning sda5 in fstab.

Its not much that I can give you, but from that information there (and before moving on to partition changes) do you think that it may be causing the issue?
ARCHE7YPE
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 02, 2013 1:39 pm

Re: Laptop WILL NOT resume after lid close/suspend

Postby ARCHE7YPE on Sun Aug 11, 2013 5:53 pm

I forgot to mention that Resume.conf cannot be found anywhere, even in the full system search. Ominous...
ARCHE7YPE
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 02, 2013 1:39 pm

Re: Laptop WILL NOT resume after lid close/suspend

Postby Spearmint2 on Sun Aug 11, 2013 6:22 pm

Looks like you put an encryption program on there which commented out the old swap location or UUID and took it over for the encryption swap. This is the new UUID for the old swap that is now encrypted.

Code: Select all
UUID="5a7eb871-6f14-41a3-81e8-50157c187d22"


run this;
Code: Select all
sudo pluma /etc/default/grub


enter the information needed on the
GRUB_CMDLINE_LINUX="resume=***************"
replacing the asterix with the path to the swap file or the UUID according to the info given below. Then run

Code: Select all
sudo update-grub


information;
https://wiki.archlinux.org/index.php/Su ... _Hibernate
https://wiki.debian.org/Grub#Configuring_grub_v2
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
Spearmint2
Level 7
Level 7
 
Posts: 1598
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Laptop WILL NOT resume after lid close/suspend

Postby ARCHE7YPE on Wed Aug 14, 2013 1:55 pm

Hi there, thank you for the further information. Sorry for the delay in replying, I've been doing some long days at work recently.

Ill be sure to try this tonight and let you know how it goes.

Thanks again for your input!

Arc
ARCHE7YPE
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 02, 2013 1:39 pm

Re: Laptop WILL NOT resume after lid close/suspend

Postby ARCHE7YPE on Wed Aug 14, 2013 3:52 pm

Thank you, thank you thank you!

You genius! This has fixed the issue for both Windows and LM15! It must have been an issue with grub after all that. Simply adding the encrypted UUID to the grub file fixed it right off the bat.

Thank you so much for your time. I'm truely honoured to be a part of this fine community.

Do we use a rep or kudos system here? I'd like to fire a +100 your way!!!

Cheers.

Arc.
ARCHE7YPE
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 02, 2013 1:39 pm

Re: Laptop WILL NOT resume after lid close/suspend

Postby Spearmint2 on Wed Aug 14, 2013 9:12 pm

aw shucks, I shud be blushing, lol. :wink:

I really wish they'd fix that so it would quit breaking for everyone.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
Spearmint2
Level 7
Level 7
 
Posts: 1598
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: andrewsmith, helloimustbegoing, Reorx and 32 guests