Elyssa: reluctant boot: Please help!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Elyssa: reluctant boot: Please help!

Postby T J Tulley on Sat Jun 28, 2008 2:03 pm

Yesterday I was happily setting up my newly installed Elyssa-r1 and today it repeatedly showed Busybox when I tried to boot. I feared that my editing of /etc/fstab had been fatal - but not so: after a day of trying to edit from Daryna and failing, it suddenly booted while I was trying to locate an .iso CD to install again! Grub simply timed out on its first option - I normally press Enter.

My screen was as I had set it up yesterday, except that one partition shown in fstab failed to mount. Here is my edited /etc/fstab:
theo@TJT4Elyssa / $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdb2
UUID=de22ad7a-2475-42cd-ae63-60c6460ccb74 / ext3 relatime,errors=remount-ro 0 1
# /dev/sdb4
UUID=da306c85-75a5-458a-b0cd-27779cb72477 /home ext3 relatime 0 2
# /dev/sdb3
UUID=cf721c13-6670-49e3-95a4-ef51eb7787af none swap sw 0 0
# /dev/sdc6
UUID=8b0c2f05-167c-4a4f-a0f2-0a0bebb28cfa none swap sw 0 0
# /dev/sdd9
UUID=879da11d-4d05-4c1c-8a60-dbc03454f2ac none swap sw 0 0
LABEL=(E)DI8:H7R /media/sdb1 ntfs defaults,umask=007,gid=46 0 1
LABEL=(Q)DI7:H7N /media/sdc2 ntfs defaults,umask=007,gid=46 0 1
LABEL=(R)DI8:H7R /media/sdc3 ntfs defaults,umask=007,gid=46 0 1
LABEL=Backups /media/sdd1 ntfs defaults,umask=007,gid=46 0 1
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

and here is the initial state of the system:
theo@TJT4Elyssa / $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sdb2 4.9G 2.3G 2.4G 50% /
varrun 502M 216K 502M 1% /var/run
varlock 502M 0 502M 0% /var/lock
udev 502M 124K 502M 1% /dev
devshm 502M 52K 502M 1% /dev/shm
lrm 502M 38M 464M 8% /lib/modules/2.6.24-16-generic/volatile
/dev/sdb4 30G 489M 28G 2% /home
/dev/sdb1 41G 23G 18G 56% /media/sdb1
/dev/sdc2 41G 18G 23G 45% /media/sdc2
/dev/sdc3 41G 23G 18G 56% /media/sdc3
gvfs-fuse-daemon 4.9G 2.3G 2.4G 50% /home/theo/.gvfs

which shows that /dev/sdd1 failed to mount,although it is called by /fstab.
[This is an ntfs partition; it has no label apart from that allocated in /fstab. The other labelled partitions had their labels created in Windows - no longer possible. Of course, the command e2label only works for ext2 & ext3 formats]

Since booting today I have mounted that partition - it now shows on the screen as 43.5 GB Media, and evidently "belongs" to me as I can edit it. But its Properties show it as a folder, the Perkissions tab shows: "The permissions of sdd1 could not be determined", and under the Volume tab the following appear: "Label: (blank), Size: 40.5 GB, Media: Hard Disk, UUID: 2044A85E4B03DE64" (typical for an ntfs partition), "File System: ntfs (3.1), Mount Point: /media/sdd1, File System: fuseblk. Mount Options: rw nosuid nodev noatime relatime user_id=0 group_id=0 allow_other, Settings" [All boxes blank]

BTW, I had to mkdir /media/sdd1 again although I had already done that yesterday.

I shall be most grateful for advice about getting this setup to behave as I want; also, most important, how do I avoid repeated Busybox appearances? Can I use any of the Busybox commands to resume booting? Is my difficulty related to those Mount Options? Where can I learn about changing them if so?

I've just looked in Linux Mint Wiki, and the only reference is in a post about True Crypt: "It appears that using the sync mount option (typing "sync" in the mount options field under preferences) prevents the stall, the transfer speed however gets pretty bad."

The HDs are b,c & d instead of a,b & c: I haven't seen anyone else commenting on this. To me it seems to be an illogical and annoying change. Why has it happened?
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Re: Elyssa: reluctant boot: Please help!

Postby MasterYoshi on Mon Jan 05, 2009 9:05 pm

Just a thought, but maybe "Backups" needs to be in parentheses, with something like "DI8:H7R" after it, making the line look something like:
Code: Select all
LABEL=(Backups)DI8:H7R /media/sdd1 ntfs defaults,umask=007,gid=46 0 1
I was just looking to see what was different from the other partitions. I really don't know much about this, and maybe somebody else can confirm.

--MasterYoshi
MasterYoshi
Level 1
Level 1
 
Posts: 4
Joined: Fri Jan 02, 2009 4:24 pm

Re: Elyssa: reluctant boot: Please help!

Postby T J Tulley on Tue Jan 06, 2009 8:25 am

Wow!That was a long time ago!

Thanks, MasterYoshi. The Busybox problem was ultimately solved (in a later installation of Elyssa - number 6!) by a suggestion to modify the kernel line in /boot/grub/menulst, and my Elyssa worked happily after that until I installed Felicia last week. The later installation of Elyssa happened with my hdds designated as sda, b, and c which is logical.

See my post "About BusyBox - NOW solved!" in Newbies forum, July 16 2008-5:08 p.m. for description of the solution. That's a long correspondence - the first reply to my original post contains the solution, but I must have made a mistake at the first try.

I have not experienced BusyBox in Felicia, but as it is again showing my hdds as sdb,c, and d I fear trouble at some stage.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England


Return to Newbie Questions

Who is online

Users browsing this forum: jackuars and 29 guests