LM15 Cinnamon Korean Language keyboard help

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

LM15 Cinnamon Korean Language keyboard help

Postby IceRapture on Fri Aug 23, 2013 9:05 am

Good day,

I need help toggling the keyboard input method between Korean (한글) and english.

I've been trying to figure this out for a few weeks now, researching people who have had similar issues, asking for help on IRC with no success as of yet, and this seems to be more challenging than it sounds.

I am running Linux Mint 15 Cinnamon on 2 different laptops, one was installed and natively set up in English and I added and updated the Korean language packs, and the other was installed and natively set up in Korean with the English language packs added and updated.

Neither machine will type in Korean.

-So far, I have changed keyboards via System Settings>Regional Settings - 'Layouts' tab - and added both 한국어 and 한국어 101/104 key keyboards
both only type in english. And while here, I chose 'Options' and selected a few keyboard shortcuts to change the layouts.
-I tried something with ibus, but I wasn't completely sure of what I was doing
-I tried something with 'Input Method Configuration im-config'
-I tried changing the settings via System Settings>Languages (this is also where I updated/added the language packs)
-one thing to note, when I viewed the keyboard layout on the screen, it did not show Korean characters either.

Thank you in advance for your assistance
IceRapture
Level 1
Level 1
 
Posts: 1
Joined: Fri Aug 23, 2013 1:22 am

Linux Mint is funded by ads and donations.
 

Re: LM15 Cinnamon Korean Language keyboard help

Postby xenopeek on Fri Aug 23, 2013 10:54 am

I've figured it out for another member using Linux Mint 15 KDE earlier: viewtopic.php?f=109&t=132951. I've just confirmed the steps for Linux Mint 15 Cinnamon myself, summarized below.

  1. Install the needed IBus packages (it will pull in some more packages, those you also need):
    Code: Select all
    apt install ibus ibus-hangul
  2. In the Preferences category of your menu you should now find "Keyboard Input Methods". Start that.
  3. As asked, confirm that you want to start the IBus Daemon. Next it will give you some information for if IBus doesn't work. Next it will open IBus preferences. Go to Input Methods tab and check "Customize active input methods". Then click the selection box below that, click on Korean, and to the right of that now click Hangul. Click on the Add button on the right. You are now done with configuration.

Notice the small keyboard icon on your panel in the status area. You can click it for changing input methods in active applications that have keyboard input and that support IBus. In such applications you can also press Ctrl+Space to toggle IBus. With IBus enabled, you type in Korean. With it disabled, you type in English. For example, open Gedit, and in Gedit type Ctrl+Space to activate IBus (or select Korean from the panel icon). You will then start typing in whichever language you set as default (Korean in your case). Ctrl+Space again to disable IBus and resume typing in English. The icon will change to reflect whether IBus is active.

Note that you now also have IBus in your System Tools category of your menu. Run that to start the IBus daemon upon future logins, as it isn't set to automatically start. If you want it to automatically start, add a new entry in Startup Applications in your System Settings, and use the command:
Code: Select all
ibus-daemon --xim
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: LM15 Cinnamon Korean Language keyboard help

Postby Taurean75 on Sun Jan 19, 2014 1:16 am

Will this work for Mint 16 xfce edition? And where is Startup Applications?
Taurean75
Level 1
Level 1
 
Posts: 1
Joined: Sun Jan 19, 2014 12:56 am

Re: LM15 Cinnamon Korean Language keyboard help

Postby xenopeek on Sun Jan 19, 2014 3:15 am

I can't get it to work on Xfce, so I suggest you create a new topic for that. I can install it fine with step 1 above, and am able to add Hangul using step 2 and 3 (though it worked a bit different and I first had to click "show all input methods" in the selection box and then had to open the selection box again and scroll down to Korean), but I can't get any program to actually use it... Probably something Xfce specific. This topic is about Cinnamon, so create a new topic.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Newbie Questions

Who is online

Users browsing this forum: mikecolley, Yahoo [Bot] and 38 guests