PLEEAASSE HELP!!!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

PLEEAASSE HELP!!!

Postby idsh on Thu Jul 03, 2008 9:36 pm

I am a newbie at Linux.

I wanted to install Linux Mint along with my WinXP Home Edition so that I have a dual boot. But after installation Linux Mint says that it cannot mount the ntfs-partition. I did not go through a partition manager before installing Linux Mint. Does this mean that my windows is lost?????? Can someone please help!!
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Linux Mint is funded by ads and donations.
 

Re: PLEEAASSE HELP!!!

Postby 67GTA on Thu Jul 03, 2008 11:22 pm

Open a terminal and post the output of
Code: Select all
sudo fdisk -l
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 3:57 am

Disk /dev/hda: 163,9 GB, 163928604672 byte
255 huvuden, 63 sektorer/spår, 19929 cylindrar
Enheter = cylindrar av 16065 · 512 = 8225280 byte
Diskidentifierare: 0x219a2199

Enhet Start Början Slut Block Id System
/dev/hda1 * 1 15517 124640271 7 HPFS/NTFS
/dev/hda2 15518 15542 200812+ 82 Linux växling / Solaris
/dev/hda3 15543 19929 35238577+ 83 Linux
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 4:20 am

In the partition manager it looks like this
Attachments
Skärmbild-Information om -dev-hda1.png
Skärmbild-Information om -dev-hda1.png (54.84 KiB) Viewed 1456 times
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby Google Spider on Fri Jul 04, 2008 6:50 am

idsh wrote: Does this mean that my windows is lost??????


I can see an NTFS partition, so windows is still there.

Are you getting the Grub menu to select the OS you want to boot into? If not, then you will have to add windows to your /boot/grub/menu.lst . Grub does that automatically, I don't know why it didn't in this case. :|
Google Spider
Level 2
Level 2
 
Posts: 86
Joined: Thu Apr 03, 2008 10:45 am

Re: PLEEAASSE HELP!!!

Postby 67GTA on Fri Jul 04, 2008 10:36 am

Try installing
Code: Select all
ntfs-config
and setting it up. It will set read/write/mount info for ntfs partition. Then do a normal boot into Windows. After that, boot back into Mint to see if the error persists.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby MagnusB on Fri Jul 04, 2008 11:50 am

And the NTFS partition is marked as a bootable partition, Windows should probably be fine, it is just that Linux can't mount the volume for some reason.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 12:42 pm

*Hello Google Spider:
How do I add Windows in /boot/grub/menu.lst? Here is the whole file:
(As I said I am a newbie, so I am sorry if I ask to many stupid or simple questions....)

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

gfxmenu=/etc/grub/message.elyssa

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda3 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Linux Mint, kernel 2.6.24-16-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/hda3 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic

title Linux Mint, kernel 2.6.24-16-generic (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.24-16-generic

title Linux Mint, kernel memtest86+
root (hd0,2)
kernel /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 12:50 pm

67GTA wrote:Try installing
Code: Select all
ntfs-config
and setting it up. It will set read/write/mount info for ntfs partition. Then do a normal boot into Windows. After that, boot back into Mint to see if the error persists.


I did what you told me, and I get a two checkboxes. I checked the box "activate....for external unit" The selection for internal unit is grey (not choosable).
I reboot but, Windows is not an option
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby MagnusB on Fri Jul 04, 2008 1:10 pm

I saw your error messages, looks like the ntfs partition is a bit broken, did you try to resize it and abort or something? And if you have a live CD of GParted, or similar laying about, boot into that, and try to run a check of the NTFS partition.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 2:12 pm

MagnusB wrote:I saw your error messages, looks like the ntfs partition is a bit broken, did you try to resize it and abort or something? And if you have a live CD of GParted, or similar laying about, boot into that, and try to run a check of the NTFS partition.


Hello MartinB
I really appreciate your help. It would't check the ntfs(?), see picture below.

When I installed Linux Mint i did not feel 100% comfortable, but neither it was the same with the installation of Ubuntu. But that worked fine...
After Ubuntu came Fedora and then I decided to try Linux Mint....
Attachments
Skärmbild-Verkställ väntande ändringar.png
Skärmbild-Verkställ väntande ändringar.png (64.64 KiB) Viewed 1381 times
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby 67GTA on Fri Jul 04, 2008 5:33 pm

You can add Windows to your grub menu and try to boot it, but it sounds like your ntfs partition got borked when it was resized. Did you manually resize it, or did the installer do it for you? Boot into Mint, open a terminal and run
Code: Select all
sudo gedit /boot/grub/menu.lst
Then insert this at the end of your menu list file under "### END DEBIAN AUTOMAGIC KERNELS LIST" and save it. It should show up in your grub menu at boot.

Code: Select all
# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Windows
root      (hd0,0)
savedefault
makeactive
chainloader   +1
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 6:00 pm

67GTA wrote:You can add Windows to your grub menu and try to boot it, but it sounds like your ntfs partition got borked when it was resized. Did you manually resize it, or did the installer do it for you? Boot into Mint, open a terminal and run
Code: Select all
sudo gedit /boot/grub/menu.lst
Then insert this at the end of your menu list file under "### END DEBIAN AUTOMAGIC KERNELS LIST" and save it. It should show up in your grub menu at boot.

Code: Select all
# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Windows
root      (hd0,0)
savedefault
makeactive


Nope it did not work. It only shows (in the boot menu) the word Windows, but when I choose it, it gets back to the menu again. Should root be (hd0,0)?
No, I did the partition myself so of course its my fault. Bit I did this (what I thought was right) because I had fedora installed previously and when used the liveCD for Linux Mint it did not find the partition where Fedora was. Then I went into manual.....

Worst case scenario: is it possible to rescue my files in Windows in ANY way??
chainloader   +1
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby idsh on Fri Jul 04, 2008 6:02 pm

Nope it did not work. It only shows (in the boot menu) the word Windows, but when I choose it, it gets back to the menu again. Should root be (hd0,0)?
No, I did the partition myself so of course its my fault. Bit I did this (what I thought was right) because I had fedora installed previously and when used the liveCD for Linux Mint it did not find the partition where Fedora was. Then I went into manual.....

Worst case scenario: is it possible to rescue my files in Windows in ANY way??
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby 67GTA on Sat Jul 05, 2008 11:06 am

Post a copy of your /etc/fstab file just to make sure it is pointed in the right direction. Have you tried mounting it manually? Open a terminal and run
Code: Select all
sudo mount /dev/hda1
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby idsh on Sat Jul 05, 2008 11:20 am

I try your command and I get:
mount: kan inte hitta /dev/hda1 i /etc/fstab eller /etc/mtab
which in Swedish is something like: "cannot find /dev/hda1 in /etc/fstab or /etc/mtab"

Here is print of the fstab:
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hda3 :
UUID=ab367f4b-622a-4867-a670-10cf5877e061 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/hda2 :
UUID=613122f8-206d-4e9b-a70f-a120322d45e8 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby 67GTA on Sat Jul 05, 2008 11:30 am

Try mounting it in a specific directory such as /media.
Code: Select all
sudo mount /dev/hda1 /media
Then if it mounts, it will be in your /media directory.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby idsh on Sat Jul 05, 2008 6:25 pm

"mount: du måste ange filsystemstypen"
It asks for the file system type......?
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Re: PLEEAASSE HELP!!!

Postby 67GTA on Sat Jul 05, 2008 6:29 pm

I think it is probably beyond repair. You might try testdisk. You can install it with the package manager. It may be able to help you restore the partition to rescue files. It is a CLI tool. Just run testdisk --help for options.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: PLEEAASSE HELP!!!

Postby idsh on Sat Jul 05, 2008 7:22 pm

ok, thanks anyway for your efforts.

I think I will try to rescue some of the files with Testdisc. After that I plan to format the ntfs partition and then reinstall Windows. I would like to keep Linux Mint so I will have a dual boot. Do you have any final recommendations for me? Is it better to format the whole harddisk and then reinstall windows, make correct partitions and then reinstall Linux Mint??

Thank you once again
idsh
Level 1
Level 1
 
Posts: 17
Joined: Thu Jul 03, 2008 9:31 pm
Location: Stockholm, Sweden

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 16 guests