libc6 broken?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

libc6 broken?

Postby runt on Fri Jul 04, 2008 9:19 pm

Ok,
did an apt-get update and upgrade today and i got an error about libc6. did an apt-get check and then -f install and got the stuff below. do i need to re-install (again)?

Code: Select all
shaun@boxen-i ~ $ sudo apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libgcc1: Depends: libc6 (>= 2.7-1) but it is not installed
E: Unmet dependencies. Try using -f.
shaun@boxen-i ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies...
 Done
The following extra packages will be installed:
  libc6
Suggested packages:
  locales glibc-doc libc6-i686
The following NEW packages will be installed:
  libc6
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.

Need to get 0B/4308kB of archives.
After this operation, 10.7MB of additional disk space will be used.
E: Cannot get debconf version. Is debconf installed?
debconf: apt-extracttemplates failed: Bad file descriptor
(Reading database ... 30 files and directories currently installed.)
Unpacking libc6 (from .../libc6_2.7-10ubuntu3_i386.deb) ...

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg: error processing /var/cache/apt/archives/libc6_2.7-10ubuntu3_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.7-10ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
runt
Level 1
Level 1
 
Posts: 6
Joined: Fri Jun 27, 2008 7:09 am

Linux Mint is funded by ads and donations.
 

Re: libc6 broken?

Postby Phosgene on Fri Jul 04, 2008 9:52 pm

Have you tried:

sudo apt-get install libc6

?
Image
Image
User avatar
Phosgene
Level 2
Level 2
 
Posts: 79
Joined: Thu Jul 03, 2008 6:59 pm
Location: Chernobyl

Re: libc6 broken?

Postby erginemr on Sun Jul 06, 2008 4:47 pm

Also flushing the cache before the installation might help:
Code: Select all
sudo apt-get clean
erginemr
Level 1
Level 1
 
Posts: 47
Joined: Sun Jul 06, 2008 4:37 am
Location: Istanbul / Turkey


Return to Newbie Questions

Who is online

Users browsing this forum: bgast1, Google Adsense [Bot], Johnny333, Reorx and 25 guests