Screen Resolution Help

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Screen Resolution Help

Postby AMLow on Sun Jul 06, 2008 4:01 pm

I just switched from Ubuntu. I was able to have a screen res of 1280x1024 but now Mint only allows me to do 1024 x840. Is there any way I can get it back to normal?
AMLow
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 06, 2008 3:53 pm
Location: Canada, Eh?

Linux Mint is funded by ads and donations.
 

Re: Screen Resolution Help

Postby erginemr on Sun Jul 06, 2008 4:10 pm

1- What is the brand and model of your graphics card?

2- How did you install the driver for your graphics card? Did you do anything special like Envy, hardware drivers, etc.?

3- Can you please post the contents of your /etc/X11/xorg.conf file by the help of this console command:
Code: Select all
gedit /etc/X11/xorg.conf


4- And the outcome of the console commands:
Code: Select all
lcpci | grep -i vga
glxinfo | grep -i render


5- Finally, what type of monitor have you been using? LCD, CRT, normal size, wide screen? And its natural resolution?
erginemr
Level 1
Level 1
 
Posts: 47
Joined: Sun Jul 06, 2008 4:37 am
Location: Istanbul / Turkey

Re: Screen Resolution Help

Postby ginjabunny on Sun Jul 06, 2008 4:19 pm

try displayconfig-gtk
you can get it via synaptic package manager
User avatar
ginjabunny
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: Screen Resolution Help

Postby AMLow on Sun Jul 06, 2008 4:25 pm

1. nvidia GeForce 2 MX 400/200
2. There was a icon in the system tray that I click and installed.
3.
Code: Select all
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Driver      "nvidia"
   Option      "NoLogo"   "True"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   Option      "AddARGBGLXVisuals"   "True"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
   Load      "glx"
EndSection

4.
Code: Select all
--- ~ $ lcpci | grep -i vga
bash: lcpci: command not found
--- ~ $ glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: GeForce2 MX/AGP/SSE2

5. http://www.viewsonic.com/products/deskt ... ries/e70f/
AMLow
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 06, 2008 3:53 pm
Location: Canada, Eh?

Re: Screen Resolution Help

Postby erginemr on Sun Jul 06, 2008 4:37 pm

Sorry, the previous command should have been "lspci | grep -i vga", but it doesn't matter any more.

I am using NVidia GeForce 4MX, so our video cards are quite similar. And here is my /etc/X11/xorg.conf file:

Code: Select all
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "tr"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Driver      "nvidia"
   Option      "NoLogo"   "True"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   Option      "AddARGBGLXVisuals"   "True"
        Option          "XvmcUsesTextures"      "True"
        SubSection      "Display"
            Depth       24
            Modes       "1024x768_75" "800x600_75" "640x480_75"
        EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen       "Default Screen"
EndSection
Section "Module"
   Load      "glx"
EndSection


With this configuration, I have been using Mint with 1024x768 resolution at 75 Hz refresh rate.

In this respect, please edit the file in question with root permissions:
Code: Select all
gksu gedit /etc/X11/xorg.conf

and add the following lines to Section "Screen":
Code: Select all
Section "Screen"
   .......
   .......
   SubSection      "Display"
            Depth       24
            Modes       "1280x1024"  "1024x768"  "800x600"
   EndSubSection
EndSection


Then, restart X (i.e. graphical desktop) with Ctrl+Alt+BackSpace.

This should open 1280x1024 at the maximum compatible refresh rate (possibly 85 or 87 Hz). If you find the desktop blurry, then edit the same file and replace "1280x1024" with "1280x1024_75", which should drop the refresh rate to 75 Hz.

That should do it. However, if it doesn't work, then there is a tool developed by NVidia in the repositories called "nvidia-settings", which you can use to adjust the resolution and refresh rate. You can install this tool with:
Code: Select all
sudo apt-get install nvidia-settings

and run it with "Alt+F2 >> nvidia-settings". But this is Plan B; you should first try the trick above.
erginemr
Level 1
Level 1
 
Posts: 47
Joined: Sun Jul 06, 2008 4:37 am
Location: Istanbul / Turkey

Re: Screen Resolution Help

Postby AMLow on Sun Jul 06, 2008 4:45 pm

Thank you very much, it worked. :D
AMLow
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 06, 2008 3:53 pm
Location: Canada, Eh?

Re: Screen Resolution Help

Postby erginemr on Mon Jul 07, 2008 1:47 am

This is great! Take care & have fun! :D
erginemr
Level 1
Level 1
 
Posts: 47
Joined: Sun Jul 06, 2008 4:37 am
Location: Istanbul / Turkey

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: nomko and 17 guests