About Busybox - NOW solved!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

About Busybox - NOW solved!

Postby T J Tulley on Wed Jul 16, 2008 12:08 pm

So many times Grub dumps me in Busybox I determined to discover whether it might be used.

I found an article in Wikipedia [NOT Mint Wiki] at:
http://en.wikipedia.org/wiki/BusyBox which gives history and how it is used.

I tried to see whether it could be accessed from within Elyssa now that is open (after another struggle today!) - a command $ man Busybox gave no manual, nor did $ man busybox - then I tried a command $ busybox, which produced the response:
theo@TJT4Elyssa / $ busybox
The program 'busybox' can be found in the following packages:
* busybox
* busybox-static
Try: sudo apt-get install <selected package>
bash: busybox: command not found [End of response].

I shall be grateful for offers of any more advice. I am puzzled by the * preceding those package names.
Last edited by T J Tulley on Tue Oct 07, 2008 9:41 am, edited 4 times in total.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Re: About Busybox

Postby ryawn on Wed Jul 16, 2008 1:18 pm

Hello,

I just wanted to shed some light on how I solved this problem. I was also being dumped into BusyBox about one of every 3 times I booted up.

To solve the problem, I had to modify my Grub menu. It's very simple:

Step 1 (step 1 is environment specific, pick the one that applies to you):

Gnome users:
Code: Select all
sudo gedit /boot/grub/menu.list


KDE users:
Code: Select all
sudo kate /boot/grub/menu.list


XFCE users:
Code: Select all
sudo mousepad /boot/grub/menu.list


Step 2:

Scroll down to the kernel section of the menu. We'll need to make a slight modification. This is what it will look like by default (note: yours may look a tad different depending on your architecture.)

Code: Select all
title      Linux Mint, kernel 2.6.24-16-generic
root      (hd1,0)
kernel      /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro splash quiet
initrd      /boot/initrd.img-2.6.24-16-generic


We need to modify the "kernel" line a little bit. We're going to remove the "quiet" switch and replace it with "all_generic_ide floppy=off irqpoll". It should look like this when you're done:

Code: Select all
title      Linux Mint, kernel 2.6.24-16-generic
root      (hd1,0)
kernel      /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro splash all_generic_ide floppy=off irqpoll
initrd      /boot/initrd.img-2.6.24-16-generic


That should do it! You shouldn't get thrown into BusyBoy anymore! :D

Please note, you'll need to repeat these steps should you ever update your kernel, or if your Grub menu is every automatically updated. Good luck!
If you woke up breathing, congratulations! You get another chance.
ryawn
Level 1
Level 1
 
Posts: 12
Joined: Sat Jul 12, 2008 11:17 am

Re: About Busybox - NOT solved!

Postby T J Tulley on Fri Jul 18, 2008 4:59 pm

Thanks Ryawn:

That method didn't work for me: in fact after that change BusyBox appeared every time I tried to boot, and ultimately I had to use Supergrub - several times before it was successful. Now I have undone that edit, but generally I avoid re-booting and instead hibernate.

That works in Elyssa although it reports failure. It works even better if you install the package hibernate and use the command line $ sudo hibernate
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOT solved!

Postby ryawn on Sat Jul 19, 2008 5:06 pm

T J Tulley wrote:Thanks Ryawn:

That method didn't work for me: in fact after that change BusyBox appeared every time I tried to boot, and ultimately I had to use Supergrub - several times before it was successful. Now I have undone that edit, but generally I avoid re-booting and instead hibernate.

That works in Elyssa although it reports failure. It works even better if you install the package hibernate and use the command line $ sudo hibernate


Strange, and I'm sorry to hear it didn't work. Since making that change I've had 100% success on my box. I guess everyone's situation is a little different though :wink:

I've read elsewhere that sometimes the physical location your hard drives are connected to on your motherboard can cause BusyBox to appear. It may be helpful to try swapping the port the hard drive IDE/SATA cable connects to on your motherboard. I found that information at this URL: http://www.techsupportalert.com/content ... usybox.htm (check out the comments). I haven't tested that theory so I have no idea whether it will work for you or not.

I hope this helps.

EDIT: Oh, and I hope you ONLY edited the "all_generic_ide floppy=off irqpoll" part, and nothing else. Copying my config exactly would likely cause 100% failure.
If you woke up breathing, congratulations! You get another chance.
ryawn
Level 1
Level 1
 
Posts: 12
Joined: Sat Jul 12, 2008 11:17 am

Re: About Busybox - NOT solved!

Postby T J Tulley on Sat Jul 19, 2008 5:41 pm

Thanks again Ryawn: Yes I was careful about the editing!

It would be difficult to change my hd connections - as well as messing up all sorts of addresses written into software and I suppose what in Windows would be Registry. It's bad enough having Elyssa suddenly deciding in /boot/grub/device.map that hdd0 = /dev/sdb et c.

My boot problems are currently aggravated by a card reader which I've just installed - I have come to the conclusion that the PC won't boot with the reader connected - but if I connect it after booting, it mounts itself nicely to a directory which I created for it. There remains a problem that I can't write to it, and it refuses to $ sudo chmod 666 - at present it's 644, owner & group are both root. But that's a discussion in another forum.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOT solved!

Postby teoh on Mon Oct 06, 2008 4:56 pm

This did wonders for my boot ;) thanks a lot!
teoh
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 06, 2008 4:55 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Tue Oct 07, 2008 7:46 am

Thanks , tech, for your reply to this - it alerted me to go back to the beginning of the topic and I tried again Ryawn's tweak of the /boot/grub/menu.lst entry - this time it has worked wonders for me too: two of my installations are booting happily after having been disabled by BusyBox. I've edited the topic to "Now solved!"

Thanks especially to Ryawn.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOW solved!

Postby flintstone on Wed Oct 08, 2008 8:57 am

I was going to try this, but my "sudo gedit /boot/grub/menu.list" attempt pulls up a blank page?.....nothing to edit? (note: I have very little experience at this sort of thing).

I opened up terminal, pasted in sudo gedit /boot/grub/menu.list, typed in password....menu list opens (except it's blank?)

What did I do wrong?
flintstone
Level 1
Level 1
 
Posts: 8
Joined: Fri May 16, 2008 2:23 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Wed Oct 08, 2008 10:32 am

Hi Flintstone:

1) Filename in /boot/grub is menu.lst, not menu.list
2) If it won't open from command, try navigating to it - but you may need to change the ownership/permissions - then double-click to open and edit. This also applies to editing by command.
3) I find it useful to go to View (in File browser) and set Visible columns to include octal permissions, owner and group. I move them to follow Date modified.
4) I think safest way to display files in / is double-click on Computer on Desktop, then Filesystem.

Hope this helps.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOW solved!

Postby flintstone on Wed Oct 08, 2008 12:02 pm

T J Tulley wrote:Hi Flintstone:

1) Filename in /boot/grub is menu.lst, not menu.list
2) If it won't open from command, try navigating to it - but you may need to change the ownership/permissions - then double-click to open and edit. This also applies to editing by command.
3) I find it useful to go to View (in File browser) and set Visible columns to include octal permissions, owner and group. I move them to follow Date modified.
4) I think safest way to display files in / is double-click on Computer on Desktop, then Filesystem.

Hope this helps.


Thank you, that does pull up the info after typing "lst" in place of "list"

I haven't changed anything yet...I have found something else strange. If I re-boot and let boot up timer count down, and then boot....my system does not go past the first load screen....the little bar just keeps going back and forth?

If I hit enter, and not let the timer count down....mint-5 loads right up every time?......no problem?.....seems kinda strange?
flintstone
Level 1
Level 1
 
Posts: 8
Joined: Fri May 16, 2008 2:23 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Wed Oct 08, 2008 12:30 pm

Yes there was a stage at which I found it would boot if I clicked but not if it timed out - didn't last long, and hasn't recurred.

One of my installs would show the reciprocating bar "for ever" - ultimately it would go to BusyBox.

Now I have 2 installs working - I shall only use one; the other will be over-written when Felicia appears.

You can try pasting in the replacement for "splash" suggested by Ryawn and see if it is saved on closing - if not you'll have to tackle the permissions. I copied the required text straight from Ryawn's post in this topic.

If necessary, you can look at man chmod in the terminal. See also: https://help.ubuntu.com/community/FilePermissions
I printed both of these for frequent reference.

If you cd to a directory, ls -l will show the details of the contained files including their permissions.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOW solved!

Postby flintstone on Wed Oct 08, 2008 2:00 pm

Ok, I did the edit and it worked :mrgreen:

Thank you ryawn and tully....I now have Mint-5 on my first hard drive working fine, and Windows XP working like it always did, on my second hard drive.....my world is good again.
flintstone
Level 1
Level 1
 
Posts: 8
Joined: Fri May 16, 2008 2:23 pm

Re: About Busybox - NOW solved!

Postby mindbender9 on Sat Apr 18, 2009 6:18 pm

Guys, I'm trying to install Mint v6 on my desktop and the Busybox error keeps coming.

Since I don't know how to modify the menu.lst from the CDROM, how do you install Mint?

Let me add that Opensuse installs fine, so does Fedora. It's impossible to install either Ubuntu or Mint without the stupid Busybox error from appearing.

Please explain how to install this, because I can't see how any Linux distro expects to succeed with this happening.
I was thinking of the immortal words of Socrates who said: "I drank what?"
mindbender9
Level 1
Level 1
 
Posts: 13
Joined: Sat Apr 18, 2009 6:12 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Sat Apr 18, 2009 6:53 pm

Hi, mindbender9:
I presume you have an installation of Felicia (LinuxMint-6) which won't open.

In a similar situation I was able to access and edit /boot/grub/menu.lst in the Mint filesystem from an installation (in memory) of PuppyLinux (recommended long ago by Fred) - you might be able to do so from OpenSuse or Fedora if you have one installed as well as Mint, but I've never used those.

Hope this helps.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOW solved!

Postby mindbender9 on Sat Apr 18, 2009 9:43 pm

Thanks for responding Theo.

Yes, I've burned a copy of the universal build of Felicia, and I get the Busybox error which dumps me at a prompt of some sort after the GUI stalls. It seems that I'm not the only one who's been experiencing this.

Let's say I was able to grab a copy of /boot/grub/menu.lst from OpenSuse. What do I do with it? There's no way to put it on the CD if I'm burning from an ISO, correct? And I can't install Mint or Ubuntu from the CD to substitute the menu.lst.

Just out of curiosity, why haven't the developers for Ubuntu or Mint done anything to resolve this? There are a number of people out there (I googled) that are asking for assistance but have not gotten anything. There are also a lot of posts everywhere that claim to have an answer, but there's nothing solid to offer people.

I've spent 11 years with SuSE in one form or another, and I've never seen an issue with a Linux distro this careless or unresponsive.

But I appreciate any/all assistance that you could provide.
I was thinking of the immortal words of Socrates who said: "I drank what?"
mindbender9
Level 1
Level 1
 
Posts: 13
Joined: Sat Apr 18, 2009 6:12 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Sun Apr 19, 2009 2:03 pm

Hi mindbender: Sorry - I wasn't entirely clear.

Obviously it is necessary to edit /boot/grub/menu.lst in the installed Felicia so that it operates during the boot process for that filesystem. To do this if it won't boot, it is necessary to access it from another working filesystem - I used PuppyLinux installed in memory. Unlike LinuxMint when working from memory, this allows editing access to hard disks.

It's a very compact distro., and not entirely intuitive to operate - however I found my way around and I've only been using Linux - exclusively Mint until then - for about 2 years.

To use OpenSuse or Fedora it would be necessary to have that installed and booted in a different partition.

BTW, have you tried Supergrub? You might get Felicia to boot with that, and then do the edit. Permissions might have to be changed.

Throughout this I am referring to the edit suggested by Ryawn in his reply to this topic dated 16/7/08. I have only experienced the Gnome access version, but the actual edit is the same for all.

Re: why it happens: a puzzle. it is very architecture-dependent. My present installation worked perfectly until I upgraded my RAM from 1 GB to 2 GB - then BusyBox prevented booting until I edited menu.lst.

I suspect it may be related to the software used in the .iso CD - the Install process produces a variable result in the file /boot/grub/device.map - I have posted about this in the Installation and Boot forum.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: About Busybox - NOW solved!

Postby mindbender9 on Sun Apr 19, 2009 2:34 pm

Thank you for replying, as I appreciate your assistance.

I apologize for not being specific about my install problem but I cannot even get Felicia to install because of this Busybox problem off of the install DVD (Universal ISO - Felicia v6). When I boot off the DVD (or a magazine-supplied CDRom just to verify), the boot screen and GUI start and then nothing happens for a while until the Busybox error pops up.

Just to clarify, I cannot install Felicia. I cannot get to the first install screen.

I am using a Gigabyte motherboard with an Intel Celeron 2.0GhZ CPU + 1GB RAM. In addition, I'm using a SATA drive, which I've read is sometimes a cause to the Busybox fault with installed systems, but I can't even get to the first install screen.

So my question is: if I cannot even get to the first install screen from the DVD's menu, how do I install Linux Mint (or Ubuntu)? This is why I've been so critical of Mint/Ubuntu because of this issue. I've even gotten the finicky OpenSolaris to install on this setup, but Mint/Ubuntu cannot be installed.

Should I start a new thread since this is an install problem? Thanks.
I was thinking of the immortal words of Socrates who said: "I drank what?"
mindbender9
Level 1
Level 1
 
Posts: 13
Joined: Sat Apr 18, 2009 6:12 pm

Re: About Busybox - NOW solved!

Postby T J Tulley on Sun Apr 19, 2009 3:21 pm

Hi mindbender again.

Your problem is certainly different - I suggest reporting it in the Installation and Boot forum.

The latest mail in it NOW is about a similar problem, with a suggestion in reply. Have a look!
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: antcj, Bing [Bot], explodingfish, slipstick and 20 guests