No HDMI sound using my Gigabyte Z87N-wifi MB & Mint [solved]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

No HDMI sound using my Gigabyte Z87N-wifi MB & Mint [solved]

Postby dennyinventura on Fri Feb 28, 2014 2:54 pm

No HDMI sound going to my HDTV monitor from my Gigabyte Z87N-wifi Motherboard using Mint Mate 16.

I just found out how to say "solved" (Don't forget to edit this thread title to add "[SOLVED]".)

My HDMI sound works great using Ubuntu 13.10.

I think I need a driver for my Intel HD4600 Graphics chip or Realtek ALC892 codec chip on my motherboard.

I'm thinking that I'll just add an n-Vidia video card that has a built-in digital audio codec chip if I can't find a driver.

I absolutely love Mint Mate 16 (Petra) so much better than Ubuntu 13.10

Denny
Last edited by dennyinventura on Tue Mar 04, 2014 8:19 pm, edited 3 times in total.
dennyinventura
Level 1
Level 1
 
Posts: 8
Joined: Fri Feb 28, 2014 1:28 pm

Linux Mint is funded by ads and donations.
 

Re: No HDMI sound using my Gigabyte Z87N-wifi MB & Mint

Postby Aristotelian on Fri Feb 28, 2014 5:18 pm

Your pulseaudio is probably set to the analog profile and you need to switch it to hdmi. Try the method here using pacmd under "changing default sink from command line" and choose the hdmi option.

http://askubuntu.com/questions/71863/ho ... g-playback
Aristotelian
Level 2
Level 2
 
Posts: 96
Joined: Tue Dec 24, 2013 7:12 pm

Re: No HDMI sound using my Gigabyte Z87N-wifi MB & Mint

Postby dennyinventura on Sat Mar 01, 2014 7:10 pm

I found some more information on getting HDMI audio to my HDTV from my Gigabyte Z87N-wifi motherboard (using Mint Mate 16)

I have no idea what Pulse Audio is or how to do the instructions from the 2 links below :

http://www.spinics.net/lists/linux-audi ... 93963.html


http://www.spinics.net/lists/linux-audi ... 93964.html

dafreedm@xxxxxxxxx wrote:
> 00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)

This is the HDMI output of the integrated GPU.

> 00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 04)

This is the HDA controller that the HDA codec (the ALC888S) is connected to.


Tell PulseAudio that you want to use the other card.
If you don't use PA, put the following into /etc/asound.conf:

defaults.pcm.card 1
defaults.ctl.card 1


Denny
user name: dennyinventura
dennyinventura
Level 1
Level 1
 
Posts: 8
Joined: Fri Feb 28, 2014 1:28 pm

Re: No HDMI sound using my Gigabyte Z87N-wifi MB & Mint

Postby Aristotelian on Sat Mar 01, 2014 9:40 pm

Pulseaudio is basically the sound system in Mint and Ubuntu. It selects which soundcard to use, and which output on the soundcard. Right now it is most likely set to the analog audio output and needs to be switched to HDMI. When you click on the volume icon you can access the pulseaudio sound settings GUI. Under "configuration" you should see options to select the HDMI profile.

If it is not available or resets when you reboot, you may need to manually change the default settings. Go into your terminal, and type the command:
Code: Select all
pacmd list-sinks


This command asks pulseaudio to list the available "sinks" or output options. It should give you options for HDMI and analog, each with a corresponding number 0 or 1. Let's say HDMI is 1. Then type:

Code: Select all
pacmd set-default-sink 1


Then reboot. It should now work.
Aristotelian
Level 2
Level 2
 
Posts: 96
Joined: Tue Dec 24, 2013 7:12 pm

Re: No HDMI sound using my Gigabyte Z87N-wifi MB & Mint

Postby dennyinventura on Sun Mar 02, 2014 6:43 pm

SOLVED !!!!! IT WORKED !!!!!!!!!!!!!!
THANK YOU ARISTOTELIAN !!!!!!!!!!!!!!

Here are the exact keystrokes that I needed to get my HDMI audio working with my Gigabyte Z87N-wifi motherboard using "Mint Mate 16 Petra".

I went into my terminal mode and typed “pacmd list-sinks” and <Enter> (at my ~ $ prompt)

Then it displayed :
Welcome to PulseAudio! Use "help" for usage information.
>>> 2 sink(s) available.

- and then about 40 lines of text,

and at the bottom it said : active port: -1 (which is my analog port)

Then, I right clicked on my speaker icon at the bottom right of my desktop and selected “Sound Preferences”.

In my “Sound Preferences” window, under the “Hardware” tab, I selected “Digital Audio HDMI Output”.

In my “Sound Preferences” window, under the “Output” tab, I selected “Built-in Audio Digital Stereo (HDMI)”.

Then, I went back into my Terminal mode and instead of typing “pacmd set-default-sink 1” like you said,

I had to type “pacmd set-default-sink 0” (which is my HDMI port).

Then, I rebooted my system, went back into my Sound Preferences, and tested my speakers.
Initially, it didn't work until I finally selected the middle “Digital Stereo HDMI Output” under “Profile” at the bottom of my “Sound Preferences” window.

Thanks again Aristotelian,

Denny
[quote][/quote]
dennyinventura
Level 1
Level 1
 
Posts: 8
Joined: Fri Feb 28, 2014 1:28 pm

Re: No HDMI sound using my Gigabyte Z87N-wifi MB & Mint

Postby Aristotelian on Sun Mar 02, 2014 9:44 pm

Glad it worked. Enjoy Mint!
Aristotelian
Level 2
Level 2
 
Posts: 96
Joined: Tue Dec 24, 2013 7:12 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Euphoria, Google Adsense [Bot], Nomin, PatH57, rudeb, tommyb. and 47 guests