Tree Views Do Not Show Mounted Volumes [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Tree Views Do Not Show Mounted Volumes [SOLVED]

Postby Harlaequin on Sat Mar 01, 2014 1:44 pm

Ok, so this may be an easy one.

I have 2 mounted volumes set up in fstab.
As each user, I can browse to the mountpoint (/mnt/Data and /mnt/Win7-Main). Both are different physical drives with correct permissions for all users, etc.)
They mount for all users without issue at login. Shorcuts work, apps work, etc.
The only issue that I can't seem to find a good answer for is the"Tree View" for browsing/file searches.

When I run apps (Nemo, gedit, LibreOffice, etc.) with eleveated rights (sudo <app>)and browse for files, I see this in the tree view:
>Home
>File System
>Data
>Win7-Main

But, as any other user I do not see the last 2 in the tree views. Since this is to help my (admittedly less technical) family mebers transion from Windows, this is a key feature to help them when browsing for files, etc.

So, how do I make those two "Drives" visible in the tree views for all apps, for all users?

EDIT -SOLVED: although the gedit/nemo combo change would probably have worked, I just did a quick fstab change to mount to "media" instead if "mnt" and on reboot all users were perfect. Thanks to all for the help!
Last edited by Harlaequin on Sun Mar 02, 2014 12:26 am, edited 1 time in total.
Harlaequin
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 01, 2014 1:30 pm

Linux Mint is funded by ads and donations.
 

Re: Tree Views Do Not Show Mounted Volumes

Postby jahid on Sat Mar 01, 2014 2:14 pm

Harlaequin wrote:But, as any other user I do not see the last 2 in the tree views

if you can see the file system, then simply opening the filesystem then to mnt and then Data/Win7-Main will take you to the right place.
Last edited by jahid on Sat Mar 01, 2014 2:42 pm, edited 1 time in total.
jahid@HP ProBook 440 G1 Laptop
User avatar
jahid
Level 5
Level 5
 
Posts: 645
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Tree Views Do Not Show Mounted Volumes

Postby austin.texas on Sat Mar 01, 2014 2:22 pm

Open gedit in root mode
gksudo gedit
Click Open (to open a new file)
Navigate to File System > /mnt > /Data
Click the + sign at the bottom left to add a bookmark
Repeat to create a bookmark for /mnt/Win7-Main

Now you have to do the same thing in Nemo opened as root.
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2626
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Tree Views Do Not Show Mounted Volumes

Postby Harlaequin on Sat Mar 01, 2014 2:48 pm

jahid: yes, those two are what I was referring to.

austin: that would work, but it seems that I would have to do that with EVERY program. I was hoping to avoid that process. I would have to do it with LibreOffice, audacity, gimp, blender, etc... etc...

I have attached a screen shot showing the difference in Nemo. I just want the two circled "folders" (ie. mounted volumes) to show like this for all users, in all programs by default.

Also, the blkid's that are relevant:
/dev/sda2: LABEL="main" UUID="7A6A62D16A628A29" TYPE="ntfs" ==> "/mnt/Win7-Main"
/dev/sdc1: LABEL="Data" UUID="A68AB79B8AB76709" TYPE="ntfs" ==> "Data"

Sample.jpg
sudo vs user pic


also... thanks for the quick respoonses!
Harlaequin
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 01, 2014 1:30 pm

Re: Tree Views Do Not Show Mounted Volumes

Postby jahid on Sat Mar 01, 2014 2:57 pm

austin.texas wrote:Open gedit in root mode

do it really needs root permission? i'm not sure about that, because i have done it without any root permission (by simply running gedit), and it seems work fine.
austin.texas wrote:Now you have to do the same thing in Nemo opened as root.

but it seems that this step is not necessary. it's like, bookmarking in gedit is enought for nemo too.
Last edited by jahid on Sat Mar 01, 2014 3:09 pm, edited 2 times in total.
jahid@HP ProBook 440 G1 Laptop
User avatar
jahid
Level 5
Level 5
 
Posts: 645
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Tree Views Do Not Show Mounted Volumes

Postby jahid on Sat Mar 01, 2014 3:02 pm

Harlaequin wrote:jahid: yes, those two are what I was referring to.

sorry about my first comment. i didn't understand your problem fully.

and you are wrong about austin.texa's method. you only need to do it with gedit not every program. every other program uses nemo settings (in general), so once you have done it with nemo you are done with every program. and it seems nemo is automatically detecting it form gedit. so you just need to do it with gedit.
jahid@HP ProBook 440 G1 Laptop
User avatar
jahid
Level 5
Level 5
 
Posts: 645
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Tree Views Do Not Show Mounted Volumes

Postby Harlaequin on Sat Mar 01, 2014 3:04 pm

Ok, sweet! It just sounded like it needed to be every program, my mistake, sorry!

... thanks for the help!
Harlaequin
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 01, 2014 1:30 pm

Re: Tree Views Do Not Show Mounted Volumes

Postby altair4 on Sat Mar 01, 2014 3:14 pm

I am not at all familiar with the "tree view" mode of nautilus / nemo and I can't reproduce what you are seeing when you run gksu nemo but I can get the mount points to show up in the side panel for an ordinary user.

Change your mount points from the /mnt directory to the /media directory:

/media/Data
/media/Win7-Main.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5813
Joined: Tue Feb 03, 2009 10:27 am

Re: Tree Views Do Not Show Mounted Volumes

Postby jahid on Sat Mar 01, 2014 3:24 pm

altair4's method will solve your problem for sure but you will need to edit fstab again for that. so austin.texas's method is the easiest one, and if i am right you won't even need root permission to do that. making two bookmarks in gedit, that's all it takes. it's your choice, which is easy to you... :mrgreen:
jahid@HP ProBook 440 G1 Laptop
User avatar
jahid
Level 5
Level 5
 
Posts: 645
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: Tree Views Do Not Show Mounted Volumes

Postby austin.texas on Sat Mar 01, 2014 3:54 pm

Harlaequin wrote:austin: that would work, but it seems that I would have to do that with EVERY program. I was hoping to avoid that process. I would have to do it with LibreOffice, audacity, gimp, blender, etc... etc...


I think you need to check to see if your assumption about having to repeat the process is correct - which it, in fact, is not.
You have to do gedit and Nemo, that's all.
jahid_0903014 may be correct about just doing it in Nemo - I didn't test that.
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2626
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 51 guests