Drive Mount issues

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Drive Mount issues

Postby charlier1977 on Wed Sep 24, 2008 3:39 pm

Hello I need some help I am not able to mount one of my partitions on my hard any longer. I can see the drive listed in file browser but not able to mount it there. If i try to do the following

sudo mount /dev/hda2 /media/hda2

I get:

mount: mount point /media/hda2 does not exist

Here is my fstab file

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda3
UUID=de330e7a-0dbe-4ab4-8654-16c508632729 / ext3 relatime,errors=remount-ro 0 1
# /dev/hda2
UUID=79813c5d-537c-4d0e-a03e-52a8a02a3f95 none swap sw 0 0mde
#/dev/hda1 /media/hda1
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0


and here is the result from sudo fdisk -l


Disk /dev/hda: 120.0 GB, 120034123776 bytes
16 heads, 63 sectors/track, 232581 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Disk identifier: 0x0008d1ff

Device Boot Start End Blocks Id System
/dev/hda1 1 31206 15727603+ 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/hda2 * 31206 198422 84276990 b W95 FAT32
Partition 2 does not end on cylinder boundary.
/dev/hda3 198422 229995 15912382+ 83 Linux
Partition 3 does not end on cylinder boundary.
/dev/hda4 230001 232581 1300824 82 Linux swap / Solaris
Partition 4 does not end on cylinder boundary.

Any HELP would be greatly appreciated
charlier1977
Level 1
Level 1
 
Posts: 5
Joined: Sat Apr 05, 2008 6:30 pm

Linux Mint is funded by ads and donations.
 

Re: Drive Mount issues

Postby Mr. Blue on Thu Sep 25, 2008 9:26 am

Looks like you need to create /media/hda2:

Code: Select all
sudo mkdir /media/hda2


Then you can use:

Code: Select all
sudo mount /dev/hda2 /media/hda2


I'm not sure if that will work, though. The fdisk output says hda2 is the fat32 boot drive, but fstab lists it as swap.

I'd suggest making the /media/hda2 directory and then use:

Code: Select all
sudo mount -t vfat /dev/hda2 /media/hda2


See what comes up.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Drive Mount issues

Postby charlier1977 on Thu Sep 25, 2008 2:31 pm

Thanks,

Creating the hda2 directory did allow me to mount the drive, however I still have the issue of not being able to mount with out using terminal and sudo. If I try in file browser. I get the following error: Cannot mount volume. DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
charlier1977
Level 1
Level 1
 
Posts: 5
Joined: Sat Apr 05, 2008 6:30 pm

Re: Drive Mount issues

Postby Mr. Blue on Thu Sep 25, 2008 3:17 pm

I think it's the /dev/hda2 line in fstab.


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda3
UUID=de330e7a-0dbe-4ab4-8654-16c508632729 / ext3 relatime,errors=remount-ro 0 1
# /dev/hda2
UUID=79813c5d-537c-4d0e-a03e-52a8a02a3f95 none swap sw 0 0mde
#/dev/hda1 /media/hda1
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0


Looks like it thinks /dev/hda2 is a swap partition. Comment that line out with a # and try this:

Code: Select all
/dev/hda2 /media/hda2 vfat defaults 0 0


Save that and try to mount from the file browser.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Drive Mount issues

Postby grimdestripador on Thu Sep 25, 2008 3:31 pm

<Unsure> If you create the directory /meida/hda2 then the auto-mount mechanism seems to fail, now it is required for you to
Code: Select all
 sudo mount /dev/hda2 /media/hda2

or add the line to your fstab file like above.

Anyone know how to return the ability of mounting using the "Computer" then double click the grayed out drive to mount it, once it has been lost.
I belive this is mintDisk, is this true?
what about using pmount, what advantages/difference?
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am


Return to Newbie Questions

Who is online

Users browsing this forum: nerdtron, Reorx and 38 guests