adding third party repository

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

adding third party repository

Postby mgh on Fri Sep 26, 2008 9:42 am

Hi All,

I am tring to add a third party repository (SlimDevices SqueezeCenter) for a wireless music player. They have instructions for Ubuntu, and I have installed in successfully in Ubuntu, but am having problems with LM V3.0.

In Ubuntu, the instructions state to make sure I have selected "Universe". I do not see that option with LM. Maybe that is the problem?

I go to settings/repositories, click new, paste the URL in the url field, clike OK, get the statement that the repository has been added. I refresh, but can not find the package to install it.

Any ideas what I am doing wrong?

Thank You
mgh
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 17, 2007 9:51 pm

Linux Mint is funded by ads and donations.
 

Re: adding third party repository

Postby clem on Fri Sep 26, 2008 10:54 am

Try to edit the source file directly, in a terminal: "sudo gedit /etc/apt/sources.list"

As for Universe, it's already enabled by default in Linux Mint.

Clem.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5545
Joined: Wed Nov 15, 2006 8:34 am

Re: adding third party repository

Postby mgh on Fri Sep 26, 2008 11:35 am

Thank You. That worked perfectly.

Will the routime of opening package manager and adding a repository ever work, or will I need to edit the list everytime?

Thanks for your time.
mgh
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 17, 2007 9:51 pm

Re: adding third party repository

Postby clem on Fri Sep 26, 2008 11:47 am

I started using Linux with Slackware in 1996 and since then I've always had a taste for nice and clear system files. So in our sources.list I decided to put comments and to use two hash signs and a space in front of commented out lines... it turns out (and I didn't know that at the time) that Synaptic expects commented out lines to be preceeded by only one # sign and doesn't really understand anything else :) In practice it doesn't see our commented lines... in future versions of Mint we'll hope that this will be fixed upstream by synaptic and we'll also make sure to only use one #.

Clem.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5545
Joined: Wed Nov 15, 2006 8:34 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], WesternSlope and 35 guests