problems with flash

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

problems with flash

Postby Paulgr on Fri Oct 31, 2008 3:38 pm

I started messing around with flash and now it won't run in youtube or google video. It was working just fine before I made any changes. I've tried reinstalling it from the package manager, but it still won't work.
Paulgr
Level 1
Level 1
 
Posts: 29
Joined: Fri Oct 31, 2008 1:02 pm

Linux Mint is funded by ads and donations.
 

Re: problems with flash

Postby msuggs on Fri Oct 31, 2008 3:57 pm

Could you explain a bit more of what you mean by 'messing around' :)
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: problems with flash

Postby Paulgr on Fri Oct 31, 2008 4:19 pm

Well it started with my inability to get good full screen video in youtube so I thought I'd install another flash player called gnu gnash. After I installed it, I couldn't get it to run at all, so I thought I'd try removing flash. That didn't work, so I re-installed flash and since then nothing seems to correct it. I can no longer play videos in you tube or google. Here is what's showing up in my package manager when I do a search for adobe flash:

Both the flash player non free packages are marked as having been installed, that is, non-free 9.0.21.78-3v1ubunt Macromedia Flash standalone player and non free 10.0.b218 Adobe Flash Player plugin installer
Paulgr
Level 1
Level 1
 
Posts: 29
Joined: Fri Oct 31, 2008 1:02 pm

Re: problems with flash

Postby msuggs on Fri Oct 31, 2008 4:22 pm

Did you remove gnu gnash?
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: problems with flash

Postby Paulgr on Fri Oct 31, 2008 4:37 pm

Yes I just did that and still can't view youtube or google videos.
Paulgr
Level 1
Level 1
 
Posts: 29
Joined: Fri Oct 31, 2008 1:02 pm

Re: problems with flash

Postby msuggs on Fri Oct 31, 2008 4:53 pm

Ok, I'd try 2 things

First go into your home directory and enable hidden files View-->Show Hidden Files

then go to the .adobe folder and trash the Flash_Player folder in there.

then in a terminal type

Code: Select all
sudo apt-get install adobe-flashplugin


This will install the latest version of the flashplayer and remove the beta version you currently have installed

If you don't want to use a terminal you could install it with the package manager. Just search for adobe-flashplugin

hth :)
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: problems with flash

Postby Paulgr on Fri Oct 31, 2008 5:44 pm

I did what you said and this is what I got in the terminal:


~ $ sudo apt-get install adobe-flashplugin
[sudo] password for paul:
Reading package lists... Done
Building dependency tree
Reading state information... Done
adobe-flashplugin is already the newest version.
The following packages were automatically installed and are no longer required:
libboost-thread1.34.1 libboost-date-time1.34.1 localechooser-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 285 not upgraded.
paul@paul-desktop ~ $

So then I typed apt-get autoremove and got this:

~ $ apt-get autoremove
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
paul@paul-desktop ~ $
Paulgr
Level 1
Level 1
 
Posts: 29
Joined: Fri Oct 31, 2008 1:02 pm

Re: problems with flash

Postby Paulgr on Fri Oct 31, 2008 5:49 pm

I still can't play flash. I looked in the package manager for adobe-flashplugin and it shows up as being installed.
Paulgr
Level 1
Level 1
 
Posts: 29
Joined: Fri Oct 31, 2008 1:02 pm

Re: problems with flash

Postby msuggs on Fri Oct 31, 2008 6:00 pm

I'm out of ideas for your flash problem but for the autoremove issue try

Code: Select all
sudo apt-get autoremove


instead of apt-get autoremove
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: problems with flash

Postby Polarfox on Tue Nov 04, 2008 10:29 am

1) Uninstall the Adobe Flashplugin ( sudo apt-get remove adobe-flashplugin flashplugin-nonfree )
2) Check the Addons/Extensions Tab in Firefox if there is flash stuff left - and remove it
3) Go to Youtube, and where it tells you "You need Flashplayer" click the link that takes you to the Adobe site.
4) Click "Install Flash player" ( They should automatically offer the Linux version when you use Firefox )
5) Restart Firefox
6) Done
User avatar
Polarfox
Level 1
Level 1
 
Posts: 20
Joined: Fri Oct 17, 2008 11:18 am
Location: Antacrtica

Re: problems with flash

Postby vsnrs on Sat Nov 08, 2008 8:24 am

Polarfox wrote:1) Uninstall the Adobe Flashplugin ( sudo apt-get remove adobe-flashplugin flashplugin-nonfree )
2) Check the Addons/Extensions Tab in Firefox if there is flash stuff left - and remove it
3) Go to Youtube, and where it tells you "You need Flashplayer" click the link that takes you to the Adobe site.
4) Click "Install Flash player" ( They should automatically offer the Linux version when you use Firefox )
5) Restart Firefox
6) Done


I have done all of these you said and stil get same result on youtube -
Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player.


then, I tried the old fashioned way, removed it with apt-get remove, then installed again with apt-get, but stil the same result as above

is there anything else I could do?
vsnrs
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 28, 2007 1:07 pm
Location: Beograd

Re: problems with flash

Postby vsnrs on Sat Nov 08, 2008 7:23 pm

I kinda made it, but only with older version, that can be found here: http://packages.ubuntu.com/hardy/flashplugin-nonfree
(that is flashplayer 9)
it works fine now
vsnrs
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 28, 2007 1:07 pm
Location: Beograd

Re: problems with flash

Postby redseventyseven on Tue Nov 11, 2008 10:18 pm

This thread from the ubuntu forums may help: http://ubuntuforums.org/showthread.php?t=951194

(in particular try making the symlinks as detailed on page 2).
redseventyseven
Level 1
Level 1
 
Posts: 8
Joined: Fri Apr 04, 2008 10:32 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Feedfetcher and 21 guests