New install. apt-get upgrade: "WARNING: The following packa"

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

New install. apt-get upgrade: "WARNING: The following packa"

Postby mrjadeo on Sat Jan 03, 2009 10:36 am

Hello,

I've got a fresh installation of Felicia. Install was easy, but I'm having trouble upgrading to the latest available packages:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
...
The following packages will be upgraded:
alsa-utils avahi-autoipd avahi-daemon avahi-utils base-files bind9-host
...
xserver-xorg-input-vmmouse xulrunner-1.9 xulrunner-1.9-gnome-support
198 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
Need to get 0B/190MB of archives.
After this operation, 5513kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libglib2.0-0 libqtcore4 login perl-modules perl libperl5.10 perl-base
...
xserver-xorg-input-vmmouse gnome-pilot
Authentication warning overridden.
Extract templates from packages: 100%
Preconfiguring packages ...

I did an a download only upgrade first time, so I'm happy that the packages download OK. Is this some kind of gpg key mismatch with the repository? What should I do about it?
mrjadeo
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 03, 2009 10:25 am
Location: London, UK

Linux Mint is funded by ads and donations.
 

Re: New install. apt-get upgrade: "WARNING: The following packa"

Postby exploder on Sat Jan 03, 2009 10:45 am

There is nothing wrong, only safe repositories are enabled by default. Our packages are not signed, so that is most likely why you saw the warning.Mint specific packages are protected in the apt preferences as well. Nothing to worry about. :mrgreen:
exploder
Level 15
Level 15
 
Posts: 5872
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: New install. apt-get upgrade: "WARNING: The following packa"

Postby mrjadeo on Sat Jan 03, 2009 10:48 am

Nice! Thanks :)
mrjadeo
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 03, 2009 10:25 am
Location: London, UK

Re: New install. apt-get upgrade: "WARNING: The following packa"

Postby analogeye on Sat Jan 10, 2009 12:45 pm

Hi,

exploder wrote:There is nothing wrong, only safe repositories are enabled by default. Our packages are not signed, so that is most likely why you saw the warning.Mint specific packages are protected in the apt preferences as well. Nothing to worry about. :mrgreen:


Does this mean the warning is not necessary? I get this warning using synaptic, and I'd like to get rid of it. Originally I had installed felicia rc1, and I upgraded to the final version when it came out as per http://www.linuxmint.com/blog/?p=474. I was thinking of doing a fresh install just to get this sorted, but I understand from exploder's post that this will remain unchanged no matter whether I reinstall or not. Is that right?


Thanks!
analogeye
Level 1
Level 1
 
Posts: 1
Joined: Thu Nov 27, 2008 6:40 pm


Return to Newbie Questions

Who is online

Users browsing this forum: austin.texas, Bing [Bot], Reorx and 34 guests