USB Drive, fstab & mount problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

USB Drive, fstab & mount problems

Postby Go99an on Sun Jan 04, 2009 11:42 am

Hi Folks,

I have been using Kubuntu for a couple of years, but have just migrated to Mint 5 KDE. I have been setting up this and now want to upload all of my saved data from an external 120Gb USB drive. Each time that I try to do this I keep getting the following error message;

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I have spent a couple of days trawling the posts for solutions but with no success and I think that I have prrobably made some stupid modification to some setting that is causing this. I also have a 16Gb SDHC card + USB reader that I used to install Mint and this is also showing the same error message....... so it did work OK before!!! I have tried cleaning and re-formatting the 16Gb combo on an XP Laptop and still get the same error.

As an aside, I have even tried to setup a Samba share to transfer the data as the 120Gb drive works fine with XP.

I am sure that this problem relates to mount/fstab issues hence the subject title......... but I may be wrong!!!

Thanks in advance for any help,

Regards,
Go99an

"and Green really is my favourite colour...."
Go99an
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 02, 2009 2:55 pm
Location: Cheshire, UK

Linux Mint is funded by ads and donations.
 

Re: USB Drive, fstab & mount problems

Postby Fornhamfred on Sun Jan 04, 2009 1:58 pm

Could you please post your fstab file.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: USB Drive, fstab & mount problems

Postby Go99an on Sun Jan 04, 2009 2:39 pm

Here is the fstab file..... sorry, I should have added it into the 1st post,

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=5462d9d9-9834-4740-b6af-cf14da37166f / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=a4068b01-ee62-47de-806a-11dc711432fe none swap sw 0 0
# Entry for /dev/sda7 :
UUID=bb198669-43d2-4f0a-bdf7-b1c2c115a521 none swap sw 0 0
/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

Regards,
Go99an

"and Green really is my favourite colour...."
Go99an
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 02, 2009 2:55 pm
Location: Cheshire, UK

Re: USB Drive, fstab & mount problems

Postby Fornhamfred on Sun Jan 04, 2009 3:02 pm

Looking at your Fstab file you appear to have two swap files, no home file and two cd/dvd drives. The strange thing is from your first post it seems that the error message is related to sdb1 which according to fstab is a cd drive not usb. Is this correct?

Also found this post in Ubuntu which is worth a try>

Re: Some USB Drives not recognized - Why?
Additional information is, that if I type dmesg in the terminal window, I can see that Linux tries to communicate with the external HDD, and get this:

Unlink after no-IRQ? Controller is probably using the wrong IRQ.

I searched for this error message and just found this in the archives. AND IT WORKED!!! So simple. If you have similar symptoms than me, that some USB thingies work fine, others don't, maybe try this one.

For experiment I tried the more careful method of pressing 'e' during booting, adding

acpi=off irqpoll

to the end of the kernel line (as I just found out on another thread, this way only the current booting would be altered, and if it does not work, I have not ruined it for good).

Since it does work, now I change it for good by using

sudo gedit /boot/grub/menu.lst
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], capivara, Dirkoir, xriss and 36 guests