default boot O/S

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

default boot O/S

Postby calymea on Mon Jan 05, 2009 7:14 am

Hi all, I,like probably a lot of people have my system dual booted with window$ XP and Mint. How do I set the boot loader to load Window$ as the default operating system, with Mint loaded when selected?
Thanks to all.
calymea
Level 2
Level 2
 
Posts: 93
Joined: Sun Jul 22, 2007 10:55 pm

Linux Mint is funded by ads and donations.
 

Re: default boot O/S

Postby hsoltau on Mon Jan 05, 2009 7:59 am

hi,
just edit the default entry in the file /boot/grub/menu.lst

type in terminal:

Code: Select all
sudo gedit /boot/grub/menu.lst


greetings

:D
User avatar
hsoltau
Level 1
Level 1
 
Posts: 22
Joined: Thu Jan 11, 2007 8:20 am
Location: Heidelberg, Germany

Re: default boot O/S

Postby calymea on Tue Jan 06, 2009 6:50 am

Hi, thanks for the reply. Put in the terminal command you supplied, got into "grub" and saw all the different options and not sure which one to edit to change the default boot O/S. Never done anything like this before. Any chance of a quick walk through please?
Thanks again.
calymea
Level 2
Level 2
 
Posts: 93
Joined: Sun Jul 22, 2007 10:55 pm

Re: default boot O/S

Postby proxima_centauri on Tue Jan 06, 2009 7:00 am

HI,

All you need to do is switch around your Linux mint entry and your Windows entry - making Windows the first entry and thus will be selected first by grub when you boot.

You should see something like this near the bottom with your windows entry somewhere under it, this is where I mean.
title Linux Mint 6, kernel 2.6.27-9-generic
root (hd0,0)
kernel /boot/vmlinux-2.6.27.generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.27-9-generic
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3972
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: default boot O/S

Postby hsoltau on Thu Jan 08, 2009 6:14 pm

Hi again,

i think its easier to change this value in the menu.lst file:

line 14 (in my file)
default 0

you have to count starting from 0 to the value where your Windows entry is:

in my file it looks like this at the bottom of the file:
if i would have liked my Win2000 to be the defalut value i would have to set the defalut value to 5 (the title Other operating systems counts too)

Code: Select all
## ## End Default Options ##

title      Linux Mint 6, kernel 2.6.27-7-generic
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.27-7-generic root=/dev/sda3 ro quiet splash
initrd      /boot/initrd.img-2.6.27-7-generic
quiet

title      Linux Mint 6, kernel 2.6.27-7-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.27-7-generic root=/dev/sda3 ro single
initrd      /boot/initrd.img-2.6.27-7-generic

title      Linux Mint 6, kernel Last successful boot
root      (hd0,2)
kernel      /boot/last-good-boot/vmlinuz root=/dev/sda3 ro quiet splash  last-good-boot
quiet

title      Linux Mint 6, memtest86+
root      (hd0,2)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows 2000 Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1



hope that helps....

bye
:D
User avatar
hsoltau
Level 1
Level 1
 
Posts: 22
Joined: Thu Jan 11, 2007 8:20 am
Location: Heidelberg, Germany


Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot] and 19 guests