OpenDNS -- name servers

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

OpenDNS -- name servers

Postby JayhawkBrandon on Thu Jan 08, 2009 9:33 pm

Hello,

In Ubuntu, I used the instructions here: https://www.opendns.com/smb/start/device/ubuntu
to setup my opendns filtering. However, this doesn't work for me in Linux Mint. The command in terminal doesn't do anything (no errors etc.), and I can't seem to change them manually in the wireless setting.

Could you explain to me how to change these name servers?
JayhawkBrandon
 

Linux Mint is funded by ads and donations.
 

Re: OpenDNS -- name servers

Postby AK Dave on Thu Jan 08, 2009 9:41 pm

The first command wants you to open Network Manager to change your DNS to their servers. You'll find it easily on MintMenu. You can also get there from nm-applet on the panel if you select the option to edit network settings.

You simply want these servers forced as your DNS options:
Code: Select all
208.67.222.222
208.67.220.220


The second set of commands forces this permenantly and should be done from the commandline.

Code: Select all
$ sudo cp /etc/resolv.conf /etc/resolv.conf.auto
$ gksudo gedit /etc/dhcp3/dhclient.conf
# append the following line to the document
prepend domain-name-servers 208.67.222.222,208.67.220.220;
# save and exit
$ sudo ifdown eth0 && sudo ifup eth0
User avatar
AK Dave
Level 6
Level 6
 
Posts: 1042
Joined: Wed May 14, 2008 3:39 pm
Location: Anchorage, AK USA


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], t0mM3k and 34 guests