How do I remove "Unlock Keyring" message at bootup/

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Re: How do I remove "Unlock Keyring" message at bootup/

Postby shayney on Sun Mar 01, 2009 10:38 pm

I've had exactly this same problem on a debian Sid, openSUSE, Parsix and now Mint Gnome installs.
It occurs for me when I have setup my wireless internet or setup email accounts in evolution.

I am still yet to find a solution to this problem in any of the distros but I find it unbearable and is almost making me switch back to KDE.
The only temporary fix I can find is to just use my wired internet connection and disable wireless and use kontact instead of evolution.
shayney
Level 3
Level 3
 
Posts: 125
Joined: Sun Mar 01, 2009 10:24 pm

Linux Mint is funded by ads and donations.
 

Re: How do I remove "Unlock Keyring" message at bootup/

Postby Husse on Sat Mar 07, 2009 9:47 am

@ GrayWizardLinux
Please start a new topic about your dragging/copying problems - this topic is tough enough anyway
It is a regression - regrettably :)
My laptop does not have the problem. I have the same password for the account and the keyring
The version of libpam-gnome-keyring is 2.24.1-ubuntu1 (for Felicia)
I also have Elyssa installed on it with no problems, but this is something that has reappeared in Felicia
All I have is a "Network secret for....wireless..." in Passwords
I changed the password of the keyring to something other than the password of my account - and sure enough I was asked to unlock the keyring. Changed it back, and I was not asked to unlock
Temporarily changed to autologin - was asked for keyring password. Changed it to an empty password - was not asked
Changed back to normal - was not asked
So this is something that happens on a small(er) number of systems and I honestly can't find anything useful
I find questions about it but nothing that looks like a good solution. Someone had success by creating a new user but that's just about all
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I remove "Unlock Keyring" message at bootup/

Postby shayney on Sat Mar 07, 2009 1:40 pm

Well in my case, I have stopped getting the keyring popup for my wireless connection so I can have that start automatically. I don't know why it stopped since I haven't done anything different.
It still pops up for evolution though.
shayney
Level 3
Level 3
 
Posts: 125
Joined: Sun Mar 01, 2009 10:24 pm

Re: How do I remove "Unlock Keyring" message at bootup/

Postby Husse on Sat Mar 07, 2009 2:43 pm

It still pops up for evolution though.

Yes I know that, and I don't think there's much to do about it....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I remove "Unlock Keyring" message at bootup/

Postby GrayWizardLinux on Sat Mar 07, 2009 6:19 pm

Husse - that's Ok - i added this as s idenote. also wasn't sure what you wanted to know. I was just posting all available issues at present.

the keyring issue ir a random situation - More than not - so it happens quite a bit - no real correlation to anything that I can see.
Linux Mint - Pure Bliss!
User avatar
GrayWizardLinux
Level 6
Level 6
 
Posts: 1240
Joined: Wed Sep 12, 2007 5:47 pm
Location: Anywhere I Am!

Re: How do I remove "Unlock Keyring" message at bootup/

Postby Sokkratez on Sun Apr 12, 2009 4:26 am

I also have this problem. This thread came up from a Google search. Has a solution been found? I couldn't decipher one from reading these posts. It's just a random thing that happens?
Downloadable Suicide - web comic, cheap PC game tips, comic tips, machinima syndication & more
My Twitter
Sokkratez
Level 1
Level 1
 
Posts: 22
Joined: Tue Sep 30, 2008 2:26 am

Re: How do I remove "Unlock Keyring" message at bootup/

Postby Husse on Sun Apr 12, 2009 4:45 am

No - it's not one of these ugly random errors
This is a new topic about it - perhaps some ideas for you there
viewtopic.php?f=53&t=24357
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I remove "Unlock Keyring" message at bootup/

Postby shayney on Sat Aug 22, 2009 7:16 pm

After I did a fresh install recently, I found I had no problems with the wireless keyring, I just entered my user password and the thing hasn't come up since.
Unfortunately I've tried evolution again only to find it still insists on throwing up the keyring dialog.

I'm wanting to move away from kontact/kmail to something gnome based since that is the only remaining kde app I use but looks like it's not gonna happen :o(
shayney
Level 3
Level 3
 
Posts: 125
Joined: Sun Mar 01, 2009 10:24 pm

Re: How do I remove "Unlock Keyring" message at bootup/

Postby jimbob on Wed Feb 24, 2010 7:03 am

Hi i had a the same problem as the above people with the login request at startup

For me its because i am using a Usb wireless Internet connection (through my home router).

changing from the auto login to the manual one has solved this for me .

I am hoping that its also going to solve my Internet (via Usb yes i am using Ndiswraper )just dying after a period of inactivity.
I was thinking that this might be because of the user no longer having rights to establish a connection.
I'm guessing that these key rings have a timer, i am basing this on that every time i try to reconnect i got the request for the wireless wpa2 key .

anyway i am not chasing any responses just thought id post that this was helpful
if i have no more connection timed out over the next day or so ill post back that everything is now hunkey dorey .

its only been a few hours but its looking good , even managed to reconnect to my wireless with out rebooting Linux.
jimbob
Level 1
Level 1
 
Posts: 2
Joined: Wed Feb 24, 2010 5:27 am

Re: How do I remove "Unlock Keyring" message at bootup/

Postby BrianD on Wed Feb 24, 2010 11:40 pm

I finally got rid of this annoying habit on my Linux Mint 7 laptop (I edited each of my saved wireless connections, and clicked the "[ ] enable for all users" box...) and, I agree -- it is a bug. ...further, another issue disappeared when I got this cleared up: when I was getting that dialog all the time, I was only able to connect to one WPA2 network (only the first one I configured, others would never connect!). I could connect to any number of open wireless networks, but not more than one WPA2 protected network. Both this problem, and the one cited in first post in this thread, disappeared for me once I edited my wireless connections and clicked that box.
need I say more??
BrianD
Level 4
Level 4
 
Posts: 306
Joined: Fri Feb 12, 2010 12:22 am
Location: Tallahassee, Florida, USA

Re: How do I remove "Unlock Keyring" message at bootup/

Postby stevefed5291 on Sun Mar 21, 2010 8:45 pm

I had the same problem, which was an enormous inconvenience since I primarily access the box in question via ssh/vnc. If I needed to reboot or there was a power failure, et cetera, I could not ssh into it, as it would not autoconnect to the network. Checking off enable all users worked beautifully. Thanks, it saved me a lot of stress :lol:.
Image
Website, Blog, and stevefed5291 on IRC
User avatar
stevefed5291
Level 3
Level 3
 
Posts: 132
Joined: Mon Feb 09, 2009 8:33 pm
Location: United States

Re: How do I remove "Unlock Keyring" message at bootup/

Postby Hicham on Tue Apr 06, 2010 8:11 am

Her is method how to solve this:

1- go to Terminal mode:

2- cd .gnome2/keyrings/

3- you will find two files : default and default.keyring
+ make a backup # mv default.keyring default.keyring-bak

4- now start your Evolution...

5- you will get popup screen to enter your mail password

6- the second popup screen will ask for the default keyring:
+ leave the password boxes empty (no password)
+ click create button
+ select unsafe storage option

7- That's it. :D

//Hicham
Hicham
Level 1
Level 1
 
Posts: 1
Joined: Tue Apr 06, 2010 7:58 am

Re: How do I remove "Unlock Keyring" message at bootup/

Postby sionghua on Sat Jan 01, 2011 8:18 am

default and default.keyring have been removed. Upon logout and login again it asked me for wireless password, that's it. Upon restart it asks me for keyring password again. Does not work for me.
sionghua
Level 1
Level 1
 
Posts: 3
Joined: Sat Jan 01, 2011 7:40 am

Re: How do I remove "Unlock Keyring" message at bootup/

Postby spelingchampeon on Tue May 10, 2011 12:29 pm

sionghua wrote:default and default.keyring have been removed. Upon logout and login again it asked me for wireless password, that's it. Upon restart it asks me for keyring password again. Does not work for me.


This worked for me on LM 10. I do not use wireless, but whenever I tried to login remotely, I was hit with the keyring. Just put your regular user password in, then leave the 'new' blank. Give this a try:

http://ubuntuforums.org/showthread.php?t=1583830&page=3
spelingchampeon
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 12, 2010 8:56 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot], panorain and 27 guests