Disabling Boot-time Disk check

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Disabling Boot-time Disk check

Postby vrk1219 on Thu Feb 05, 2009 10:13 am

Hi,
In my system I have installed the Daryna version of Mint, and is working fine.
But at the boot time (after loading sound drivers, I came to know as speakers gives a small beep sort of sound) the system tries to check partitions of my HDD, and it gives errors as given below(mainly my Windows Partitions). :x

But in Windows does not show any errors and is working fine (no chkdsk needed).
So, due to this service, the booting time is going beyond a minute. :(

The error looks like:
There are differences in the boot sector and its backup,(original/ offset) please run chkdsk to solve this. :?:

Please let me know how I can turnoff this disk check.
Thanks & Regards
RK Veluvali
vrk1219
Level 2
Level 2
 
Posts: 75
Joined: Thu Dec 04, 2008 3:35 am

Linux Mint is funded by ads and donations.
 

Re: Disabling Boot-time Disk check

Postby vrk1219 on Sat Feb 07, 2009 2:22 pm

Hi,
Could any of you get me out of this problem....
Thanks & Regards
RK Veluvali
vrk1219
Level 2
Level 2
 
Posts: 75
Joined: Thu Dec 04, 2008 3:35 am

Re: Disabling Boot-time Disk check

Postby Fred on Sat Feb 07, 2009 3:12 pm

vrk1219,

In a terminal type:

sudo gedit /etc/fstab

This will open your fstab file for editing. Look at the mounting stanzas for each of your ntfs partitions. You will see that each ends with a "0" and probably a "1". Change only the ntfs stanzas so they end in "0 0" instead of "0 1". Save and close this file.

This should stop your Linux system from checking these partitions on boot.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Disabling Boot-time Disk check

Postby vrk1219 on Sat Feb 07, 2009 4:12 pm

Fred wrote:vrk1219,

In a terminal type:

sudo gedit /etc/fstab

This will open your fstab file for editing. Look at the mounting stanzas for each of your ntfs partitions. You will see that each ends with a "0" and probably a "1". Change only the ntfs stanzas so they end in "0 0" instead of "0 1". Save and close this file.

This should stop your Linux system from checking these partitions on boot.

Fred

Hi Fred,
Thanks for the quick reply.
Here is the output of the file.

More over I don't have any NTFS partitions on my system, all are FAT32 only.
Please let me know what to do?

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdb7
UUID=beabcb6c-56b2-4fab-8bd9-d40710bc5167 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=487A-77EE /media/sda1 vfat defaults,umask=007,gid=46 0 1
# /dev/sda5
UUID=928E-61EE /media/sda5 vfat defaults,umask=007,gid=46 0 1
# /dev/sda6
UUID=D0A0-5CB9 /media/sda6 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb10
UUID=A624-7F72 /media/sdb10 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb11
UUID=465B-6933 /media/sdb11 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb5
UUID=D312-3E57 /media/sdb5 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb8
UUID=196D-A99C /media/sdb8 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb9
UUID=5FC9-147B /media/sdb9 vfat defaults,umask=007,gid=46 0 1
# /dev/sdb6
UUID=a4fcfdf4-0a4c-ab93-4673-c45ad2b28776 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
Thanks & Regards
RK Veluvali
vrk1219
Level 2
Level 2
 
Posts: 75
Joined: Thu Dec 04, 2008 3:35 am

Re: Disabling Boot-time Disk check

Postby Fred on Sat Feb 07, 2009 11:05 pm

vrk1219,

Follow the instructions exactly as I gave above except change only the vfat partitions to end in 0 0

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Disabling Boot-time Disk check

Postby vrk1219 on Sun Feb 08, 2009 3:31 am

Fred wrote:vrk1219,

Follow the instructions exactly as I gave above except change only the vfat partitions to end in 0 0

Fred


Thanks a lot Fred. :D
Thanks & Regards
RK Veluvali
vrk1219
Level 2
Level 2
 
Posts: 75
Joined: Thu Dec 04, 2008 3:35 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], f43fz1fb54z, Google Adsense [Bot], tenfoot and 25 guests