Mint update killed my video

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Mint update killed my video

Postby 85stang on Thu Feb 05, 2009 10:31 am

I noticed an update last week contained some kind of Nvidia stuff. yesterday i reboot my computer and now I have no video signal on the login screen. The graphical grub and the boot meter show, but when the login screen should appear there is no video signal, the amber light comes on the monitor. So I'm trying to get to the terminal from the grub screen, how do you do that?
85stang
Level 1
Level 1
 
Posts: 7
Joined: Thu Feb 05, 2009 10:00 am

Linux Mint is funded by ads and donations.
 

Re: Mint update killed my video

Postby Husse on Sat Feb 07, 2009 4:47 pm

Use Recovery mode and run xfix to fix your X :)
Can't promise success but it will most likely do it
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mint update killed my video

Postby 85stang on Mon Feb 09, 2009 9:37 am

I tried the recovery boot, it would not ever boot completely, just freeze part way through. I got my video back but have another problem now. What I did was boot from a live CD (Dreamlinux 3.0) Switched my xorg.conf to the failsafe one, and that got me basic video. I then was able to boot and remove the package that did it, nvidia-glx-new-envy. which contains the 173 driver. i already had 180.22 which was working great. I reinstalled 180.22, configured X how I wanted it, then crl-alt -backspace and it works fine. however, if I reboot the machine, it reverts back to low graphics mode. Why does it do this if i restart just X it works?
85stang
Level 1
Level 1
 
Posts: 7
Joined: Thu Feb 05, 2009 10:00 am

Re: Mint update killed my video

Postby 85stang on Mon Feb 09, 2009 4:45 pm

Ok I finally got this fixed, after hours of hair pulling. I found this post viewtopic.php?f=59&t=8430&p=128534#p128534

and in it was the fix for me, since i had installed the video driver manually, i needed to add nv and nvidia-new to the disabled modules and the nvidia driver now loaded when i rebooted. However, this was working before it broke and i had manually installed the driver so something triggered it to go haywire, which started with the package mint update installed. So to anyone that did not use Envy to install a video driver, don't let mint update install the package "nvidia-glx-new-envy" This is just a guess, and if someone knows please correct me, but if if I had uninstalled envy, i don't think i would have got this update?
85stang
Level 1
Level 1
 
Posts: 7
Joined: Thu Feb 05, 2009 10:00 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Pilosopong Tasyo, xxTtxx22 and 24 guests