Freezes After Suspend??

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Freezes After Suspend??

Postby Guest on Thu Feb 19, 2009 5:36 pm

Hello everyone.

I new to the Linux world, just switched from Vista, and i can proudly say that, "i will never go back to windows again".

But on to the problem im having. When i close the lid on my laptop it suspends just fine but, whenever i come back to it and open the lid for it to load, it freezes, with lines on the screen and i have to hold the power button and restart it.

Is there any fix for this? or whats going on? Im using Mint 6.2 x64 edition on a HP DV2610us laptop. AMD turion x64 2core 1.9ghz, 4gb memory nvidia video card etc..

Any help would be greatly appreciated. Thanks in advance.
Guest
 

Linux Mint is funded by ads and donations.
 

Re: Freezes After Suspend??

Postby Reaper29 on Thu Feb 19, 2009 5:38 pm

The post above is me, i forgot to login, sorry about that... :lol:
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby Beau on Thu Feb 19, 2009 5:47 pm

Having the same problem on a desktop. Goes to sleep at the designated time, screen goes black, can still hear fans running, but can't get out of standby. I have to hard boot. :?:
Organ Donations Save Lives:
Register to be an organ donor here:
http://www.organdonor.gov/
User avatar
Beau
Level 1
Level 1
 
Posts: 34
Joined: Sat Feb 14, 2009 10:28 pm
Location: Anderson, SC USA

Re: Freezes After Suspend??

Postby Reaper29 on Fri Feb 20, 2009 1:24 pm

anyone? help....lol...
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby Reaper29 on Sat Feb 21, 2009 2:28 am

bump for some help...
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Sat Feb 21, 2009 4:39 am

This is a generic tweak for systems with nVidia graphics cards to make hibernate and suspend work correctly, but I have not tested it on any AMD64 systems yet.

1. Open /etc/default/acpi-support to add post_video=false and vbe_save_state=false:
Code: Select all
gksu gedit /etc/default/acpi-support

Use mine as reference:

# Should we save and restore state using the VESA BIOS Extensions?
#SAVE_VBE_STATE=true
SAVE_VBE_STATE=false <=

# The file that we use to save the vbestate
VBESTATE=/var/lib/acpi-support/vbestate

# Should we attempt to warm-boot the video hardware on resume?
#POST_VIDEO=true
POST_VIDEO=false <=

*Remember to comment out the default settings before making any modifications.*

2. Disable Vsync in Compiz:

System > Advanced Desktop Effects Settings > General Options, go to the Display Settings tab and clear the checkbox next to Sync to Vblank.

More detailed instruction is available here.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Sat Feb 21, 2009 1:19 pm

thanks again. does this also work for the computer going into suspend? like when i close the lid and it goes into standby. will this fix it?
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby Reaper29 on Sat Feb 21, 2009 5:48 pm

i tried it and it messes up my whole graphics.. everything gets huge. any ideas?
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Sun Feb 22, 2009 5:49 am

Post here the contents of every single file that you edited. I suspect that you made a typo somewhere. Even if you did not, I will hopefully be able to suggest something to sort it out.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Sun Feb 22, 2009 12:54 pm

as soon as i type in these commands just like how u see it, with the arrows and everything, save it, then reboot, it messes up everything. heres what it looks like.
Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NvAGP" "1" <=
Option "nologo" "1" <=
Option "NoLogo" "True"
EndSection

where the 2 arrows are is what i inserted cause thats what it says. am i suppose to remove the arrows?
also it says if i have that problem with the graphics getting bigger, to add it to the blacklist file, but when i try to do that, it says permission denied.

my other file as of right now, looks exactly like this. i copied straight from the file.

# Should we save and restore state using the VESA BIOS Extensions?
#SAVE_VBE_STATE=true
SAVE_VBE_STATE=false <=

# The file that we use to save the vbestate
VBESTATE=/var/lib/acpi-support/vbestate

# Should we attempt to warm-boot the video hardware on resume?
#POST_VIDEO=true
POST_VIDEO=false <=

also, i really dont care about the hibernating part. all i really want is for my laptop to go into standby/suspend when i close the lid.
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Sun Feb 22, 2009 2:17 pm

am i suppose to remove the arrows?

You should not have included the arrows -- they are simply pointers. So what you should do now are:
1. Remove all arrows from each file that you edited.
2. Remove the line that reads Option "NoLogo" "True" from your xorg.conf file.
3. Reboot your computer afterwards then check to see if your computer can suspend and resume correctly.

If then you think you still have to blacklist AGPGART, do these steps:
1. Open the blacklist file for editing, with this command:
Code: Select all
gksu gedit /etc/modprobe.d/blacklist

2. Append this line to the bottom of the file:
Code: Select all
blacklist agpgart

3. Save and exit.

As for triggering standby/suspend by closing the lid, that mostly has something to do with how the new version of X handles inputs, which is still beyond my knowledge as of now.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Sun Feb 22, 2009 2:58 pm

ok iv done everything like you said so far. my graphics no long mess up but its still not working. its freezes on a black screen now. i added it to the blacklist. it looked like this when i added in the command you said to put:

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# blacklist ipv6
blacklist ipv6
blacklist agpgart

that correct? its still freezing on a black screen when resuming from suspend.
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Sun Feb 22, 2009 3:23 pm

Yes, that is correct. Unfortunately I have no idea what to do next for I do not have an AMD laptop, as stated in my previous post. So the best thing I can recommend now is to undo all the changes since they do not seem to do any good for you.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Sun Feb 22, 2009 3:28 pm

whats funny is that it use to work when i first installed mint, switching from ubuntu. it never had a problem with ubuntu. i was actually gonna see how fedora was, but idk. i already started putting a bunch of stuff on mint... i need some fast, and mint seems a bit slow. idk.

i wonder what happened along the way of having mint, that now it will not resume from suspend?
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby Reaper29 on Mon Feb 23, 2009 2:20 pm

ok i think i may have found the problem. it seems that my swap partition may not be setup right. when i try to hibernate, this is what it says:
matt@DV2610us ~ $ s2disk
s2disk: Could not lock myself. Reason: Cannot allocate memory
matt@DV2610us ~ $ sudo s2disk
[sudo] password for matt:
s2disk: Could not stat the snapshot device file. Reason: No such file or directory

heres the boot option from the kernal:
dmesg | grep command
[ 0.000000] Kernel command line: root=/dev/sda1 ro quiet splash resume=/dev/sda5
[ 0.612202] ACPI: EC: GPE = 0x2a, I/O: command/status = 0x66, data = 0x62

and this is what it says when i check the uswsusp config:
cat /etc/uswsusp.conf
# /etc/uswsusp.conf(8) -- Configuration file for s2disk/s2both
resume device = /dev/sda5
splash = y
compress = y
early writeout = y
image size = 1849474498
RSA key file = /etc/uswsusp.key
shutdown method = platform
snapshot device = /dev/sda5
suspend loglevel = 2
max loglevel = 2

this is where i stand with everything. so where i do go from there? i did not go past step 12 on your post.
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Mon Feb 23, 2009 5:02 pm

I need some time to investigate this. I will come back to this thread with my findings within days -- less than 3, hopefully.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Mon Feb 23, 2009 5:49 pm

thanks so much garda. if you need any more info, just let me know.
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby garda on Wed Feb 25, 2009 2:43 pm

Looks like I need some more information. Could you please post the outputs of the following commands:
For kernel-related informations:
Code: Select all
uname -rmpio

For general partitions informations:
Code: Select all
sudo parted /dev/sda print

For swap partition informations:
Code: Select all
swapon -s

For Nvidia-related packages informations:
Code: Select all
dpkg -l nvidia-* | grep ^i

For uswsusp package informations:
Code: Select all
apt-cache showpkg uswsusp

I have managed to convince a generous friend to lend me his Turion laptop so that I can play around with ACPI tidbits more accurately. All I can tell for now is that the kernel ring message [ 0.612202] ACPI: EC: GPE = 0x2a, I/O: command/status = 0x66, data = 0x62 has nothing, or at least very little, to do with uswsusp.

And I am going out of town this morning, so this might take longer than I initially estimated.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Freezes After Suspend??

Postby Reaper29 on Wed Feb 25, 2009 2:51 pm

garda wrote:Looks like I need some more information. Could you please post the outputs of the following commands:
For kernel-related informations:
Code: Select all
uname -rmpio

For general partitions informations:
Code: Select all
sudo parted /dev/sda print

For swap partition informations:
Code: Select all
swapon -s

For Nvidia-related packages informations:
Code: Select all
dpkg -l nvidia-* | grep ^i

For uswsusp package informations:
Code: Select all
apt-cache showpkg uswsusp

I have managed to convince a generous friend to lend me his Turion laptop so that I can play around with ACPI tidbits more accurately. All I can tell for now is that the kernel ring message [ 0.612202] ACPI: EC: GPE = 0x2a, I/O: command/status = 0x66, data = 0x62 has nothing, or at least very little, to do with uswsusp.

And I am going out of town this morning, so this might take longer than I initially estimated.


Ok heres all the info you requested. From top to bottome just like you have listed.

matt@DV2610us ~ $ uname -rmpio
2.6.27-12-generic x86_64 unknown unknown GNU/Linux

matt@DV2610us ~ $ sudo parted /dev/sda print
[sudo] password for matt:
Model: ATA FUJITSU MHY2160B (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 157GB 157GB primary ext3 boot
2 157GB 160GB 2871MB extended
5 157GB 160GB 2871MB logical linux-swap

matt@DV2610us ~ $ swapon -s
Filename Type Size Used Priority
/dev/sda5 partition 2803300 0 1

matt@DV2610us ~ $ dpkg -l nvidia-* | grep ^i
ii nvidia-173-modaliases 173.14.12-1-0ubuntu5.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-177-kernel-source 177.82-0ubuntu0.1 NVIDIA binary kernel module source
ii nvidia-177-modaliases 177.82-0ubuntu0.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-71-modaliases 71.86.04-0ubuntu10 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-96-modaliases 96.43.09-0ubuntu1.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-common 0.2.4 Find obsolete NVIDIA drivers
ii nvidia-glx-177 177.82-0ubuntu0.1 NVIDIA binary Xorg driver
ii nvidia-settings 177.78-0ubuntu2.1 Tool of configuring the NVIDIA graphics driv

matt@DV2610us ~ $ apt-cache showpkg uswsusp
Package: uswsusp
Versions:
0.6~cvs20070618-1ubuntu2 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_universe_binary-amd64_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_universe_binary-amd64_Packages
MD5: 17d68640e4dc892d990f728f624c6132


Reverse Depends:
acpi-support,uswsusp 0.2
powersaved,uswsusp
hibernate,uswsusp
education-laptop,uswsusp
gdm,uswsusp
acpi-support,uswsusp 0.2
Dependencies:
0.6~cvs20070618-1ubuntu2 - libc6 (2 2.6-1) libgcrypt11 (2 1.2.2) libx86-1 (0 (null)) zlib1g (2 1:1.2.3.3.dfsg-1) debconf (18 0.5) debconf-2.0 (0 (null)) splashy (2 0.3) initramfs-tools (2 0.74) mount (2 2.12r-17)
Provides:
0.6~cvs20070618-1ubuntu2 -
Reverse Provides:

Thats everything. Thank you so much for all the help, i appreciate it very much.
Reaper29
Level 1
Level 1
 
Posts: 33
Joined: Thu Feb 19, 2009 5:24 pm

Re: Freezes After Suspend??

Postby Beau on Wed Feb 25, 2009 4:35 pm

And mine too Reaper29. My problem is a freeze after suspend requiring a hard reboot.

uname -rmpio

2.6.27-7-generic i686 unknown unknown GNU/Linux
.......................................

sudo parted /dev/sda print
[sudo] password for beau:
Model: ATA WDC WD2500JS-60N (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 250GB 250GB primary ntfs boot
...........................................

swapon -s

Filename Type Size Used Priority
/dev/sdb5 partition 1646620 1892 -1
............................................

$ dpkg -l nvidia-* | grep ^i

ii nvidia-173-modaliases 173.14.12-1-0ubuntu5.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-177-kernel-source 177.82-0ubuntu0.1 NVIDIA binary kernel module source
ii nvidia-177-modaliases 177.82-0ubuntu0.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-71-modaliases 71.86.04-0ubuntu10 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-96-modaliases 96.43.09-0ubuntu1.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-common 0.2.4 Find obsolete NVIDIA drivers
ii nvidia-glx-177 177.82-0ubuntu0.1 NVIDIA binary Xorg driver
ii nvidia-settings 177.78-0ubuntu2.1 Tool of configuring the NVIDIA graphics driv
.......................................

$ apt-cache showpkg uswsusp

Package: uswsusp
Versions:
0.6~cvs20070618-1ubuntu2 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_universe_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_universe_binary-i386_Packages
MD5: 17d68640e4dc892d990f728f624c6132

Reverse Depends:
acpi-support,uswsusp 0.2
powersaved,uswsusp
hibernate,uswsusp
education-laptop,uswsusp
gdm,uswsusp
acpi-support,uswsusp 0.2
Dependencies:
0.6~cvs20070618-1ubuntu2 - libc6 (2 2.6-1) libgcrypt11 (2 1.2.2) libx86-1 (0 (null)) zlib1g (2 1:1.2.3.3.dfsg-1) debconf (18 0.5) debconf-2.0 (0 (null)) splashy (2 0.3) initramfs-tools (2 0.74) mount (2 2.12r-17)
Provides:
0.6~cvs20070618-1ubuntu2 -
Reverse Provides:
.........................................
Organ Donations Save Lives:
Register to be an organ donor here:
http://www.organdonor.gov/
User avatar
Beau
Level 1
Level 1
 
Posts: 34
Joined: Sat Feb 14, 2009 10:28 pm
Location: Anderson, SC USA

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot] and 26 guests