How do you disable automatic updates?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How do you disable automatic updates?

Postby jacatone on Fri Feb 27, 2009 7:59 pm

I'm running LM 6 Main. I've noticed that sooner or later some update from the automatic update feature is going to screw up my system. Linux is so fragile and buggy that I want to avoid these almost constant re-installs. Thanks.
jacatone
Level 4
Level 4
 
Posts: 246
Joined: Fri Apr 18, 2008 5:23 pm

Linux Mint is funded by ads and donations.
 

Re: How do you disable automatic updates?

Postby shane on Fri Feb 27, 2009 8:22 pm

if you want to disable updates simply remove the updater... mintUpdate from the startup... I am assuming that you are using Gnome. You can remove it in the Sessions configuration tool.

AFAIK mintUpdate just notifies you of updates and does not update automatically... what problems did you face?
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: How do you disable automatic updates?

Postby jacatone on Sat Feb 28, 2009 3:51 am

Linux Mint just becomes buggy. I'd install/remove a program or update and my screen resolution would go to hell and I couldn't fix it, or my optical mouse would stop working, my wifi would no longer connect, etc. I've had similar problems with other distros as well if I could even get them to work. Linux is just very unreliable. I like it because it works on my old computers but I'd use XP Pro if the hardware would take it.
jacatone
Level 4
Level 4
 
Posts: 246
Joined: Fri Apr 18, 2008 5:23 pm

Re: How do you disable automatic updates?

Postby Fred on Sat Feb 28, 2009 5:54 am

jacatone wrote:
I've had similar problems with other distros as well if I could even get them to work. Linux is just very unreliable.

Many/most find Linux/Mint to be solid, reliable, and considerably more stable than your preferred OS. Might it be possible that the problem is not Linux?

Please read the first part of my sig. lines. :-)

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: How do you disable automatic updates?

Postby viking777 on Sat Feb 28, 2009 6:32 am

I install every update that is going on Mint up to and including the 'level 5' ones and I have never broken anything yet so it is strange that jacatone has the experience that he does.

That said though, a simple and reliable (non command line) roll back utility would do a lot to reassure people like jacatone who have these problems. Windows has had this as standard for years I just wonder why Linux doesn't? It is not reasonable to expect casual users to resort to dd, partimage or clonezilla to create images for backup purposes as I do - they are all pretty horrible programs anyway. So why not a roll-back utility? What is so difficult about it? The Linux world seemed to move mountains to get Beryl/Compiz working - that is a strange set of priorities to my mind.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: How do you disable automatic updates?

Postby altair4 on Sat Feb 28, 2009 8:04 am

Fred wrote:jacatone wrote:
I've had similar problems with other distros as well if I could even get them to work. Linux is just very unreliable.

Many/most find Linux/Mint to be solid, reliable, and considerably more stable than your preferred OS. Might it be possible that the problem is not Linux?

Please read the first part of my sig. lines. :-)
Insanity: Doing the same thing over and over and each time expecting a different result.
Fred


Fred, I've truly come to appreciate your rapier wit :lol:
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5508
Joined: Tue Feb 03, 2009 10:27 am

Re: How do you disable automatic updates?

Postby Fred on Sat Feb 28, 2009 8:33 am

viking777 wrote:
The Linux world seemed to move mountains to get Beryl/Compiz working - that is a strange set of priorities to my mind.

We can certainly agree on that one. For me, Beryl/Compiz is a complete waste of resources. Having said that, obviously that isn't the case for many. :-)

@altair4,

Yes, well, I can't help it sometimes. The devil and I go way back. It isn't my fault, he makes me do it! :-)

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: How do you disable automatic updates?

Postby elija on Sat Feb 28, 2009 1:56 pm

Fred wrote:viking777 wrote:
The Linux world seemed to move mountains to get Beryl/Compiz working - that is a strange set of priorities to my mind.

We can certainly agree on that one. For me, Beryl/Compiz is a complete waste of resources. Having said that, obviously that isn't the case for many. :-)


Beryl / Compiz seems to be the second best* marketing tool that Linux has.

I have prattled on about stability, reliability, freedom and the lack of viruses, spyware and so on with very little effect. Show a Windows user a spinning desktop cube and wobbly windows then they go and try Linux :|

Oh and to keep on topic, I can't say I have noticed any instability after an update. I have had graphics issues after a kernel update but only because I needed to install the correct version of the Nvidia drivers

* After Windows Vista :twisted:
less is more, but more more than more is, so more is less less, so use more less if you want less more, more or less.

Read my blog at the Fifth Continent
Over 50? Visit the Saga Zone
Registered Linux User: #459086
elija
Level 1
Level 1
 
Posts: 29
Joined: Sun Dec 21, 2008 9:30 am

Re: How do you disable automatic updates?

Postby Fred on Sat Feb 28, 2009 2:04 pm

elija,

I love your sig. line. :-)

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: How do you disable automatic updates?

Postby elija on Sat Feb 28, 2009 2:46 pm

Fred wrote:elija,

I love your sig. line. :-)

Fred


I can't claim authorship... I read it on www.slackbook.org and fell in love with it. I'm considering adding my own twist to it... in fact...
less is more, but more more than more is, so more is less less, so use more less if you want less more, more or less.

Read my blog at the Fifth Continent
Over 50? Visit the Saga Zone
Registered Linux User: #459086
elija
Level 1
Level 1
 
Posts: 29
Joined: Sun Dec 21, 2008 9:30 am

Re: How do you disable automatic updates?

Postby jacatone on Sat Feb 28, 2009 2:52 pm

I don't think I'm alone in my assessment of Linux. A good friend of mine purchased one of those little netbooks which came with Ubuntu 8.04? He got so frustrated with it because of connection to hot spot problems and trying to use the OS, that he traded up to the XP version. I offered to install XP for him but apparently doing so voids the warranty.
jacatone
Level 4
Level 4
 
Posts: 246
Joined: Fri Apr 18, 2008 5:23 pm

Re: How do you disable automatic updates?

Postby Fred on Sat Feb 28, 2009 4:39 pm

jacatone wrote:
... that he traded up to the XP version.

Please!

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: How do you disable automatic updates?

Postby det4100 on Sun Mar 01, 2009 10:33 am

The hook is dangling in the water.......... :roll:

det4100
det4100

Running Mint Debian
User avatar
det4100
Level 4
Level 4
 
Posts: 225
Joined: Mon Dec 10, 2007 9:51 am
Location: New York

Re: How do you disable automatic updates?

Postby rdonnelly on Sun Mar 01, 2009 3:20 pm

elija wrote:
Fred wrote:viking777 wrote:

Oh and to keep on topic, I can't say I have noticed any instability after an update. I have had graphics issues after a kernel update but only because I needed to install the correct version of the Nvidia drivers

* After Windows Vista :twisted:


What is the correct Nvidia driver? I have problems with resuming from suspend with the Nvidia 173 driver. Never had this problem with Felicia until I applied updates.
The OS: Linux Mint Debian 64 KDE Plasma 4.10.5
The Hardware: Dell 17R Special Edition, Intel Quad Core, i7 - 3.40 GHz, 8 GB Ram, HD 1TB
Video NVIDIA GeForce GT 650M 2GB
The Name: Bob
User avatar
rdonnelly
Level 4
Level 4
 
Posts: 409
Joined: Thu Nov 27, 2008 9:38 pm

Re: How do you disable automatic updates?

Postby elija on Sun Mar 01, 2009 4:11 pm

rdonnelly wrote:What is the correct Nvidia driver? I have problems with resuming from suspend with the Nvidia 173 driver. Never had this problem with Felicia until I applied updates.


The one for your kernel version and graphics card. I haven't had this with Mint, but when messing with Slackware I updated the kernel and X completely stopped working. I had to recompile the Nvidia driver.
less is more, but more more than more is, so more is less less, so use more less if you want less more, more or less.

Read my blog at the Fifth Continent
Over 50? Visit the Saga Zone
Registered Linux User: #459086
elija
Level 1
Level 1
 
Posts: 29
Joined: Sun Dec 21, 2008 9:30 am

Re: How do you disable automatic updates?

Postby rdonnelly on Sun Mar 01, 2009 5:19 pm

elija wrote:
rdonnelly wrote:What is the correct Nvidia driver? I have problems with resuming from suspend with the Nvidia 173 driver. Never had this problem with Felicia until I applied updates.


The one for your kernel version and graphics card. I haven't had this with Mint, but when messing with Slackware I updated the kernel and X completely stopped working. I had to recompile the Nvidia driver.


How do you recompile the nvidia driver? Right now I have the drivers disabled in the "hardware drivers" selection. I wonder if I selected the earlier kernel at the grub menu, would it work like it used too?
The OS: Linux Mint Debian 64 KDE Plasma 4.10.5
The Hardware: Dell 17R Special Edition, Intel Quad Core, i7 - 3.40 GHz, 8 GB Ram, HD 1TB
Video NVIDIA GeForce GT 650M 2GB
The Name: Bob
User avatar
rdonnelly
Level 4
Level 4
 
Posts: 409
Joined: Thu Nov 27, 2008 9:38 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], JeremyB, LOTC and 31 guests