Keyboard repeat rate much too fast despite adjusting

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Keyboard repeat rate much too fast despite adjusting

Postby gumby on Sat Mar 07, 2009 5:02 am

In Control Center, I adjusted the keyboard repeat rate to the longest possible "delay" and the slowest possible "speed" but it is still way too fast and I am getting too many repeating characters. This is happening with both an external keyboard and the laptop internal keyboard.

In windows, adjusting it to the longest delay solves the problem for me. How can I do the same in Mint?
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Linux Mint is funded by ads and donations.
 

Re: Keyboard repeat rate much too fast despite adjusting

Postby Ripose on Sat Mar 07, 2009 5:47 am

You should check your BIOS Typematic settings first.

I can't tell you where in BIOS to find it since every version is different (I use ASUS 1901)
User avatar
Ripose
Level 1
Level 1
 
Posts: 44
Joined: Thu Feb 12, 2009 2:03 am
Location: Lethbridge, Alberta

Re: Keyboard repeat rate much too fast despite adjusting

Postby gumby on Sat Mar 07, 2009 12:25 pm

Thanks, Ripose, but my computer's BIOS, called "InsydeH20 setup utility" does not have any Typematic controls that I could find.

I see that this has been reported as a bug in Ubuntu:

http://ubuntuforums.org/showthread.php?t=993982

https://bugs.launchpad.net/ubuntu/+sour ... bug/264196

https://bugs.launchpad.net/ubuntu/+sour ... omments/26

Would any of the workarounds suggested in these threads work with Mint? This problem is incredibly annoying, I'm getting repeat characters very often and I'm a fairly fast typist. I can't believe other Mint users haven't noticed this.
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Re: Keyboard repeat rate much too fast despite adjusting

Postby Ripose on Sat Mar 07, 2009 9:45 pm

Did you try turning REPEAT KEYS off?
uncheck the box: key presses repeat when key is held down

Also check the /etc/kbd file uncomment the keyboard settings (bottom of page) and change the settings there.

Fore more Info - In terminal:
Code: Select all
man kbdrate
press q to quit reading man page.

Some instructions will tell you to check /etc/rc.local but I don't have that file...
User avatar
Ripose
Level 1
Level 1
 
Posts: 44
Joined: Thu Feb 12, 2009 2:03 am
Location: Lethbridge, Alberta

Re: Keyboard repeat rate much too fast despite adjusting

Postby gumby on Sun Mar 08, 2009 1:57 am

Thanks, Ripose. Turning "repeat keys" off did the trick. :)
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Re: Keyboard repeat rate much too fast despite adjusting

Postby gumby on Sun Mar 08, 2009 1:55 pm

I'm starting to realize that turning "repeat key" off isn't a great solution. There are many times when I want keys to repeat, such as when I'm deleting a few words of text with backspace, or similar situations. I just want the repeat to have a functional delay so I can control it. jjjjjjjjjjjjjjjjjjjjjjjjjjj llllllllllllllllllll :shock:

While I was typing this post, for some reason the repeat key function turned itself back on, and my keys are repeating again, despite the fact that the Repeat Keys box in Control Center-Keyboard remains unchecked! :cry:

What about those Ubuntu workarounds I linked to earlier in this thread?

Thanks again for any help.
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Re: Keyboard repeat rate much too fast despite adjusting

Postby gumby on Sun Mar 08, 2009 2:44 pm

Well, after I restarted my computer, the keyboard behavior went back to normal, no repeat. But the problem still remains that turning the repeat function off completely isn't a great solution, as it causes other inconveniences.

I'm suspecting that maybe the fact that I unplugged an external keyboard from a main usb port and then plugged it into my usb hub while the computer was on might have triggered the strange behavior...but it shouldn't have, I would think.
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Re: Keyboard repeat rate much too fast despite adjusting

Postby Fred on Sun Mar 08, 2009 2:50 pm

gumby,

If there is an usb hub involved it could very well be. I have seen strange problems before with some usb hubs, on both Windows and Linux. When it comes to usb hubs there can be compatibility problems, I suspect related to not implementing the usb protocols correctly. Hot plugging can be tricky if it isn't implemented just right.

Fred


Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Keyboard repeat rate much too fast despite adjusting

Postby gumby on Wed Mar 18, 2009 2:55 am

Here's a good easy fix for this problem from https://bugs.launchpad.net/ubuntu/+sour ... bug/264196

"wolfwitch wrote 12 hours ago: (permalink)

The workaround posted near the top of this bug, submitted by Jorge Peixoto de Morais Neto, seems to be the best fix for this for now. It works on my laptops and home desktop when using any keyboard...

Just add:

kbdrate -r 25 -d 500

...to /etc/rc.local

I just put it right above "exit 0" at the bottom of the file.

Frankly, I can't believe this hasn't been fixed yet."

******

I changed those figures a bit to repeat rate 15 and delay 750, which works for me.

Remember to restart after editing rc.local. This will make the fix work for all keyboards, including USB.
gumby
Level 3
Level 3
 
Posts: 154
Joined: Sun Feb 15, 2009 12:57 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot] and 23 guests