strange ALSA problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

strange ALSA problem

Postby Soulprayer on Sun Mar 15, 2009 4:35 am

Hi,

I am using MintOS 6.0 XFCE version with 2.6.27-7-generic.
When i boot up my PC, my sound card is gone - i can only find my onboard sound in the alsamixer and i have no sound! Nada, Niente, Rien, Nichts!
But when i do alsa force-reload, there it goes, my Audigy 2 ZS is correctly in alsamixer and i can hear sound with anything.
And now it gets weird: It's not every time i boot up the pc - it's randomly!!!

Well, i can't really decipher my dmesg for suspicious lines, perhaps you know what this means?

FAIL:
Code: Select all
[   11.049415] [fglrx] module loaded - fglrx 8.54.3 [Oct 10 2008] with 1 minors
[   11.481468] iTCO_vendor_support: vendor-support=0
[   11.510276] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.03 (30-Apr-2008)
[   11.517228] iTCO_wdt: Found a ICH9 TCO device (Version=2, TCOBASE=0x0860)
[   11.517336] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   11.763420] HDA Intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[   11.763445] HDA Intel 0000:01:00.1: setting latency timer to 64
[   11.793653] input: PC Speaker as /devices/platform/pcspkr/input/input5
[   11.829496] gameport: EMU10K1 is pci0000:05:01.1/gameport0, io 0xe480, speed 1011kHz
[   11.888883] EMU10K1_Audigy 0000:05:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   11.892733] Installing spdif_bug patch: Audigy 2 ZS [SB0350]
[   13.081857] lp0: using parport0 (interrupt-driven).
[   13.185513] Adding 498004k swap on /dev/sda2.  Priority:-1 extents:1 across:498004k
[   13.728379] EXT3 FS on sda3, internal journal

SUCCESS:
Code: Select all
[   10.960868] [fglrx] module loaded - fglrx 8.54.3 [Oct 10 2008] with 1 minors
[   11.115732] iTCO_vendor_support: vendor-support=0
[   11.165723] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.03 (30-Apr-2008)
[   11.165808] iTCO_wdt: Found a ICH9 TCO device (Version=2, TCOBASE=0x0860)
[   11.165891] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   11.364767] gameport: EMU10K1 is pci0000:05:01.1/gameport0, io 0xe480, speed 1011kHz
[   11.400071] udev: renamed network interface eth0 to eth1
[   11.436359] input: PC Speaker as /devices/platform/pcspkr/input/input5
[   11.449909] udev: renamed network interface eth1_rename to eth0
[   11.773228] EMU10K1_Audigy 0000:05:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   11.777055] Installing spdif_bug patch: Audigy 2 ZS [SB0350]
[   11.802812] HDA Intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[   11.802830] HDA Intel 0000:01:00.1: setting latency timer to 64
[   12.873498] lp0: using parport0 (interrupt-driven).
[   12.977903] Adding 498004k swap on /dev/sda2.  Priority:-1 extents:1 across:498004k
[   13.520552] EXT3 FS on sda3, internal journal


Perhaps its the gameport is loaded first?!?
And i don't really think i have this Ubuntu 8.10 sound bug, because there is no pulseaudio loaded anyway. Other way, there is no "Sound"-Option where i can change something to ALSA. (I only find a "Sound", where i can check some boxes for on/off controls or something)

My /etc/modprobe.d/alsa-base looks like this:
Code: Select all
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modpr$
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ;$
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu1$
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq $

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; :$

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

It looks fine for me, my snd-emu10k1 is in there and when i do this alsa force-reload trick this is the output:

Code: Select all
Terminating processes: 6218.
Unloading ALSA sound driver modules: snd-emu10k1-synth snd-emux-synth snd-seq-virmidi snd-seq-midi-emul snd-emu10k1 snd-hda-intel snd-ac97-codec snd-seq-dummy snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-oss snd-seq-midi snd-util-mem snd-hwdep snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
Loading ALSA sound driver modules: snd-emu10k1-synth snd-emux-synth snd-seq-virmidi snd-seq-midi-emul snd-emu10k1 snd-hda-intel snd-ac97-codec snd-seq-dummy snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-oss snd-seq-midi snd-util-mem snd-hwdep snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.


You see, the same modules are loaded after unloaded. there is no extra module, when i do the trick.
I dont get it - really i dont get it!!!
Please help me.

Regards
Soulprayer
It will get dangerous when dumb people get busy!
Soulprayer
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 15, 2009 3:26 am
Location: Cologne, Germany

Linux Mint is funded by ads and donations.
 

Re: strange ALSA problem

Postby Husse on Sun Mar 15, 2009 12:52 pm

Well instead of solving the problem we could do a dirty workaround
Code: Select all
gksu gedit /etc/rc.local

Add alsa force-reload before the exit 0 statement
It will now be executed at every boot (last in the boot process)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: strange ALSA problem

Postby Soulprayer on Sun Mar 15, 2009 2:10 pm

hm, okay - thx.
Just a weird problem, maybe that needs a weird solution ^^
It will get dangerous when dumb people get busy!
Soulprayer
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 15, 2009 3:26 am
Location: Cologne, Germany


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Rea Lize, worldwidewilly and 34 guests