Video Driver will not stick upon reboot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Video Driver will not stick upon reboot

Postby jtr on Wed Apr 01, 2009 12:27 pm

Hi there,

I have installed a copy of Linux Mint 6 on a USB stick. I have some issues trying to enable the proper video driver. I get to the point of the driver being loaded and requiring a reboot to take affect thus enabling use of the visual effects.

When the reboot is complete and I try to change desktop visual effects it requires the driver to be loaded again. Upon checking the video drive in the hardware list it shows as inactive. It keeps going through this over and over. Is the issue because I'm using the USB instead of a full install?

I have managed to get persistent working.

I am fairly new to Linux so please be gentle :)

Jay
jtr
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 01, 2009 12:09 pm

Linux Mint is funded by ads and donations.
 

Re: Video Driver will not stick upon reboot

Postby draka on Thu Apr 02, 2009 7:48 pm

Hi ! I got the same problem.

The problem (from replied i got) it's because of the live cd only.

So here is my way to "fix" this : (Well, without install mint; also, i didn't search more about a better way, if you found one just write it!)
Note: One problem about this method, you must do it at each boot...
1- Before any mint loading keep TAB pressed until 2 lines come at the screen. The last one should be
BOOT:

Just press enter
2- Keep TAB pressed (
immediately after you pressed enter) again until a menu appear. At the bottom of the screen you may have something that look like that (check from the end of your line)
append file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.gz quiet splash persistent --
First you must replace
quiet splash
by
ro single
(you can't only add
ro single
because you couln'd do the next step because the menu will bug)
So now you have (for exemple)
append file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.gz ro single persistent --

Then just press enter
3 - Now you should get a blue and grey menu, i don't remain exacly the option you should select but it something like "root terminal".
4 - Ok now you should get a console with the root access, type
cd /etc/X1/
ls xorg.conf.*

If you are in a real persistent mode, you should see some line that look like
xorg.conf.<some number (in fact this is the date; <year><month>...)

Then do a
cat xorg.conf.<a number from the list of file from the ls command>
on every file listed by the ls command.
We search a file that have many line (more than ~20), about (or more than a screen). In fact, we look for a file where you can't find "Defaut <something>" section. (If you have some "Default" section but have also other kind of section (or option like the adresse of your graphic card (PCI:0:0), your resolution,...) you probably found a good xorg.conf for the next step)

When you got one file like that you just do
rm xorg.conf
cp xorg.conf.<the number from the file where you find sections other than "Default" xorg.conf

Tips: You could also rename xorg.conf.<number> for something like myxorg.conf, so in the futur reboot you will be able to skip the ls and cat step, do the rm but then only
cp myxorg.conf xorg.conf
)

then just type
startx


Now your driver should be loaded and have your mint desktop ready !
draka
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 16, 2009 5:42 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 26 guests