set up wireless to start at boot? SOLVED

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

set up wireless to start at boot? SOLVED

Postby drum on Fri May 04, 2007 10:00 am

I can get wireless connection by running wlassistant as root but how do I set it up to start automatically at boot?
Your help will be appreciated
Thanks
:D
Last edited by drum on Sat May 05, 2007 6:34 am, edited 1 time in total.
drum
Level 1
Level 1
 
Posts: 18
Joined: Thu Dec 21, 2006 7:55 am
Location: Australia

Linux Mint is funded by ads and donations.
 

Postby Boo on Fri May 04, 2007 10:17 am

mintmenu --> admin --> networking

pick the wireless device, properties, enable.
set settings...

and hay presto.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby drum on Fri May 04, 2007 8:13 pm

Thanks Boo,
I don't think I was clear enough. Newbie :-)
After I boot up I have no wireless connection so in Gnome I go to wlassistant in Apps/Internet and open it and it tells me I have to be root, so i go to terminal as root and type wlassistant and it comes up and connects to my Netgear router just fine. I close it and that's it OK.
I did what you said and the only "enable" checkbox is to enable roaming mode.
Netgear is listed there but the checkbox for it is greyed out so I can't set it.
I hope this is all clear.
Thanks for your help
:)
drum
Level 1
Level 1
 
Posts: 18
Joined: Thu Dec 21, 2006 7:55 am
Location: Australia

Postby Boo on Sat May 05, 2007 5:37 am

you can change it from roaming to use a default/set wireless network.

un-tick roaming and set a static wireless network.
you can then save that network setup as a location then.
you can setup each wireless network (and wired) as a seperate location.

there is another way using network-manager but I first need to test something on mint.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby Boo on Sat May 05, 2007 6:20 am

alright with the previous method make sure the interface is ticked in the network window.

now for a better way (maybe), this is the way i had to setup wireless networking in fiesty.

this is how to setup network-manager which is the network icon next to the clock.

save your network interfaces file.

sudo cp /etc/network/interfaces /etc/network/interfaces.save

edit the interfaces file, remove any line that is not for the loopback interface lo. this should leave the first 2 lines.

gksu gedit /etc/network/interfaces

now you can restart the network daemon or just reboot.

now you can setup your network via network-manager (network icon next to the clock) by left clicking on it.
then choose connect to other wireless network.
then setup via the gui...

when you close the gui you will be asked to enter a password (new) for the network-manager.

then hay presto network setup, then the network icon changes to a sign strength icon.

BTW if you now look at admin network gui all the interfaces are not active and set to roaming.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby drum on Sat May 05, 2007 6:33 am

Hi Boo,
The first way you told me worked fine thanks.
I unchecked roaming mode and set my essid and network password and rebooted and it connects automatically.
I'll keep your more advanced way as a reference for the future.
Cheers mate. where abouts in OZ are you?
Regards
:D
drum
Level 1
Level 1
 
Posts: 18
Joined: Thu Dec 21, 2006 7:55 am
Location: Australia

Postby desertViking on Sat May 05, 2007 11:38 am

Boo wrote:this is how to setup network-manager which is the network icon next to the clock.
(sorry for hijacking this post) Somehow I lost this applet from the task bar, and I cannot find it to add back from the add applet dialog. Do you know how to recover it?
desertViking
Level 1
Level 1
 
Posts: 17
Joined: Sat Mar 31, 2007 1:48 pm

Postby Boo on Sat May 05, 2007 9:45 pm

you need network-manager and network-manager-gnome installed.

then right click your gnome panel and add to panel, choose network monitor.

I hate how the same application is call different things in different places.

also network-manager does not work correctly (or at least differently) if you dont have only lo interfaces in the /etc/network/interfaces file.

network manager uses the keyring manager for encrypted networks ie wireless.

now that i have totally confused you I'll leave.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: all41, Bing [Bot], Google Adsense [Bot], Mute Ant and 30 guests