[SOLVED] I cannot... open executable files!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] I cannot... open executable files!

Postby Hetor on Mon May 18, 2009 12:05 pm

Whenever I try to open an executable in nautilus, it says that there's no program to run them. I've tried to do that through terminal, but it says "permission denied", even tried running as root. Please help me!
Last edited by Hetor on Mon May 18, 2009 12:26 pm, edited 1 time in total.
Hetor
Level 1
Level 1
 
Posts: 7
Joined: Mon May 18, 2009 12:02 pm

Linux Mint is funded by ads and donations.
 

Re: I cannot... open executable files!

Postby rohedin on Mon May 18, 2009 12:11 pm

In the terminal you need to 'chmod' the file so it is executable.
Run this command before starting it:
chmod +x ./nameoffile

+x means that it can be executed.
rohedin
Level 1
Level 1
 
Posts: 3
Joined: Mon May 18, 2009 12:08 pm

Re: I cannot... open executable files!

Postby Hetor on Mon May 18, 2009 12:14 pm

I have tried to do that before posting, the file were allowed to execute and was readable. By the way, it started happening after I installed WINE. First it made that ALL executable files should open through WINE, including linux binaries. So I thought it's a good idea to remove WINE, so did I, and now I have this problem :(
Hetor
Level 1
Level 1
 
Posts: 7
Joined: Mon May 18, 2009 12:02 pm

Re: I cannot... open executable files!

Postby rohedin on Mon May 18, 2009 12:17 pm

Sorry, I'm a tad confused. Are you trying to open a Windows or a Linux binary here?
rohedin
Level 1
Level 1
 
Posts: 3
Joined: Mon May 18, 2009 12:08 pm

Re: I cannot... open executable files!

Postby Hetor on Mon May 18, 2009 12:18 pm

Linux binary. All of them don't work.
Hetor
Level 1
Level 1
 
Posts: 7
Joined: Mon May 18, 2009 12:02 pm

Re: I cannot... open executable files!

Postby rohedin on Mon May 18, 2009 12:21 pm

So when you run it from the terminal like:
./whatever
what error message do you get?
Also make sure the file is definitely owned by you with:
chmod 755 ./whatever
rohedin
Level 1
Level 1
 
Posts: 3
Joined: Mon May 18, 2009 12:08 pm

Re: I cannot... open executable files!

Postby Hetor on Mon May 18, 2009 12:26 pm

I've solved my problem. It was caused by incorrectly mounted partitions. I've edited my fstab so now everything works fine. Sorry for wasting your time.
Hetor
Level 1
Level 1
 
Posts: 7
Joined: Mon May 18, 2009 12:02 pm

Re: [SOLVED] I cannot... open executable files!

Postby emorrp1 on Mon May 18, 2009 12:50 pm

As further explanation for anyone who finds this thread because of a similar problem: this often occurs when trying to run executables from external USB disks. This is a safety feature to prevent malicious programs from being easily run. The solution as Hetor posted is to edit the fstab, but he didn't mention what you have to change: you have to add the "exec" mount option.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], JeremyB, UgoRipley and 31 guests