Touchpad Sensitivity and xorg.conf

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Touchpad Sensitivity and xorg.conf

Postby Lancaster on Mon May 18, 2009 7:52 pm

I'm totally new to Linux, I randomly installed Mint today, and I like what I see so far.

The biggest problem I'm having is with my touchpad. The sensitivity is far too low, only crossing about 5 in of my screen, when I would rather have a single swipe cross the entirety of the screen. The mouse pane in the preferences seems to have no effect on the touchpad, the sensitivity doesn't change at all no matter where I move the slider. I did some searching and found that I need gsynaptic to change the touchpad settings. I installed it using the terminal, and I now have a touchpad pane in the preferences. The instructions that I found said that I need to add a line of code to xorg.conf, which I found. My problem is that my touchpad is not listed in xorg.conf.

Code: Select all
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
   Identifier   "Configured Video Device"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection



That's it. Here are the instructions I am supposed to be following:


Now we’re going to break out Gedit, our graphical editor and make a quick change to your xorg.conf file

gksudo gedit /etc/X11/xorg.conf

Once in there, find the section that looks like this:

Section “InputDevice”
Identifier “Synaptics Touchpad”
Driver “synaptics”
Option “SendCoreEvents” “true”
Option “Device” “/dev/psaux”
Option “Protocol” “auto-dev”
Option “HorizScrollDelta” “0″
EndSection

If it’s not already there, add the following line below the HorizScrollDelta line and above EndSection:

Option “SHMConfig” “on”



What's up with my xorg.conf?
Lancaster
Level 1
Level 1
 
Posts: 1
Joined: Mon May 18, 2009 7:40 pm

Linux Mint is funded by ads and donations.
 

Re: Touchpad Sensitivity and xorg.conf

Postby Husse on Wed May 20, 2009 6:23 am

You did not tell us which version you installed but I guess Felicia
xorg.conf is no longer used for I/O configuration - it is to disappear in the long run
Create a file (on the Desktop) called touch.fdi with the following content
Code: Select all
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
       <merge key="input.x11_options.Protocol" type="string">auto-dev</merge>
       <merge key="input.x11_options.HorizScrollDelta" type="integer">0</merge>
       <merge key="input.x11_options.SHMConfig" type="integer">0</merge>
    </match>
  </device>
</deviceinfo>

The 'Option “Device” “/dev/psaux”' is not needed as far as I understand
You can clearly see the similarity with the Section “InputDevice” you posted
Once the file is done it has to be moved to the right location
Open a terminal on the Desktop (if you created the file on the desktop) and
Code: Select all
suod mv touch.fdi  /etc/hal/fdi/policy/touch.fdi

It's enough to unplug and plug back in but you can't do that so you have to restart X
Close and save any open application - then Ctrl+Alt+backspace
If this is the right options then it will be OK after that
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], thrib and 18 guests