Workspaces problem **Solved**

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Workspaces problem **Solved**

Postby Ozzyberto on Fri May 29, 2009 8:14 pm

I did a little searching and found that theres a difference between viewports and workspaces, but I've been unable to work it out.

I installed Linux Mint 7, and as I started switching workspaces through the keyboard shortcut I assigned in the CompizConfig Settings -> RotateCube menu, I noticed that they all had the same windows on the task bar, they were just minimized.
So I tried right-clicking one of the windows title bar and choosing Move to Another Workspace -> Desk 2 because I remembered that each workspace should have its own windows, or at least that's how it worked when I was using Linux Mint 6..

As expected that window immediately dissapeared, but as I switched to what I thought was desk 2 or workspace 2 (using the keyboard shortcut), there were only the same window titles I had in the task bar, except for the window I had moved.

I added a workspace switcher to my task bar and by switching with it to Desk 2 I found that same window I had moved before; I realized these workspaces were working as I remembered, but my keyboard shortcuts just aren't using them, I tried changing them in the CompizConfig Settings, and in the Preferences -> Keyboard Shortcuts menu, but got nowhere.

So this is my question:
How do I get to access those workspaces through keyboard shortcuts?

btw I like having Compiz enabled more than I actually need the workspaces.

Thank u in advance for any help you might provide =)
Last edited by Ozzyberto on Fri May 29, 2009 9:16 pm, edited 1 time in total.
Ozzyberto
Level 1
Level 1
 
Posts: 2
Joined: Fri May 29, 2009 7:47 pm

Linux Mint is funded by ads and donations.
 

Re: Workspaces problem

Postby richyrich on Fri May 29, 2009 8:51 pm

When you right click on a minimised app in the panel, you can choose by radio button. If you choose to have them "Only in this Workspace" they will only show in the workspace that they were minimised. If you choose "Always in Visible Workspace" they will show on the panel in all workspaces.

The workspace switcher in the panel should be set to the same as in Compiz, General Settings, Desktop Size (4 horiz, 1 vert, 1 desktop, for mine)
right-click the switcher, preferences; 4 columns, 1 row.

Hope this helps,
regards, Richard
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Workspaces problem

Postby Ozzyberto on Fri May 29, 2009 9:15 pm

richyrich wrote:When you right click on a minimised app in the panel, you can choose by radio button. If you choose to have them "Only in this Workspace" they will only show in the workspace that they were minimised. If you choose "Always in Visible Workspace" they will show on the panel in all workspaces.

The workspace switcher in the panel should be set to the same as in Compiz, General Settings, Desktop Size (4 horiz, 1 vert, 1 desktop, for mine)
right-click the switcher, preferences; 4 columns, 1 row.

Hope this helps,
regards, Richard


I had made sure I had selected "Only on this Workspace", however changing Compiz -> General Options -> Desktop Size to your values solved it =D (I had it on 1 Horizontal, 1 Vertical and 4 Desktops).

Thank you very much! =)
Ozzyberto
Level 1
Level 1
 
Posts: 2
Joined: Fri May 29, 2009 7:47 pm


Return to Newbie Questions

Who is online

Users browsing this forum: ace_N_kelly, gene, SammyD and 30 guests