Useradd in Cassandra

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Useradd in Cassandra

Postby Steve on Thu May 17, 2007 3:45 pm

I'm sorry to be vague here , but i'm a newbie in need of help. got Cassandra installed , but cannot add users. Read forums and tried "sudo su" commands and still got nowhere. What do you need to know in order to suggest something? Please forgive my ignorance but i will attempt to listen and learn. Many thanks Steve
Steve
Level 1
Level 1
 
Posts: 6
Joined: Thu May 17, 2007 3:38 pm

Linux Mint is funded by ads and donations.
 

Re: Useradd in Cassandra

Postby scorp123 on Thu May 17, 2007 4:06 pm

Steve wrote:I'm sorry to be vague here
Well ... for starters: What were you trying to do?? What did you want to achieve? And what precisely did you do, e.g. what did you click on, what commands did you type, and what error messages did you get back? :D
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Useradd in Cassandra

Postby Steve on Thu May 17, 2007 6:13 pm

Firstly , thanks for the quick response. As stated i'm a newbie and was wishing to try linux and get away from the Microsoft upgrade cycle and incurred expenses. From what i have read and understand , each user has a seperate account and access from root for security purposes. I was trying to create an account for myself and my daughter. Information from this forum said to open a terminal console and "sudo su" to add user and create password. When i logged out and attempted to login and test my daughter's account i recieved the following messages:-

User's $HOME/.dmrc file is being ignored. This
prevents the default session and language from being
saved. File should be owned by user and have 644
permissions. User's $HOME directory must be owned
by user and not writable by other users.


I then clicked OK button at the bottom of this message and got:-

Your session only lasted ten seconds. If you
have not logged yourself out , this could mean that
there is some installation problem or that you may be
out of diskspace. Try logging in with one of the failsafe
sessions to see if you can fix this problem.

I tried re-installing to check (i know i may not need to , but i'm on a learning curve) but i still get the same result at this point. Any pointers will be gratefully accepted. Regards. Steve
Steve
Level 1
Level 1
 
Posts: 6
Joined: Thu May 17, 2007 3:38 pm

Postby Boo on Thu May 17, 2007 7:00 pm

first do not use "sudo su" unless you really know what you are doing. ie Don't. :)

In general do not use a terminal window, you should be able to do everything using a GUI. GUI's use sudo if the task they are doing needs admin access and will ask you for a password.

When you installed you would have created an initial user which i expect is your account. this accounts' username was added to the sudoer list making it an administration capable user. ie you can create users, install software etc.

To add another account/user goto mintmenu-->administration-->users and groups.
or goto mintmenu-->config center--> administration --> users and groups.
Enter your password when asked for one.
Now if you see the user name you created in the terminal (the not working one) highlight it and delete it.
In the GUI click on the add user button, fill out required fields and click OK.
exit the GUI
Logout and login as the new user.

I hope this helps.
Remember the GUI is your friend.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: Useradd in Cassandra

Postby scorp123 on Thu May 17, 2007 7:11 pm

Steve wrote: sudo su
... That command switches into a root shell which is dangerous!! Especially if you don't really know what the commands do you type in there!!. It does not create anything in the best case and in the worst case it creates one hell of a mess (especially when you enter commands you don't yet understand ...). Either I am misunderstanding you here or you did not write precisely enough what you did. Sorry to say so.

Steve wrote: I was trying to create an account for myself
You should already have one, e.g. when you installed? Weren't you asked to provide a username?

Steve wrote: and my daughter.
You can do that via the "Preferences" menu if I am not wrong? (in GNOME)

Steve wrote: File should be owned by user and have 644 permissions.
OK, can you please open a terminal and give me the verbatim output of the following command (please copy & paste: highlight the stuff with the left mouse button, then go over to the terminal window, and hit the middle mouse button or mouse wheel):
Code: Select all
cat /etc/passwd
... This will show me what user accounts are present on the system or not (most are standard accounts present on everyone's system which are used by some background tasks; you don't need to be worried about them). Don't be misguided by the name ... no password will be shown here. The passwords are stored in a heavily encrypted form in another file only root has access to ( /etc/shadow ... if you want to take a look).

Sometimes people are told on forums never ever to reveal their passwords to anyone ... that's absolutely true. But then again, that's not what I asked you here, OK? :wink:

As for permissions: Normally the command for fixing a files permission is chmod (short for "change mode"). I am not really sure what you did on your system and what user account you used to get that error message, but if you want to follow the error message's suggestion, then the command sequence to fix the error would be, e.g.
Code: Select all
sudo su -
cd /home/of/affected/user
chown affecteduser .dmrc
chmod 644 .dmrc
exit


Steve wrote: i still get the same result at this point.
I am still not really sure about the "adding an account for my daughter part" ... Can you elaborate more what precisely you did there? Because "sudo su" really just changes into a root shell ... It would be more interesting to know what you did after that step :wink:

.
.
.
.
Last edited by scorp123 on Thu May 17, 2007 7:17 pm, edited 1 time in total.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 on Thu May 17, 2007 7:15 pm

Boo wrote:first do not use "sudo su" unless you really know what you are doing. ie Don't. :)
I absolutely second that :D
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 on Thu May 17, 2007 7:28 pm

sudo = short for "SuperUser do" ... e.g. do something as the God-like superuser "root". Example:
Code: Select all
sudo poweroff
... will poweroff a system.

su = short for "Switch User" ... e.g. change into someone else's user account inside a shell session. Example:
Code: Select all
su - jake
... will ask for password of user "jake" and upon successful login all following commands will execute as "jake" and with jake's priviledges. Not telling the system which user precisely you want to switch into will assume that you mean to switch into root's account:
Code: Select all
su -


Both commands combined:
Code: Select all
sudo su -
... mean translated into English: "SuperUser do: switch user into root's account!"

If you don't know what you do, you should perhaps not use that command unless someone with more knowledge tells you to do it (e.g. in case you have to fix an unexpected problem ...).

Nontheless I hope this small explanation helps you to understand those "cryptic" commands better :wink:

BTW, there are manual pages to every command.
Code: Select all
man sudo
man su
So if you're not sure about what a shell command does, it won't harm to check the manual pages :wink: (use cursor keys, Page Up and Page Down to navigate; press Q to exit from a manual page).
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Useradd in Cassandra

Postby Steve on Thu May 17, 2007 7:32 pm

We now have two user accounts set up. Thanks very much for your troubles. The next stage is for me to get away from this machine and set up wireless connection on Mint box. Can you aim towards preparatory reading? Whatever your answer , i hope i can return this favour at some point in the future. Regards. Steve
Steve
Level 1
Level 1
 
Posts: 6
Joined: Thu May 17, 2007 3:38 pm

Postby Boo on Thu May 17, 2007 7:57 pm

read the sticky posts in the wireless section first.

and use the search function if you hit troubles.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Useradd in Cassandra

Postby Steve on Fri May 18, 2007 7:24 am

Some replies came in after i was able to achieve a solution , so i just want to thank everyone who helped by replying. I apologise for any inaccuracy of post caused by my lack of experience , but this will improve , as will my linux use thanks to people like yourselves. Kindest regards. Steve
Steve
Level 1
Level 1
 
Posts: 6
Joined: Thu May 17, 2007 3:38 pm

Postby Husse on Fri May 18, 2007 12:11 pm

You are welcome (goes for all "Minties" in this post, but I haven't asked them :))
Remember it's only the first user that can use sudo. A very good way to stop nasty things happen in your kids account
(or your wifes/husbands :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Cogar, Debroyston, jez.two and 37 guests