sharing folders

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

sharing folders

Postby fossfollow on Wed Jul 08, 2009 4:23 pm

Just wondering if I share a folder with read and write permissions for group, owner, and others does that mean anyone on the same wireless network can see and edit my files? (I am doing this to share with a windows guest in virtualbox)
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Linux Mint is funded by ads and donations.
 

Re: sharing folders

Postby altair4 on Wed Jul 08, 2009 4:36 pm

You don't have to actually "share" the folder in the Mint host to be accessible in the Windows guest in VBox.

Once you create the Windows guest go to Settings > Shared Folders > Add new shared folder in the VBox App itself. It's a "virtual" share. And there you define it to be writeable or not. It won't change the permissions of the actual host folder.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Re: sharing folders

Postby fossfollow on Wed Jul 08, 2009 4:57 pm

hmm, I tried doing it that way, and I could never see any folders. The only way I could see a folder was by sharing it...
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Re: sharing folders

Postby altair4 on Wed Jul 08, 2009 5:01 pm

Did you install guest additions?

On a Windows guest once the Windows OS boots:
Devices > Install Guest Additions on the top task bar.

EDIT: Forgot Something: First you have to mount the virtual CDROM that holds the Guest additions:
Devices > Mount CD/DVD-ROM > CD/DVD-ROM Image > VBoxGuestAdditions.iso > Select
Actually it should autostart the Guest Addition install once you mount it
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Re: sharing folders

Postby altair4 on Wed Jul 08, 2009 7:07 pm

Well. I've got to pack it in for the day. If even after you have installed guest additions you still can't get VBox Shared Folder to work there is something seriously wrong with your VBox install I think.

But to answer your original question:
Just wondering if I share a folder with read and write permissions for group, owner, and others does that mean anyone on the same wireless network can see and edit my files?

The answer is yes. But only if you created the share enabled with guest access. If you didn't then they will be able to see that you have a share but they won't have access untill they provide a unsername and password.

If you prefer the simplicity of enabling guest access there is a way around this problem and it relies on the fact that the Guest in VBox has a fixed ip address. To find the Windows guest ip address boot into the virtual Windows and:

Open Command Prompt
Type ipconfig

In the Mint Host

Press Alt+F2
Type gksu gedit /etc/samba/smb.conf
Add the following line in the [global] section of that file:
Code: Select all
hosts allow = 127.0. 10.0.2.15

Change 10.0.2.15 to match the actual windows ip address.

Save the file

Open Terminal
Type sudo service samba restart



What the addition to smb.conf will do is restrict network access to your Mint shares only to the VBox guest. If at some later time you need to expand access to select others on your home network you can always add more to that line:

hosts allow = 127.0. 10.0.2.15 192.168.0.100 for example
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Re: sharing folders

Postby fossfollow on Thu Jul 09, 2009 10:21 pm

thanks for the advice. i'll give it a try tomorrow and post back here. I definitely installed the guest additions. I spent 2 days trying to get the folder to show up and I could not get it to work. I tried reinstalling the guest additions at least 3 times, and also trying to mount the share from the command line in windows. no luck. i tried everything i could find on the internet in any forums. its possible that there is something wrong with my install, but since vista is such a huge pain in the ass to set up, i would rather not reinstall it.
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Re: sharing folders

Postby altair4 on Fri Jul 10, 2009 8:05 am

You know you really should try to get the VBox shared folder to work. It's probably the greatest strength of VBox that it has this internal mechanism to share folders between guest and host. It's vastly more secure than anything you attempt with VBox's Bridge networking that you're using to have full networking between host and guest. Then you could go back to the default NAT networking mode in VBox.

Did you install VBox from the Mint Repos or did you install the deb yourself?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Re: sharing folders

Postby fossfollow on Fri Jul 10, 2009 9:11 am

I just tried setting it up again, and the folder doesn't show up on the network unless I enable guest access....I installed it from the Vbox repo which I added to my sources list, as per the instructions here http://www.virtualbox.org/wiki/Linux_Downloads
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Re: sharing folders

Postby altair4 on Fri Jul 10, 2009 12:01 pm

I don't know if you have the time or inclination for this but this is really beginning to upset me. Vbox shared folders should work out of the box and I don't understand why it's not working for you.

Tell me if you see something like the attached screen when you do this:

Open VirtualBox ( just the application - don't launch Vista )
Go to Settings > Shared Folders

You should see all of the folders that you told VBox to share.
Screenshot.png
Screenshot.png (45.35 KiB) Viewed 1040 times


EDIT: If it shows nothing then that's your answer. Just to see if your problem is on the Mint host side or the Windows guest side: When you click on the little folder on the right with a plus "+" sign another dialog box opens up. That's where you should be able to add a share:
Screenshot2.png
Screenshot2.png (10.75 KiB) Viewed 987 times

Are you getting errors anywhere in this process?

Also, what version of VBox did you install ?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Re: sharing folders

Postby fossfollow on Fri Jul 10, 2009 4:15 pm

Yea, the shared folder shows up properly in vbox..I've also tried re-adding that a bunch of times. I also tried sharing a folder outside my home folder just to see, but that doesn't work either. I don't know what else to try. I'm using 3.0, but before that I was using 2.2 and still the same problem...
fossfollow
Level 1
Level 1
 
Posts: 21
Joined: Sat Jan 10, 2009 3:27 pm
Location: Ontario, Canada

Re: sharing folders

Postby altair4 on Fri Jul 10, 2009 4:42 pm

This isn't going to make any sense but I found this in the virtualbox forums. As it turns out you're not alone. Have you tried to map the drive?

OMG Thank you soooo much. I was pulling my hair out over the shared folder issue. I had updated to the newest VBOX and was still not getting anywhere, it was the tip off that the shared folder showed up under Computer rather than Network that set me on the straight and narrow. If you get the newest VBOX and want to get the Shared folder to work, just Right-Click the Computer heading and Map Drive from there. All you need to do is leave the Drive letter as X: and in the blank below, instead of chosing a drop down, type: \\vboxsvr\share_folder_name of course replacing the share_folder_name with whatever you named the folder on your Host system.


I know you said you tried to mount it using the command line in windows and the "map drive" should be just a GUI to that same command but it seems to work for some folks. I think the poster went too far about leaving it at X: but mapping to the VirtualBox share name may be the way out.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6086
Joined: Tue Feb 03, 2009 10:27 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: austin.texas, Bing [Bot] and 27 guests