Black Screen

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Black Screen

Postby 160809 on Thu Jul 09, 2009 11:34 am

Hi All
Im new to Linux and have this problem.
I have installed Mint 7 x64 through mint4win, everything seems to have gone OK but when booting mint all i get is a black screen. I can get a terminal window by pressing Ctrl+Alt+F1. but dont know where to go from here.
I previously installed Mint 6 with no problems at all, could even get wobbly windows after installing the correct driver

I have a ATI HD4670 graphics card if this is any help.

Really want to mint 7 and not mint 6 as i have it on my laptop and just about getting used to it.

Thanks
Steve
160809
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 09, 2009 11:26 am

Linux Mint is funded by ads and donations.
 

Re: Black Screen

Postby johnnyj on Thu Jul 09, 2009 6:06 pm

I'm new to Linux myself. I've only used it for a few months. But I'll take a crack at this.

What happens if you log into the terminal window and type "startx"?

If that doesn't work, maybe X (the software that gives you a GUI in Linux) is configured wrong.

When you're in the grub menu, boot into recovery mode. Then select the "Xfix" option in the recovery menu. Then drop into a root terminal, and type "reboot". You probably won't need to reboot, but it might help.

If that doesn't work, boot into recovery mode, drop into a root terminal, type "dpkg-reconfigure xserver-xorg", then answer the questions. Then when it's done, type "reboot".

If that doesn't work, I'm out of ideas.
johnnyj
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 08, 2009 2:39 pm

Re: Black Screen

Postby 160809 on Fri Jul 10, 2009 11:03 am

Tried these ideas and still not working
startx - get error: server is already running on disply 0
xfix - get error: -bash xfix: command not found
160809
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 09, 2009 11:26 am

Re: Black Screen

Postby johnnyj on Fri Jul 10, 2009 2:42 pm

Well, that's weird. Maybe I can still help.

startx - get error: server is already running on display 0


If the X server is already running, maybe it's doing something. What happens when you type Ctrl+Alt+F7? This should bring up your 7th "virtual terminal" (or "TTY"), which is the one your X server runs in.
johnnyj
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 08, 2009 2:39 pm

Re: Black Screen

Postby johnnyj on Fri Jul 10, 2009 2:59 pm

By the way, you said you couldn't get to Xfix. You can get to things like Xfix by going into "recovery mode". This is how you go into recovery mode in Mint4Win:

    Start your computer.

    When you get that screen that says "Select operating system to boot", select Linux Mint and hit enter.

    Now it'll tell you to press Esc to see a menu. Hit the Esc key.

    Now you're in the grub menu. There should be an entry that has the words "(recovery mode)" at the end of it. Select that entry and hit enter.

    Now you should get a menu that has various options in it, like Xfix and drop to a root terminal. This is recovery mode.
johnnyj
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 08, 2009 2:39 pm

Re: Black Screen

Postby 160809 on Fri Jul 10, 2009 6:08 pm

Pressing Ctrl+Alt+F7 brings a black screen (no signal)
Tried recovery mode, xfix was selected but still no signal

I have tried to look at the xorg.conf file but there doesnt appear to be any ( sudo gedit /etc/X11/xorg.conf), maybe this is the problem?
160809
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 09, 2009 11:26 am

Re: Black Screen

Postby johnnyj on Fri Jul 10, 2009 9:56 pm

160809 wrote:Pressing Ctrl+Alt+F7 brings a black screen (no signal)
Tried recovery mode, xfix was selected but still no signal

I have tried to look at the xorg.conf file but there doesnt appear to be any ( sudo gedit /etc/X11/xorg.conf), maybe this is the problem?


You probably got the message:

Gtk-WARNING **: Cannot open display


when you tried to open gedit. gedit can't run in a terminal because it's graphical.

However, nano can run in a terminal. So you should be able to get to xorg.conf with:

Code: Select all
sudo nano /etc/X11/xorg.conf


Now, I don't know what any of the stuff in xorg.conf means. But I do know that if xorg.conf is messed up, you may be able to fix it with:

Code: Select all
sudo dpkg-reconfigure -phigh xserver-xorg


which will guess what to put in xorg.conf and put it in there.

If that doesn't work, the following may still work:

Code: Select all
sudo dpkg-reconfigure xserver-xorg


The difference between this and the other one is that this one will ask you questions instead of just guessing. I had a similar problem to yours a few weeks ago, and I was able to fix it this way.

After changing your xorg.conf, it's a good idea to reboot with:

Code: Select all
sudo reboot


If that doesn't work, then you might have a driver issue, which I don't know how to fix.
johnnyj
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 08, 2009 2:39 pm

Re: Black Screen

Postby 160809 on Sat Jul 11, 2009 2:54 pm

ive tried your suggestions again. but still not working.
i did however get to see the xorg.conf file with the nano command.
i re-installed mint 6 and printed off the xorg.conf file then compared it with the mint 7 version, they are both the same!!
so i dont think its a xorg problem. my thoughts now is the graphics card not being seen or not loading basic drivers during boot.

i think i'll give up with this now and go back to windows or maybe mint 6

thanks for your advise though.
i will continue to monitor this post to see if anyone else could possibly help
160809
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 09, 2009 11:26 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], BlackVeils, bruce.ober@gmail.com, felizcortez, mz5 and 43 guests